1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 a little trouble shooting help please

Discussion in 'Logic 8' started by rainguitar, Apr 30, 2009.

  1. rainguitar

    rainguitar Member


    I'm not sure where to ask this question but I thought I'd try here. I run Logic Pro 8 (8.02) on a new intel iMac that I purchased just before the newest ones came out. (24", 2.8, 4 gigs ram, OS 10.5.6). I use an Edirol FA-66 for audio capture and midi. On my previous machine (an older intel iMac running 10.4.11) I used the same interface with no problems. On the new machine, however, I get a lot of clicking and popping sounds both when I'm using Logic and when I'm using other applications. Apple techs have installed a new logic board and a new power supply on this mac and while these actions have solved other issues, the clicking and popping sounds remain. Roland has not released any new Leopard drivers for the FA-66, and the fact that the clicking and popping occurs outside and well as inside Logic seems to rule out a buffer setting issue. I've replaced the firewire cable and this had no effect. It seems a bit strange to me that the FA-66 would choose the moment I plugged it into a new computer to stop working properly. I also have G-Tech firewire hard drive plugged into this machine and that seems to be working normally, which I'm guessing would rule out a problem with the iMac's internal firewire card. Both that drive and the FA-66 were also plugged into my old machine and worked fine. I'm afraid of buying a new interface or fixing the current one, in case this is another issue but I'm not sure what else to try. Any ideas?


  3. Eli

    Eli Senior member

    Have you tried running the Edirol interface without the FW hard drive connected at the same time? It's worth a try. I know it's the same interface and drvie as before. But it's a different computer. Maybe the FW and/or USB ports work differently.

    Also, even though there are no new drivers, try trashing your old driver and prefs and reinstalling - just to make sure you are running from a fresh driver install and fresh prefs.
  4. rainguitar

    rainguitar Member

    Hi Eli,

    And thanks for the response. Unplugging the FW drive had no effect. The Fa-66 doesn't normally need drivers to work with a mac, the drivers on the disc that came with it are all for windows. I talked with a Roland Tech earlier today and he told me that the FA-66 should work and that there weren't any reported issues with Leopard. Where do I find the prefs I need to trash? I'm also going to try plugging the FA-66 into the old computer and see what happens, but that computer is running 10.4.11.

  5. Gio

    Gio Member

    Where do I find the prefs I need to trash? I'm also going to try plugging the FA-66 into the old computer and see what happens, but that computer is running 10.4.11.

    Hey Greg,
    Try using the iMacs mic/line input to feed logic, just to make sure its not Logic being silly.
    See if the pops get recorded and it they are output with the basic Apple hardware.
    Try the Edirol with Garageband, and/or Quicktime Pro see what the results are.

    Prefs will be in the main library>prefs
    and also in the User>Library>prefs

    Good Luck
  6. rainguitar

    rainguitar Member

    I'm pretty sure this is not a logic-specific issue simply because I actually get more clicks and pops when I'm not using Logic than I do with it. It particulary bad when I wake up the computer or simply switch applications but it also showed up when I was attempting to use automation with the Morph pad in FM8 within Logic, but it has yet to mess up an actual audio recording. It's pretty random except when I'm waking up the computer. Then it always happens. It seems to be related to changes quick changes in the amount of CPU the computer is using, like what happens when the computer goes from being dormant to active.
  7. rainguitar

    rainguitar Member

    It's the FA-66. I plugged it into my old computer and got all the same pops and clicks. Weird how it waited until I plugged it into the new computer before it started acting up. Oh well, get it fixed or upgrade? I just spent a ton of cash upgrading my computer, now I guess I'll have to shell out a little more. Expensive hobby this Logic stuff. Thanks to all who helped.

  8. Howard W

    Howard W Member

    How are you powering the device, external power supply?

  9. It might be that the new iMac you got is using a different FW chipset than the old one. Many FW audio interfaces are known to cause problems when running on any other than a TI FW chipset.
    Fwiw, I have an Agere FW chipset in my Macbook, and fortunately my M-Audio FW-410 is running fine with it, but I know that older MBs had the TI chipset built in, causing less troubles for most people.

    Unfortunately, Apple seems to go for cheaper and cheaper components in their "sort of low budget" machines (this is also very true for their onboard soundcards).

    I don't exactly remember the procedure about how to find out about your FW chipset anymore, it was something like booting in system analysis mode or so.

    - Sascha
  10. Markdvc

    Markdvc Administrator Staff Member

    There have indeed been reports that computers with Agere Chipsets seem to have problems with some FW devices (most notably RME, this has been discussed at length on their forum), but, as you acknowledge yourself, not with others, which I suspect makes it somewhat difficult to establish exactly what the cause of the problem may be. Greg now seems to think that his FW Device may be the problem itself.

    kind regards

  11. Well, not exactly. Let's put it this way:
    - TI chipset: Very little chances of running into problems.
    - No TI chipset: Quite higher chances of running into problems.

    Whether there's interfaces that perform as well with the Agere chipset isn't exactly the point. To me it's obvious that the most acknowledged and reliabe chipset has got to be the TI one. IMO each computer in the price league of what Apple offers should come with it.

    - Sascha
  12. Markdvc

    Markdvc Administrator Staff Member

    I don't want to drag this into OT areas, nor be seen to be defending something I don't even own, but "very little" and "higher" are firstly qualitative as opposed to quantitative, and secondly, presumably assumptions on your part, perhaps just based on reading user reports on the internet? They can be useful, but be careful which conclusions you may draw from them, even if for the best of reasons such as wishing to help others.

    As you well know, in order to solve a problem, it has to be identified, reproduced and acknowledged. The fact that some FW units (you yourself say you have one) work with these chipsets indicates that it may be difficult to ascertain exactly what the cause of the problem is. Anything else may be of a speculative nature. The fact that some FW interfaces work while others don't may be very relevant - not least of all if those whose interfaces work don't do anything or concern themselves about potential problems which the agere chipsets may very well have, so I would say that this is very much one of the points.

    That is all I am trying to say, and I'd rather leave it at that, especially as rainguitar (at least according to his last post) seems to have traced the source of the problem to his FW unit.

  13. Not at all. Of course, there's been numerous reports about anything else but a TI chipset being truly "audio-proof" on the net, but I already experienced the troubles myself, too (well, on two friends' machines).
    There's no myths or anything else being made up, it's just that licensing non-TI-chipsets (and actually putting them in) seems to be a cheaper alternative for many computer makers, including Apple. Just as Realtek and whatnot is what's usually used on the internal audio interface side of things. It's just the cheaper solution.
    I perfectly understand this from a business point of view, but it's not in the best interest of customers trying to use these things on a professional level.
    In addition it's absolutely wellknown that older Macs (G4s and G5s) usually performed quite a bit better in these areas (the same is probably true for earlier Intel Macs).

    Really, no matter how much you like Apple or not, there's quite some evidence that they *did* resort to some cheaper hardware components in a lot of areas, especially when it comes to their "entry" level models (namely Macbooks and iMacs). Unfortunately, I should add.

    - Sascha
  14. David51

    David51 Senior member

    Edirol drivers

    I had the same problem when I switched to Intel Core duo 10.5.6 from PPC 10.4.11 I looked at my Audio/MIDI set up and saw the check marked in the Box 'use PPC drivers' for the MIDI section. I went to the Roland web site and after much searching found that there were new[?] drivers for my USB UA-24 for use in 10.5, after correcting that-including unplugging all usb before installing drivers,it all worked again.

    I fear I still expect too much from MIDI and am praying the next up date will help this, or Snow Leopard,which I hear is a revamp of leopard whihtout the glitches.

    The PPC MIDI driver's,Core MIDI, where not much help, I had multiple projects I had to finish at a friend's house with headphones to mix.
    I have a Behringer FW audio interface which never worked until I foolishly tried to install a developer's kit [SDK24 ] to fix the FW chipset problem-all I got was a FireWire meltdown were nothing worked, fortunately I have a nephew who is a Mac repairman and he fixed it using iChat and desktop sharing.

Share This Page