PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Another Logic freeze problem

Discussion in 'Logic 9' started by drbrad98, Aug 16, 2012.

  1. drbrad98

    drbrad98 New Member

    Hoping someone can help. Logic 9 is crashing every time I go to bounce or freeze tracks on my current project. When I started the project, it was on a Mac running Snow Leopard, and I then upgraded that Mac to Lion shortly before selling it. I'm not sure if there were any issues at that point because I wasn't bouncing or freezing anything. I subsequently migrated everything over to a new Mac running Lion, which seemed a little buggy but generally OK until I tried bouncing or freezing. I've tried initializing and resetting preferences, loading a new ProKit (apparently the version I have is newer than the one on Apple's site), and even taking my tracks onto a new template--nothing helps. Any suggestions would be greatly appreciated. Thanks!

  3. georgelegeriii

    georgelegeriii Senior member

    you're sure you are waiting long enough? Logic has to load a number of bufferes before it starts to bounce, and depending on how many tracks, it could take a bit.

    Seems people think that they can bounce 20 or 30 tracks and it should start right away... I've seen it take a minute or 2 to even get going, depending on a number of factors (plug-ins used, drives, computer, ram amount).. so I would say wait a bit and see if it is actually working or not.
  4. drbrad98

    drbrad98 New Member

    No, it's definitely crashing--it either locks up and stays in position (I actually left it that way overnight last night, hoping maybe it might eventually come together), or Logic closes altogether and generates an error message.
  5. georgelegeriii

    georgelegeriii Senior member

    Great, at least it's giving you an error: what is it?
  6. drbrad98

    drbrad98 New Member

    I misspoke a bit: What it does is generates a large error report to send to Apple, not a numbered error message. I'd be glad to relay any of that if it would be helpful but I honestly have no idea what the important information is. I very much appreciate your taking the time to reply, by the way.
  7. georgelegeriii

    georgelegeriii Senior member

    Yea, I realize this... try this: you will se one of 2 things: a list that says thread X crashed, or one that says hung, and then a list that goes over and over again (if you take a close look, it will repeat the same list, that's what hung is).

    The crashed thread thing is great: you can see the info on the crashed thread, take a look at it, and see if Logic crashed, or if a 3d party plug-in was the reason...

    So.... a crash log can be VERY helpful when looking at an issue, if you know what to look for.

    So, was it a thread crash or a hang?
  8. drbrad98

    drbrad98 New Member

    A thread crash according to the error log. It says

    Thread 62 crashed with X86 Thread State (32-bit):
    eax: 0x00000000 ebx: 0x9649157e ecx: 0xe5a3cabc edx: 0x9504c9c6
    edi: 0xe5a3e000 esi: 0x00000006 ebp: 0xe5a3cad8 esp: 0xe5a3cabc
    ss: 0x00000023 efl: 0x00000206 eip: 0x9504c9c6 cs: 0x0000000b
    ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f
    cr2: 0x06ad60c0
    Logical CPU: 0

    Where should I be looking?

  9. georgelegeriii

    georgelegeriii Senior member

    Look down the list of threads..they should be listed, thread one: Logic , thread 2, uad-1 (or whatever plugins you have).. sorry for the long post but here goes:

    Below is a partial crash log. I edited out the data for the first 5 threads to save space, but left the system, app, and crashed event, so you could see exactly what is going on.

    You can clearly see that thread 6 crashed Logic, and that the plugin Predator was the bad guy in this case.

    So, in this case I'd either look for an update of the problem app or plugin, or send the crash report to the developer, and hope for some kind of an answer on what to do.

    So, there you go. Lesson 1 on how to see the problems when you get a crash report. It's not always this clear... Logic crashes all the time, all by itself, no clear reason why. But in this case, I can clearly see the problem, and then I can remove the problem plug-in, or at least I know what to be careful with when working, right?

    Process: Logic Pro [4351]
    Path: /Applications/Logic Pro Pro
    Version: 9.1.7 (1700.57)
    Build Info: Logic-17005700~1
    Code Type: X86-64 (Native)
    Parent Process: launchd [143]

    PlugIn Path: /Library/Audio/Plug-Ins/Components/Predator_64.component/Contents/MacOS/Predator_64
    PlugIn Identifier: com.RPCX.Predator.component
    PlugIn Version: 1.6.2 (1.6.2)

    Date/Time: 2012-07-20 18:58:42.826 -0700
    OS Version: Mac OS X 10.7.3 (11D50d)
    Report Version: 9

    Crashed Thread: 6

    Exception Type: EXC_BAD_ACCESS (SIGABRT)
    Exception Codes: 0x000000000000000d, 0x0000000000000000

    VM Regions Near 0:
    __TEXT 0000000100000000-0000000100c16000 [ 12.1M] r-x/rwx SM=COW /Applications/Logic Pro Pro

    Application Specific Information:
    objc[4351]: garbage collection is OFF
    abort() called

    Thread 0:: Dispatch queue:

    Thread 1:: Dispatch queue:

    Thread 2::

    Thread 3::

    Thread 4:

    Thread 5:

    Thread 6 Crashed::
    0 libsystem_kernel.dylib 0x00007fff89b34ce2 __pthread_kill + 10
    1 libsystem_c.dylib 0x00007fff865c27d2 pthread_kill + 95
    2 libsystem_c.dylib 0x00007fff865b3b4a __abort + 159
    3 libsystem_c.dylib 0x00007fff865b3aab abort + 192
    4 0x00000001003b1df6 std::_Rb_tree<short, std::pair<short const, CGRect>, std::_Select1st<std::pair<short const, CGRect> >, std::less<short>, std::allocator<std::pair<short const, CGRect> > >::_M_erase(std::_Rb_tree_node<std::pair<short const, CGRect> >*) + 98422
    5 libsystem_c.dylib 0x00007fff86614cfa _sigtramp + 26
    6 com.RPCX.Predator.component 0x00000001bc890171 APlugin::processMidi(long) + 929
    7 com.RPCX.Predator.component 0x00000001bc8040e0 AUPLUGINMIDIEvent(void*, unsigned int, unsigned int, unsigned int, unsigned int) + 224
    8 ??? 0x00000001b27d3400 0 + 7289517056
  10. drbrad98

    drbrad98 New Member

    OK. So here's the the initial identifier, and then the bulk of the specific report of thread 62:

    Crashed Thread: 62 Dispatch queue: CFPreferences Background Sync Queue

    Exception Type: EXC_BAD_ACCESS (SIGABRT)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000

    Thread 62 Crashed:: Dispatch queue: CFPreferences Background Sync Queue
    0 libsystem_kernel.dylib 0x9504c9c6 __pthread_kill + 10
    1 libsystem_c.dylib 0x9643bf78 pthread_kill + 106
    2 libsystem_c.dylib 0x9642cce3 __abort + 198
    3 libsystem_c.dylib 0x9642cc1d abort + 231
    4 0x003e50c9 std::eek:stream& TraceOutContainer<CEvs>(std::eek:stream&, CEvs, char const*, int) + 3839577
    5 libsystem_c.dylib 0x9649159b _sigtramp + 43
    6 libsystem_c.dylib 0x96411a57 memmove$VARIANT$sse42 + 154
    7 0x999ad995 dataCopyProperty + 149
    8 0x999ad8e2 CFWriteStreamCopyProperty + 146
    9 0x999fe7b4 -[CFXPreferencesPropertyListSourceSynchronizer writePlistToDisk] + 260
    10 0x999c33a3 -[CFXPreferencesPropertyListSourceSynchronizer synchronizeAlreadyFlocked] + 595
    11 0x999c30fa -[CFXPreferencesPropertyListSourceSynchronizer synchronize] + 522
    12 0x99a0650a __-[CFXPreferencesPropertyListSource synchronizeInBackgroundWithCompletionBlock:]_block_invoke_1 + 122
    13 libdispatch.dylib 0x92378fc9 _dispatch_call_block_and_release + 15
    14 libdispatch.dylib 0x9237a94f _dispatch_queue_drain + 224
    15 libdispatch.dylib 0x9237a7f4 _dispatch_queue_invoke + 47
    16 libdispatch.dylib 0x92379ffc _dispatch_worker_thread2 + 187
    17 libsystem_c.dylib 0x9643bb24 _pthread_wqthread + 346
    18 libsystem_c.dylib 0x9643d6fe start_wqthread + 30

    No specific plugin seems to be the issue, as I read this. How would you interpret this?

  11. georgelegeriii

    georgelegeriii Senior member

    "Preferences Background Sync Queue"

    Do you have an auto sync thing going anywhere? Maybe to the now none existant "" stuff like the network disc thing, or anything that has a timed sync, cue? Looks like whatever that is was the issue. I have an app, 1 password, and also Drop Box. They both will try and sync to their online servers... maybe something like that.

    But to be honest, that is a best guess.

    Looks like a generic crash. If Logic was crashing constantly, with this same crash report, I would spend time looking for anything related to sync on my system, and play around until I worked it out... but I also do tech support for a living... not sure I would suggest you try that, and if you do, and break something please don't blame me ;-)).
  12. drbrad98

    drbrad98 New Member

    Thanks very much--I'll see what I can come up with along those lines. You've been very helpful. Any if anything breaks, you're absolved! :)
  13. drbrad98

    drbrad98 New Member

    And the problem seems to have been Ivory, at least on this project. I've managed to salvage the data and get everything where it needs to be. Thanks again George for the help.
  14. georgelegeriii

    georgelegeriii Senior member

    My pleasure...

Share This Page