1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Anyone Successfully Using Logic 9 with Mackie Onyx Mixers?

Discussion in 'Logic 9' started by Ken Adams, Oct 1, 2009.

  1. Ken Adams

    Ken Adams Member

    Hi All,

    I've been waiting to update both to 10.5 or Snow Leopard, and to Logic 9, as my biggest outside client (whom I record live spoken word interviews for) has a Mackie Onyx 1620 mixer which I recommended (now with remorse). I use this with my Macbook Pro 2.2 core duo w/ 2gb RAM and Logic 8 running OS 10.4.11.

    I use for all my other work, my MOTU 828mkII which after 5 yrs. is still a reliable workhorse.

    The onyx card works pretty well most of the time, but is not officially supported by Mackie for Leopard, and the communications from Mackie have been abysmal to say the least on this issue. Suffice to say, they never in two years or more got a supported driver for 10.5.x and are now by their silence saying they are not supporting Leopard. I need a reliable recording solution for 1.5 - 2 hour talks. I've seen spotty info on the Mackie forums with some folks seeming to do okay with Leopard, some having big problems.

    So, I'm wondering if any LUGgers out there have the same or similar setup, have waded into Leopard or Snow Leopard and Logic 9 with the (now legacy) onyx cards.

  3. Ken Adams

    Ken Adams Member

    So no one out there uses a Mackie onyx setup???
  4. Ken Adams

    Ken Adams Member

    nobody at all?
  5. rick.b.martin

    rick.b.martin New Member

  6. Ken Adams

    Ken Adams Member

    Thanks Rick,

    I've actually got 4 posts on that thread already and have combed the forum for more definitive info. I wanted to post here to get outside of the Mackie forum itself. There seems to be some people using the onyx somewhat successfully (lots of reboots, problems like that) some people who can't use it.

    I wanted to ask here as it is a Logic group and I thought I'd get some direct experience from other Logic/Onyx users. My usage of the mixer and into logic is critical that I be able to record for 1.5 to 2 hrs straight w/out weirdnesses and crashes, glitches, etc.

    Thanks for the link though. Anyone else out there?
  7. jonblakey

    jonblakey New Member

    onyx 1640

    Hi, JB here I'm using logic with an onyx1640.
    all working fine
  8. Ken Adams

    Ken Adams Member

    Hi JB. I'd be interested in your experience if you had a moment. You are talking about the original Onyx cards not the Onyx-i, right? So what OS are you using and what version of Logic? If Leopard or Snow Leopard, did you have to downdate your Apple Firewire drivers? I did w/ 10.4.x right off the bat and am "stuck" so far at 10.4.11.

    Do you ever "lose" the interface to where Logic can't recognize it?

    I ask all this, as you may know, because Mackie only "supports" the Mac OS up to 10.4.x. There are all sorts of horror stories over on the Mackie Forums on the Onyx series of products. In my case, this is not my home rig, but my main client's and I have limited testing time with it, but have to jump in and record 1.5 to 2 hour events. So, I'm wanting to update to Leopard or Snow Leopard so I can upgrade Logic to v9, but am very wary of having problems in the middle of an event and lose the recording.

    Anyway, thanks JB for any more particulars you might have time to share.

  9. jonblakey

    jonblakey New Member

    i'm using the original onyx 1640
    snow leopard
    Not done anything with the firewire drivers, just installed logic and plugged my desk in, once i had bought the firewire converter lead for the new mac
    never have lost the interface
    Just come back from recording my band, two 50min sets, no problem
    brand new macbook pro and latest logic
  10. Ken Adams

    Ken Adams Member

    Alright then JB. That's hopeful, although still a bit scary with the troubles others seem to be having and Mackie's lack of "support" and complete silence on the issue.

    I'll run some tests and see how it goes.

    I really appreciate your input and time to JB and the others who posted on this thread. If you hear of anything new from Mackie, or have any other experiences on this, I'd love to hear about it.

  11. jonblakey

    jonblakey New Member

    All I did was check with digital village in birmingham, and all they said was I would need a new firwire lead to connect the mackie and the mac, maybe I have been lucky!!!!. but I don't think technology works like that!!
  12. Ken Adams

    Ken Adams Member

    Well that's great it's working for you, and hopeful that it might for me as well. Maybe mackie stuff works better on a different hemisphere.....

    Good luck w/ your band!:thmbup:
  13. ghost-life4land

    ghost-life4land New Member

    Hi Ken, i have Logic 8 that i use with an onyx 1620 on a dual 2gb G5.....

    I can't even upgrade to 10.4.11, i'm on 10.4.9, if i do upgrade the soundcard just ceases to work after one or two attempts. read on the mackie forum that it might be the firewire protocols in osx that changed, but i've given up asking mackie for help, as like you i've been practically begging them to do something about this for two years! but i heard that rolling back the firewire drivers for OSX may work? but i haven't had any joy... i ended up having to reformat the os when i tried. any help? ANYONE!?
  14. heykyleinsf

    heykyleinsf New Member

    you are not alone bud.. i rolled back to the firewire audio tiger driver...
    split results and tonite I am still going to try something further.
    I agree with somebody here that said it's not just a logic problem, not
    just a mackie problem, it's a mac problem. A lot of us can't believe that
    but it's super lame that mac has let this slide ever since leopard was
    released, and like you... i feel a little lost seeing so little outcry.

    OK...when I did the roll back drill to get my drivers back to 2.01 (see in
    system profile under extensions, scroll down to firewireaudio and you
    will see what firewire version you have). Weird for me, and I am on
    10.58 on my power station desktop. I have 2 macbookpros both 10.61.

    Anyway, got my onyx satellite through right away, but my 1620 mixer
    with the 400 card is still a know show. I am pretty sure that my fire
    wire sound went out around 10.54 or so... I know I did have my Onyx
    working past Leopard. The most disappointing and frustrating thing of
    all this is that just about everyone has a different situation all the way
    around so rhyme and reason is thrown right through the window!!

    But I think you have to remember it's a three prong problem and don't
    forget the mac part. Here's their solution below... I will see how it goes.
    Just a side note... I have been shopping firewire interfaces, and almost
    bought one when the onyx satellite popped up!!

    I hope I can help a lot of people if I can break through this mess... maybe
    get you closer..
    If you want directions how to back date your drivers, I can post that to.
    anyway... here is what mac says to do. I hope this forum keeps going,
    don't give up the fight!!!!


    Go into the folder Applications/Utilities and open the ‘Audio MIDI Setup’ app. Check the properties for ‘Built In Output.’ It might be set to 96KHz. Change it to 44KHz. Make sure the Default & System Output options re set to ‘Built-in Output.’ Next, where it says ‘Properties for:,’ make sure it’s set to ‘Built-in Output.’ Last, make sure the option for ”’Source:’ is ‘Internal Speakers.’

    2. Reset your PRAM.

    3. If you have a laptop with no sound, check your output jack on the side. Is there a red light on inside? If so, the analog/digital switch is stuck and the laptop won’t have any sound. Take a wood toothpick and insert it gently in the output sound jack and press gently downwards until the red light (LED) is off. You should have sound again. If you can’t get the light to go out, you will have to have it serviced. Contact Apple.

    5. Try cleaning your User and System cache files with a utility that’s compatible with Leopard, like Cocktail 4.0.1 or Leopard Cache Cleaner.

    4. Try deleting the following files after cleaning cache files:
  15. Ken Adams

    Ken Adams Member

    Thanks for the update, ghost-life4land, and for that possible apple reset, heykyleinsf.

    Yeah, everyone has a little different experience, which makes it so difficult to try to either replicate, or trust upgrading if your system is currently working.

    Regarding the mac part of the 3 prongs. I hear ya there, and I read that in the forums that it was a problem with the mac OS firewire, etc. My problem with that is still kinda like "so what?" There are so many other FW interfaces out there that somehow managed to run w/ Leopard and Snow Leopard. My MOTU 828mkII, (what 6 yrs. old?) runs like a champ so far. I know Mackie was trying to be all class compliant and all. I'm certainly no programmer or software/hardware design engineer, but it just seems that a firmware update, actually writing a driver, something could have been done to address this. And if not possible technically? Mackie should have communicated this directly and clearly to its users at the very least. And maybe given a nifty upgrade/crossgrade path to the new Onyx-i. (We'll see how well that line works out anyway... fool my twice and all that.) I dunno. I'm lucky my system seems to work okay so far I guess. I'm about to pull the trigger and upgrade to Logic 9 which means Snow Leopard.

    We'll see. Thanks again for posting that as a resource.
  16. heykyleinsf

    heykyleinsf New Member

    Mackie won't rush for this anytime soon. I am probably going to get an interface as well. Mackie may have had something up their sleeve, a little coincidental that leopard launches, then they drop support and discontinue for the i line. It is sleek, but criminey fxxk!! They expect the average band to cough up 2k for a mixer?
    It's greed. And I don't expect apple or mackie to ever address it. It leaves logic 9 users with mac systems and mackie boards out cold, and I really think there is at least some corporate greed element to this.
  17. gigazaga

    gigazaga New Member

    I have been running one of the new Mackie Onyx 1220i mixers with Snow Leopard, Logic 9.1 and PT LE 8.0.3 for about a day and a half. I wanted a setup where I could easily change between DAW software and also have some routing flexibility for screencasting.

    Initially, I was very disappointed because my computer seemed completely bogged down. But now I have figured out how to make it work, it does seem to be going more smoothly. This is still very early, so I might wind up returning it. Here is my configuration:

    MacBook Pro with Samsung SSD
    4GB RAM
    OSX Snow Leopard 10.6.2
    Logic 9.1 32 bit mode
    Glyph audio drive
    Euphonix MC Transport
    Apple 24 LED display

    Since I have only one FW port, I am running a FW800 to 400 cable from the computer to the mixer, then running FW400 from the mixer to the Glyph.

    I need to leave the mixer and drive turned off until the computer is booted when starting up. Then turn on the mixer, then the drive.

    It did not work well chained the other way. What I mean is running FW800 from the MacBook to the Glyph then running FW400 from Glyph to the Onyx i.

    So while I like what this mixer does, I am concerned about if it will be stable over the long haul. I will give it a few more days to determine if it will be going back.

    On the positive side, I really like having a real mixer and not having to shuffle yet another onscreen mixer. It also gives me the ability to run Pro Tools M if necessary. The only other similar option is the M-Audio NRV-10.
  18. gigazaga

    gigazaga New Member

    Just a follow-up to this. After experiencing several lock ups of OSX, I returned the mixer. Something about it makes it very sensitive to the order that things are powered on. I thought I could live with that, but it also got confused when I switched apps or changed the OSX preferences. This would require power cycling the mixer and that would lock OSX with the gray error screen. I tried to get help on Mackie's forum but there is nobody home there. The mixer when back. It is sad, I used to love Mackie products.

Share This Page