1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Audio imported from QT is always locked

Discussion in 'Logic 8' started by Eli, Apr 8, 2009.

  1. Eli

    Eli Senior member

    Hi All,

    I've got a bizarre recurring problem that I'm wondering if anyone can shed some light on. When I bring a quicktime movie into Logic and then use the "Import audio to arrange" option, the audio file always seems to be locked.

    When I try and make a destructive edit in the sample edit window, I get the message saying that I can't make changes because the file or volume is locked. I know I can reset the permissions on the file in the Finder, but if I instead quit Logic and immediately relaunch it - all seems to be fine.

    What's particularly odd is that when I am importing the audio, Logic copies the newly created file first to the project folder - as per the assets settings. So this problem isn't from the the audio coming directly from the QT. It is from the version of the audio file that's been copied to Logic's own project folder.
  3. Orren Merton

    Orren Merton Logic Samurai / Administrator Staff Member

    That sounds an awful lot like a bug to me...

  4. Eli

    Eli Senior member

    Yeah - to me too! Fortunately the workaround is fairly painless. I don't even have to futz around with the files in the Finder. Just quitting and restarting Logic seems to update Logic's relationship to it's own file that it just created.
  5. gdoubleyou

    gdoubleyou Senior member

    It could be a permissions issue, do a get info on the file. and look at the permissions.

    Also if you are importing from CD/DVD, sometimes the files are locked as part of the burning process.

  6. Eli

    Eli Senior member

    These files are coming from a Quicklime I've created myself using Screenflow. So there is no external media involved.

    It does seem like a permissions issue. It's just bizarre that it should be an issue in this specific circumstance. Especially since I have assets set to be copied to the the project folder. So, it's not even the audio from the QT that's the problem- it's the copy of it that Logic itself creates and places in the Project folder that is problematic. There is no logical reason for this to happen.

    But since when are permission problems solved simply by quitting Logic and relaunching it? It must be something else. This is a real mystery.......
  7. Orren Merton

    Orren Merton Logic Samurai / Administrator Staff Member

    Ba-dum-bum. :drm: ;)

    I doubt it's a permission issue for that reason. If it were a permissions issue, it would "stick." Even if it was Logic's extraction of the audio changing permissions, it would remain changed. It sounds like for some reason, when Logic extracts the audio, it trips some flag temporarily that causes the audio to seem locked until you re-launch Logic.

    Do you have any other software that can extract audio from QT movies? What about just saving out the audio using QT Pro? If you can extract the audio without using Logic and have it copy into Logic's project folder without appearing locked, that would be an even stronger indicator that you're running into some bug in Logic.

  8. jlproductions

    jlproductions Member

    IMHO this has to do with Logic's lock to smpte feature. When you import audio from quicktime to arrange it often locks it to smpte. it is easy enough to 'unlock' from smpte using key commands. However this is now buggy in logic and often drives me crazy. later if you try to insert or cut time, Logic will often starting locking other regions to smpte on it's own. There are bugs in here...
    but learn the lock/unlock to smpte commands and see if this helps..
  9. Eli

    Eli Senior member

    Hi Jamie - that was actually a good suggestion. The file in fact actually does default to being locked to smpte position when it is imported. But unfortunately that doesn't seem to be the problem.

    I just started a new project (new video) and imported the QT and had the exact same problem. Unlocking smpte position didn't make a difference.

    Orren, your suggestions make sense, but honestly - it's just way easier and less time consuming to just quit Logic once and restart it. The whole thing takes about twenty seconds - and then I'm done and can continue working. So, I probably won't bother at this point to try and trouble shoot it further.
  10. sonnykeyes

    sonnykeyes Senior member

    I just tried to reproduce Eli's problem, and was unable to. Even the locked file took destructive changes without problem.

    This reminds me of a problem I have had off and on since Logic 8 came out. On rare occasions when I try to perform a Time Machine function on a piece of audio, Logic will refuse because I don't have sufficient permission to perform that function, or words to that effect. I've checked to see if the Record Path is set to a locked disk, but it's not, and nothing, not even rebooting Logic will fix it. Then, a week later I try the same thing in a different song file, and no problem. Now, obviously that means something is funky in that particular song file, but it seems to happen to quite a few song files, and then to others...not.

    But, in concert with Eli's problem, it points to Logic (under certain circumstances) dealing with permissions in a way that is not intended.

    Sonny Keyes
    Ricochet Audio
  11. Eli

    Eli Senior member

    Hi Sonny,

    Thansk for taking the time to reproduce the situation on your system. It leads me to a hypothesis. Maybe it's that the videos in question that I have been using are coming from an app called Screen Flow. Maybe when I export the video from Screen Flow, it renders it in such a way that the audio file contained in it is locked. And then when Logic extracts it - it somehow recognizes these attributes. And since they aren't really locked - in the traditional sense that we all know of - the quitting - rebooting thing clears those flags ro tags, or whatever the hell they are. Anyway - it's just a theory.

    As far as the TP Machine randomly not wanting to perform on certain files, I get this as well. It's very annoying. Usually one of two things solves the problem for me. Either chaning the permissions on the file in the Finder (even though there's no reason the permissions should have neen wrong in the first place.) Or copying the file in the Finder to another drive temporarily, deleting the original, and then copying the version from the external drive back; and finally deleting the copy from the external drive (takes longer to write about it than actually doing it!.)
  12. Doug Zangar

    Doug Zangar Senior member

    Hey Eli,

    One suggestion (probably lame) is to bring audio to bin (Import Audio from Movie), not arrange window (Import Audio to Arrange) and drag it to arrange - curious if that would make a difference (doubt it, though).

    I've had plenty of SMPTE lock bug issues using Snapz Pro - haven't yet got into Screen Flow - how do you like it? (Other than the possible issue we're discussing.)
  13. Eli

    Eli Senior member

    Hey Doug,

    I'll try importing the audio to the bin first rather than directly to the Arrange Window next time. It's worth a try.

    FTR, I don't think this is specifically a smpte lock issue. Because even when I unlock it, the problem still persists.

    Screenflow is great. Its got tons of features I don't use. But just for the regular meat and potatoes things that you and I usually do with it, it's more flexible and enjoyable to work in than SnapZ Pro.
  14. dinerdog

    dinerdog New Member

    Eli, I've been trying to figure this out for a long time now. It does it in both L7 & L8 for me. I think it actually started a few years ago. Same thing. ANY Quicktime I'm working with, when I import the audio to the arrange page is ALWAYS locked. I use the page up/down key to lock and unlock regions, so I just hit that and move the audio till it lines up with the movie. Then I cut the audio on bar 1, so if I change the tempo it still always lines up with the movie. Perhaps someone at a Genius Bar could answer this one?
  15. jlproductions

    jlproductions Member

    My guess is that this is a hard drive issue not a Logic issue. I have a drive where the permissions are messed up (I need to enter my password just to copy something there) and according to Apple the only way to fix this is to reformat the drive...
  16. Eli

    Eli Senior member

    Interesting - these files do reside on a second internal drive that I use just for audio. And I know the type of problem of which you speak. Although I don't seem to have it on any of my drives currently.

    And to dinerdog - this doesn't seem to be a problem related to files either begin smpte locked or unlocked. That status doesn't seem to make a difference. The "locked" I am referring to is when the OS won't allow changes to be made to the file.
  17. leytonnz

    leytonnz Senior member

    i dont have experience with eli Ks problem but sonnys "dont have permissions thing with audio files" my workaround is by right clicking and saving it as a new audio file.

    this is particularly handy for apple loops.
  18. Pete Thomas

    Pete Thomas Administrator Staff Member

    I have also had the same issue for a while now. Also with a separate internal drive. I have been trying to find a way reproduce it consistently but no success yet.

    EDIT: it's not always from imported audio, I also get this sometimes with audio recorded directly in Logic.

Share This Page