PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Big Fat Hairy Bug!

Discussion in 'Logic 9' started by Eli, Mar 21, 2010.

  1. Eli

    Eli Senior member

    Hi All,

    I have this big fat hairy bug that I have been plagued with on and off forever now and it is really starting to BUG me:brkwl:

    I've never seen or heard of this bug on another system and am hoping someone can shed some light. Basically it's this: when I record arm a group of drum tracks and hit record, another track randomly gets muted. When I hit stop, the track un-mutes. Hit record again and it mutes itself. No there is no mute automation.

    Here is a short video showing the problem. I stop and start a few times and even switch the selected track in the group. No matter what, the track named "keys" always mutes as soon as record is engaged. And un mutes when the transport is stopped.

    Any ideas????
  3. Eli

    Eli Senior member

  4. Orren Merton

    Orren Merton Logic Samurai / Administrator Staff Member

    Wow...I've never seen that before. That's of no consolation of course. But it's certainly not common. Ironically, there's probably someone out there who has been wishing for a (controllable) mute on record functionality, and this is almost there!

    The best advice I can give is that since it's a MIDI track that is muting, I'd check to see if there is some sort of MIDI CC data or something being sent that is somehow being interpreted by Logic as a channel mute. I don't even know what MIDI message that would be, but you never know.

    If that comes up empty, do you have a control surface attached? If so, disconnect it, deinstall the drivers, restart your Mac, and see if the problem is gone. If it is, you know that it's an issue involving the control surface/driver/Logic combination.

    Hope that helps!
  5. Eli

    Eli Senior member

    I do have an MCU. But this happens even when it is not powered on. For example, when I recorded this video earlier, the MCU wasn't even on. But it's an interesting idea. I wonder if deleting the MCU definition from my controller setup window would effect the behavior. I'll try it next time.

    In terms of MIDI CC data being sent, you just gave me an idea. This seems to happen when I hit record from my qwerty keyboard. I'll check next time and see if it happens using the mouse in the transport bar.

    But how could hitting an asterisk keystroke on a keyboard be triggering a CC mute message?
  6. Orren Merton

    Orren Merton Logic Samurai / Administrator Staff Member

    Does the MCU use drivers? The drivers could be causing the problem, even if the device itself isn't on.

    Environment object (fader/transform/etc)? Act of God?

  7. TBPlayer

    TBPlayer New Member

    I also noticed in your movie that when the track mutes itself in the "arrange view" it does NOT mute in the "mixer view". :confused: Could it be there is a problem in the "environment"?

  8. Petrosil

    Petrosil Member

    This looks pretty normal to me: The Software Instrument is record enabled, though not yet in Live mode. You can see that from the red R in the record button. In Live mode (which will be enabled as soon as the track receives MIDI data) the entire button gets red.

    This means you are actually recording on both Audio and Software Instrument tracks. As there is already a region on the SI track, Logic automatically mutes the current content of the track. Otherwise you'll end up with a cacophony of all takes and the current input playing at the same time.

    Sorry to say that, but the bug seems to sit in front of the computer in this case:)


  9. daveyboy

    daveyboy Senior member

    OT question but: Is that the amplidude logic gui mod you have and if so is it perfectly stable? I thought I'd try it as it looks cool. Sorry about the bug.
  10. Jay Asher

    Jay Asher Senior member

    It looks to me like your Kick track is protected.
  11. Eli

    Eli Senior member

    Manfred, you're a genius. You nailed it! That was in fact exacly the problem. It never occured to me. I just tried it again and put the last used software instrument track out of live mode and that solved it. Than you! This has been bugging me for soooo long. I am so glad to finally have a solution:D

    Thanks to everyone else for their responses and input as well.

    To Orren:
    No, there are no drivers for the MCU. And my Environment was pristine. Physical Input to keyboard and monitor objects then to Sequencer Input. There was nothing customized in it at all.

    To TBPlayer:
    Yes, it was a track mute that was happening; not a channel mute. But again, nothing in the environment would have caused this.

    To Dave:
    Yes, that is the Amplidood mod. It is perfectly stable. But I am actually thinking of reverting back. I know this is not currently the popular opinion, but I actually find that I prefer the exponential scale metering in the mixer over the Sectional DB-Linear mode. And that mod doesn't work with the exponential scale.

    To Jay,
    I know the video resolution is pretty small, but that's the Q - Reference button that is in the track header. They are grouped and enabled for phase locked editing. There is no track protect buttons in the track header. And it is the keys track that was the problem anyway, not the kik.

    Thanks again to everyone for their input. And to Manfred - I am really glad that this is pilot error and not something else. That is the best possible outcome. Pilot error is the easiest to fix :)
  12. Colin Shapiro

    Colin Shapiro Senior member

    Eli, can you elaborate please. I have read and understand all references to Live Mode in the Logic Manual, but was wondering if you are doing something special here.
  13. Eli

    Eli Senior member

    Hi Colin,

    What's strange about this bug is that it seems to be intermittent. The problem occurs when I have been programming a MIDI track (software instrument) then go to record arm the drum group (audio tracks) and start recording. The last used MIDI track stays in live mode - meaning the R button on it is engaged. And because there is data on the MIDI track already, it is temporarily muted once recording begins.

    What's odd though is that it doesn't always happen. I can't quite figure out what specific circumstances dictate wether the last used MIDI track remains armed, or "live" or not. Because sometimes it's not an issue. Anyway, now that I know what the problem is, it's easy enough to deal with. Just make sure to un-arm - or take out of live mode- the last currently used MIDI track.

Share This Page