PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Broken in L9: Reindex apple loops from external drive

Discussion in 'Logic 9' started by iota, Nov 24, 2009.

  1. iota

    iota New Member

    Adding loops from an external drive in Logic 9 does not seem to work any longer. It used to work great in L8. Anyone have similar experiences? Know any work arounds? Is it a bug? If it's a bug I'll file it with Apple.

    Previously in Logic 8 it was easy to reindex loops on an external drive:
    (1) Delete the loop indexes from root/Library/Audio/Apple Loops Index
    (2) Use Finder to locate the loops on the external
    (3) Drag the loop folders into the L8 media browser.
    (4) L8 asks if you want to copy the loops or use them from their present location. Select present location intsead of copy locally.
    (5) L8 takes 5-20 minutes to build index of loops from external drive

    I have tried this procedure several times in L9 without success. Instead I get the following:
    (1) Delete the loop indexes from root/Library/Audio/Apple Loops
    (2) Use Finder to locate the loops on the external
    (3) Drag the loop folders into the L8 media browser.
    (4) L9 ask for my admin password.
    (5) Enter my password
    (6) I'm NOT asked if I want to copy loops locally or use them in their present location. Instead a reindex progress dialog comes up for 2 seconds then goes away.
    (7) In the end nothing happened. No loops copied, indexed, or anything

    There is only one way I managed to get loops into L9 but it is exactly what I'm NOT looking for:
    (1) In the folder with all my loops spotlight search ".CAF" (In this case want to reindex Apple content which is all CAF)
    (2) Make sure to click "show more" at the bottom of the search results.
    (3) Drag the search results to the loop browser.
    (4) L9 indexes them all right, AND also copies them to my user library! All 30 GBs worth. Definitely not what I want.

    In the end, I had to reinstall the Loops from the DVDs and specify an external location for them. (This whole mess got started when I tried to move the GarageBand and iLife loops to an external drive. The installer does not let you specify a location for them.)

    Just so you know I've done some homework:
    I've scoured other Logic forums and found these relevant threads that in the end did not solve the issue. They mostly seem to refer to Logic 8 which does not have this issue.

    @ LUG
    Thread 1

    @ Logic Pro Help
    Thread 1
    Thread 2
    Thread 3 this fellow seems to have a similar problem as I. He drags folders into the loop browser but nothing happens.

    @ Apple Discussions
    Thread 1
    Thread 2
  3. gdoubleyou

    gdoubleyou Senior member

    Try dropping the loops into Garage Band's loop browser.
  4. iota

    iota New Member

    Thanks gdoubleyou, I would try this if I still had GarageBand installed.

    If anyone else ends up trying this tip, please report your results to help future users!
  5. bresnark

    bresnark New Member

    Sadly, I don't have an answer to this but wanted to confirm Iota's issue. It's affected me too and it's a nightmare. I've actually stopped using loop now entirely. I never used them MUCH before, but it was nice to have the option...


  6. pfloyd714714

    pfloyd714714 Senior member

    I haven't yet purchased Logic 9. Experiences like this leave me wondering whether I should. When I read the initial post in this thread I asked about it at the Apple site. I only got one reply (as of this writing), but apparently not everyone is effected by this.

    Could anyone else weigh in with their experiences--good or bad?

  7. audioirony

    audioirony New Member

    The reindex dialog appearing for a short time and not doing anything seems to be a permissions problem.
    I had the same issue because the Apple Loops Index folder was owned by root.
    I changed permissions to be owned by me (admin account) and it worked.

    Just to be clear, I wasn't reindexing loops from an external drive - but I assume the index files are still written to your boot drive anyway - so it might work.

    I can't confirm if loops will be added in place or copied.

    The method I used to force Logic 9 to reindex files is documented in many other places - but a quick rundown is:
    1. open loop browser and search for a known stock loop - like 70s ballad drums.
    2. locate the actual loop in the finder and move it temporarily to the desktop
    3. go back to the loop browser and click on the loop.
    4. the reindex dialog appears - don't do anything yet
    5. go back to the Finder and move the loop back
    6. go back to the reindex dialog and click on reindex.
  8. DeeJay SchmeeJay

    DeeJay SchmeeJay New Member

    Thanks for this post, audioirony.
    You just saved my butt.
    Posts like this are priceless.

    Brilliant. :)

Share This Page