1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't find Legacy sounds in EXS24

Discussion in 'Logic Pro X' started by Hansverm, Jan 2, 2014.

  1. Hansverm

    Hansverm Member

    I have installed all additional content and had Logic 9 installed before installing X, but the legacy sounds do not appear in the preset list of my EXS24. How can I install these again?
  3. Colin Shapiro

    Colin Shapiro Senior member

    You should find Legacy Instruments in the Factory folder for EXS24.

    Have you downloaded all the content for 10.0.5?
  4. Hansverm

    Hansverm Member

    I was looking at a tutorial on MacProVideo and he showed a folder in the preset menu of EXS24 itself. He had an extra folder called 'Legacy Instruments', between 'Textures' and 'Garageband'. I have installed all extra content, including the Legacy libraries. One sound he used from that library was a Synth String> Mini Brightstrings.
    I had problems with missing legacy presets from Ultrabeat too, but these suddenly appeared after a while.
    I already tried refresh menu in the EXS24.

    Attached Files:

  5. Colin Shapiro

    Colin Shapiro Senior member

    On my system, the Legacy Instruments folder is not between Textures and Garageband like yours. In fact, both Textures and Legacy Instruments are inside the Factory Folder.

    Look here in the Finder:
    Macintosh HD/Library/Application Support/Logic/Sampler Instruments

    I have these folders:
    01 Acoustic Pianos
    02 Bass
    03 Drums & Percussion
    04 Keyboards
    05 Synthesizers
    06 Pop Strings
    07 Pop Horns
    08 Guitars
    09 Orchestral
    10 World
    11 Textures
    12 Legacy Instruments

    I haven't changed anything. This is what has been installed on my system by Logic.
  6. Hansverm

    Hansverm Member

    Hi Colin, thanks for your reply. I haven't got that folder on that location. How does this folder appear when you select a preset inside EXS24 itself? (just like the pic in my previous post).
  7. Colin Shapiro

    Colin Shapiro Senior member

    In the Library browser, it looks like this:

    I do have the MiniBrightstrings in there….
  8. Hansverm

    Hansverm Member

    Anyone knows how to download these Legacy Instruments on their own?

    Are they part of the 'Logic Studio 2 Compatibility Sounds and Instruments' in the 'Legacy and Compatibility' tab of the Additional Content'? I reinstalled this one, but to no avail.
    I have installed all other additional content too.
  9. madelefant

    madelefant Senior member

    This is completely goofed up on Logic Pro X. I have found ways to import older legacy content that isn't there in the downloads but it frequently is missing the samples. Even when setting the search preferences to all attached drives it never finds them, even though they are there.
  10. stv_collins

    stv_collins New Member

    Hansverm- This is just a hunch, but have you tried to use Disk Utility to repair permissions following your LogicX install? With other Apple software installations, the permissions can get mucked up, leading to unexpected behavior, such as failing to access files because the system doesn't think you have the correct privileges to do so. Easy enough to try...

    Like you, I installed LogicX on top of my previous installation (only recently removed Logic 9 application after verifying the new version was working on my old songs). I've been fortunate in not experiencing any problems. In fact, I have access to old (some non-Apple) instruments/samples dating from Logic6. The instruments are in the directory Colin mentioned earlier, and the samples are in Macintosh HD/Library/Application Support/Logic/EXS Factory Samples.
  11. tooloud

    tooloud Member

    I have a similar problem where I'm told that many Logic 9 .exs instruments are not valid .exs files. A close look at the app support folder shows the exs from V9 to be complete but without the associated sample files. I'm wondering if a complete install of LP9 from DVD will work or will I end up screwing up LPX content?
  12. Colin Shapiro

    Colin Shapiro Senior member

    You could try using Pacifist:

    It's a great app that allows to look inside installer packages and select only the sections you choose to install.
  13. tooloud

    tooloud Member

    I have Pacifist.... I'll try and be selective about dragging just the V9 stuff across without touching any X files. Thanks Colin.
  14. tooloud

    tooloud Member

    OK... solved it... what was missing was found in Logic 8 content on the LP9 discs. Who'd have thought it?
  15. tooloud

    tooloud Member

    a permissions reset on the exs and samples folder helped too.
  16. Colin Shapiro

    Colin Shapiro Senior member

    Thanks for the info - pleased you solved it.

    While it's all fresh in your head, you should file a report to Apple to mention this problem. Maybe they'll fix it and add back the old content in an update to Logic X?
  17. coffeemate

    coffeemate New Member

    Turns out the Legacy Instruments folder is not included in the download version of LP9 or LPX. They're just preset settings for the instruments, so not sure why they aren't there.

    Anyway, would you be so kind as to make zip that "Sampler Instruments/Legacy Instruments" folder and make it available to others with LPX? Or email me a copy?

  18. Omar17166

    Omar17166 New Member

    Hi tooloud!
    I'm suddenly up against a similar problem. I cannot see this folder "Legacy Instruments". I have the latest update of LPX, and all my additional contents are installed. So I think it is a similar problem to what you had and solved. You mentioned that you solved this by changing some permissions. Can you kindly explain how/which permissions? I mean can you see the folder "HD/Library/Application Support/Logic/EXS Factory Samples", but the permissions are wrong on it? Please elaborate.

    Thaanks in advance :)
  19. Omar17166

    Omar17166 New Member

    I hadn't pay attention to the dates. I've just realized this thread is almost 2 years old. Perhaps I should issue a new post?

Share This Page