PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Can't Install Logic 8 on New Mac

Discussion in 'Logic 8' started by markwhite1980, Sep 4, 2010.

  1. markwhite1980

    markwhite1980 New Member

    I recently bought a new, second hand imac 27 i5 to replace my older imac 24.

    I bought Logic 8 a few years back so had it installed with serial on imac 24. It is also installed on a macbook.

    When I attempt to install Logic 8 on the new mac after entering the serial the next page, asking which parts to install, greys out logic pro part and other components. Why is this?

    I understand the limit of only using Logic 8 on two computers but I'd like to leave it on the old imac 24 to wrap up a few projects during the transition period. If need be I am happy to uninstall it from macbook for the transition period. However, both the imac 24 and macbook are both switched off when I try to install on the new imac 27 so how does it know...I thought the number of machines was worked out via the network?

    I am not trying to wangle more uses that is legal, I simply want:

    Logic 8 on new imac 27 and 24 and am happy to delete from macbook for time being if need be.

    What should I do and what order should I do things in?

    Any advice greatly appreciated...I really want to get going with the new imac!
  3. Colin Shapiro

    Colin Shapiro Senior member

    Without actually checking here...
    Isn't the installer saying that you can't NOT install those bits? In other words, you MUST install them, so they're greyed out as there is no option to exclude them. They will indeed install.

    That's my recollection from installing stuff in general.
  4. markwhite1980

    markwhite1980 New Member

    Dop! good point, it's saying 9 GB required so I think you're probably right.
  5. markwhite1980

    markwhite1980 New Member

    No luck - Logic 8 Installation

    No luck with that. The only components which were not grayed out (Waveburner & Jam Pack content) are the only things that installed. Any other ideas...I really need to get some projects going!

    Is it re. licenses as in my first post?
  6. robgb

    robgb Member

    Call Apple?

    Although that may be a crap shoot. My brother-in-law called Apple help the other day because the screen on his iPad went blank. He was on the phone with them for half an hour, rebooting, etc., and they finally told him he'd have to bring it in to the shop and get a repair.

    He called me in despair and I said, hey, it sounds to me like you have the screen curtain down (he uses voice over). Tap the screen three times with three fingers.

    He did, and the screen came back to life.

    So, tell me, why the hell didn't the Apple techs know this simple solution? It's ridiculous.

    Anyway, sorry to go off on a tangent. It sounds to me like your machine thinks that Logic is already installed. You say you bought it second hand, is there a possibility that the previous owner had logic and didn't fully uninstall it? You might want to check in the Library to see if there are logic bits already in there and make sure everything is properly cleaned out.

    Just a thought.
  7. robgb

    robgb Member

    P.S. Mark. I went to your website. I like your work. Nice.
  8. zerobeat

    zerobeat Senior member

    You can't install 8.0 on top of 8.01 or higher. That's one reason why it would be greyed out as not being an option to install.

    Also, Logic 8 was never officially Snow Leopard compatible but some people had luck with it anyway.
  9. markwhite1980

    markwhite1980 New Member

    Thanks Rob for your kind comment.
  10. markwhite1980

    markwhite1980 New Member

    Thanks for the advice zerobeat.

    I have tried to get rid of all traces of Logic 9 before putting on Logic 8 - plists, receipts and all. From what I've read Snow Leopard is unlikely to be causing this problem, I might be wrong, or maybe it's because people are upgrading to 10.6 once Logic 8 is other way round to me.

    Here's the list I followed of deleted stuff:

    Application Files
    /Applications/Logic Node
    /Applications/Logic Pro
    /Applications/Soundtrack Pro
    /Applications/Utilities/Apple Loops Utility
    /Applications/Utilities/Impulse Response Utility

    Factory Settings, Instruments
    /Library/Application Support/Logic/
    /Library/Application Support/Garageband/
    /Library/Application Support/Garageband Content/ (Legacy)
    /Library/Application Support/Soundtrack Pro/
    /Library/Application Support/WaveBurner/

    Impulse Responses
    /Library/Audio/Impulse Responses/

    Receipts can vary quite a bit depending on your system. Try to find all those that look like the following:

    User Preferences:
    ~/Library/Preferences/Logic/ (Legacy preferences)

    /Library/Application Support/ProApps/Logic Studio System ID

    Apple Loops
    /Library/Audio/Apple Loops/Apple/Apple Loops for GarageBand/
    /Library/Audio/Apple Loops/Apple/Apple Loops for Soundtrack Pro/
    /Library/Audio/Apple Loops/Apple/iLife Sound Effects/
    /Library/Audio/Apple Loops/Apple/Jam Pack 1/
    /Library/Audio/Apple Loops/Apple/Jam Pack Remix Tools/
    /Library/Audio/Apple Loops/Apple/Jam Pack Rhythm Section/
    /Library/Audio/Apple Loops/Apple/Jam Pack Symphony Orchestra/
    /Library/Audio/Apple Loops/Apple/Jam Pack World Music/
    /Library/Audio/Apple Loops Index/

    I really need to fix this for work so anymore advice greatly appreciated.
  11. zerobeat

    zerobeat Senior member

    Even worse, Logic 8 definitely can't install over top of Logic 9.

    Unless somebody knows the exact thing to delete or modify to fool Logic8 into thinking there's no Logic9 install, I'd be re-installing the OS (from scratch) or buying the Logic9 upgrade (cheaper, because my time is worth money... plus, it's better anyway).
  12. markwhite1980

    markwhite1980 New Member

    Managed to instal ( I think!) using Pacifist.

    ALthough I deleted a long list of associated files there a more:

    usr/sbin/setbuf size
    library/spotlight/logic pro etc.

    ...amongst other random files.

    Just need to get Kontakt 3 out of demo mode now...even though it has been authorized.

    Thanks for all the help.

Share This Page