Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Controller Key deleting tracks

Discussion in 'Logic 9' started by Yakipro, Aug 17, 2014.

  1. Yakipro

    Yakipro New Member

    I have a Mac-Pro Quad core with 8g of ram and running Logic 9. I'm using a Motu Micro Express midi interface and up till now everything was fine. It seems when i press the G key on my midi controller my midi tracks wether it be external or software gets completely wiped out. I don't understand what could be the problem. First I thought I had a dead key on my controller so I took it to the shop. I had another keyboard, hooked that one up only to realize it wasn't the controller becasue it did the same thing. I even sent the interface back to the dealer and they sent me a new one..same thing. I reinstalled the drivers also. One thing I did notice is that in Utilities I can't get the test to trigger the modules.My last resort is reinstalling Logic but I wonder if that will work. I checked all the settings I could think of that would be causing this but i'm at a loss right now. Any assistance or nuggets of information would be great. Thanks.:brkwl::brkwl::brkwl:
  3. Eli

    Eli Senior member

    Shot in the dark here; try rebuilding defaults in the control surface preferences. See attached screenshot.

    Attached Files:

  4. bayswater

    bayswater Senior member

    Is there a key command assignment that maps the MIDI note to a delete command, or to a macro? Do you have something like Keyboard Maestro that is responding to the MIDI note?
  5. Yakipro

    Yakipro New Member

    Thanks! I went into Preferences and rebuilt the default settings, but it was still doing it. Then I looked at the Controller Assignments Parameter, there it was. I have no idea how it got to that and I looked in that section but I guess I didn't go deep into it but I appreciate you pointing me in the right direction.

Share This Page