PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Delayed playback mystery

Discussion in 'Logic Pro X' started by normbias, Oct 25, 2013.

  1. normbias

    normbias New Member

    I've been working on a new track and when I reopened it today, all the drum editing I did yesterday is out of time. Nothing is lining up with the metronome as it was yesterday and visually, the playback heard is approximately one second late compared to the visual of the audio file!

    I've tried removing all plugins, turning delay compensation off and on, rebooting… nothing seems to work. This is a new problem I haven't encountered before (Logic X is full of new problems I haven't encountered before). Does anyone have any insight as to what might be causing this and how to remedy?

  3. Eli

    Eli Senior member

    You really aren't giving enough information about the nature of the editing you did.

    Is it possible you accidentally shifted the actual position of the region in the Track's Area?

    You mention editing and you mention the visual of the "audio file"; indicating a single audio region. What type of editing were you doing that resulted in a single audio file at the end? Did you do a bounce in place? Or did you bounce the edits and then bring the file back in to the Track's Area? If it is just a single audio region, the solution should be as simple as shifting the single region until it is in place. And then the rest of the audio file should play in time. Were there any tempo changes involved? Did these change before/after bouncing down your edits to a new audio file?
  4. normbias

    normbias New Member

    Sorry for incomplete question - and thanks for your response, Eli.

    I recorded a mono drum machine and then edited the performance. When I edited, everything sounded correctly in time with metronome and the waveform corresponded with what I was hearing. For example, I would hear a kick on the 1 of the bar and see the corresponding waveform in the same place.

    When I next worked on the piece, all my edit points were no longer seamless and the tempo lurched at each edit point. When I look at the waveform, it looks as it did last session - with, for example, kick on the 1 of the bar. The sound in playback did not correspond with the visual of the playback cursor but was delayed by approx 1 second. I would see a pattern in wave file as the playback rolled but then hear that corresponding sound a second later. It is a single mono track that has been edited and not bounced yet. All edits are derived from same source file. There are no tempo changes in the piece and the tempo of the session is the same as it was when I first did tempo detection and resaved. A tempo change would be the most obvious reason but this does not appear to be the reason. The sound is off from the visual, making visual editing next to impossible and a nightmare of guessing for any further editing.

    Thinking this may be some kind of odd extreme latency, I removed all plugins, resaved, rebooted, looked at delay compensation. No change, things still sounding much later than the waveform visual would indicate. I've never encountered this issue before but am finding Logic X to be full of surprises. I'm stumped.
  5. normbias

    normbias New Member

    I solved my issue by copying all my data into a new session. I should have tried this before but now everything works fine. That particular session file must have been corrupted somehow. I don't understand it but it's working now, phew. Thanks again for your help.
  6. Eli

    Eli Senior member

    Glad you got it sorted out!
  7. normbias

    normbias New Member

    Okay, now I'm really losing my mind. When I opened the new session today, the same issue is occurring. The sound is delayed, the waveform does not line up with the sound. I feel this has something to do with the metronome and how it affects audio files. My tempo was set using beat detection but I noticed that when I change the tempo, it also alters audio file to play back faster and slower. In one session, audio plays back way too fast and the file is shorter as a result. In the new session I created by copying and pasting audio file from old session, it is playing back with delay as described, and all the edits are screwed up again. Everything was fine when I shut down last night. I can't figure this out and I hate to just abandon a piece of music I've worked on for three days. So frustrating.
  8. Eli

    Eli Senior member

    Do you maybe have flex time enabled, unintentionally?
  9. normbias

    normbias New Member

    No, flex time not engaged. I feel like it has something to do with tempo being embedded in audio track. Since I didn't know the tempo before I recorded the drum machine, Logic was at 120bpm. When I beat detected, I then reset, in Logic, the tempo to what the drums really are. It's probably not this though because the tempo of audio and the tempo of Logic are not so drastically different as 120 and 210 bpm. Three days of trying to remedy this…

    Although flex is not on, and has never been on for this session, when I adjust length of audio file in the Arrange window, a message box comes up that says "This Action will remove inactive flex anchors." This message regularly occurs since switching to Logic X, even when Flex not engaged. Perhaps there is a new level of hidden flex I don't know about. Why would there even be flex anchors? And if they are there, why aren't they visible?
  10. Eli

    Eli Senior member

    I'm not sure what you mean by this. The process of beat detection has Logic create and place tempo change events along the timeline. That's the whole objective of beat detection. To create a tempo map that follows your audio. So what do you mean when you say you "reset the tempo to what the drums really are"? That would undo all the beat detection events, wouldn't it?

    Using flex time and having it visible are two separate things.Think of it like automation; you can have automation in your project even though automation view isn't enabled. Same thing with flex. You can turn flex view on/off independently of actually enabling flex.
  11. Doug Zangar

    Doug Zangar Senior member

    Hmmm… have you tried removing tempo information from audio files? Under main Edit menu>Tempo. I don't use this but have read of people trying it with success on certain issues.

    If it were me I'd make a backup of the project first, then try this - stemming mostly from ignorance on what might happen, thus I can go back to original project.
  12. New Member

    Logic x bugs

    i am recording in logic x ( latest ver. 10.0.4 ) very bizarre things are happening , first - when i track audio i can see the wave display appearing but it is not the way it was in LP 9 ( in LP 9 it would be always tight on time ) but rather very late and not consistent , it can start appearing 5 , 8 , 10 seconds after the actual start , every time a different pattern of appearance while the playhead is running and it is recording , sometimes it stops showing the wave completely and only after i stop the recording the wave display will appear where it suppose to be.
    second bug - once i record an audio clip and would like to move the recorded audio region on to a different audio track ( just for organization like i have always done in LP 9) the audio is pitch shifted !! Never heard off !! tried to UNDO it jumps back on to the previous audio track but plays early ( like 2 seconds early ) while the display of the wave is right on time - the sound is not! it is crazy for application that i make my living with in a professional recording studio is acting this way. when i restart Logic it is back on pitch and on time.
    It happens with no plugins opened and no flex time in any way or form being involved
    Setup is Mac Pro 2.66 8 core Nehalem processor with 32 GB RAM , OS 10.8.5
    Audio device : RME HDSPe-MADI with the latest drivers and firmware connected via MADI to DO Tec Andiamo 32 I/O AD/DA audio converter.
    The description of the problems i see here are starting to connect with what i experience with Logic X.
    and the worse is that i cannot in any way save this project to be able to open on LP 9 , so must use PT 11 at this point , very upsetting , called apple tech support for pro apps they wanted a $99.99 for this call when they had no clue . I refused to pay for support at that price for a beta product that being released and sold for profit - to make experiments.
  13. Eli

    Eli Senior member

    You definitely have flex pitch enabled in this project. Although unintentionally.

    Just to rule out project specific corruption or unintended settings, what happens if you create a new Empty Project (not from a user template, but the Factory Empty Project) and try recording in there? I'd suggest this be the next thing you try. That will either confirm or deny whether the problem is specific to the individual project you have been having trouble with, or global to your Logic install in general.

Share This Page