PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Don't Wanna See Muted Regions in P.R. ed.

Discussion in 'Logic 9' started by sunhunter9, Jul 2, 2009.

  1. sunhunter9

    sunhunter9 Member

    How do I set up the Piano Roll editor so that the content of muted regions (or whole tracks) doesn't appear?

    I have the score editor set up this way, but I can't remember how I did it. Somewhere in preferences or on some menu is the option to hide muted regions, which I almost always prefer, but I can't remember where this option is! Please's a great feature, IMO, and I do hope it is available in Piano Roll.

    Also, speaking of Piano Roll, how about that phantom hierarchy button? It is described on manual page 65, and would be a great feature for me, but there isn't a hierarchy button on my Piano Roll. Does anyone have this?
  3. tommcleod

    tommcleod New Member

    I hear ya! Incredibly frustrating that the piano roll shows muted regions - I'm sure previous to Logic 8 and 9 this was not the case. I have not been able to find a mute button. Even more frustrating, is that the outgoing region is prioritised over the incoming region - so if you have a bit of extra overlap at the end of a region (or a muted region is underneath) it will show you this instead of what is playing at that moment. Logic 9 appears no different. Anyone else have any solution?
  4. Doug Zangar

    Doug Zangar Senior member

    You can't hide muted regions, but you do have some choice of what regions to view. In arrange area select only regions you want to view in PR. In PR, make sure you're at the top view level (dbl clk in background). To view a single region again, dbl clk on any of its notes.

    Good feature for wish list if it's not already there.

    @ Sunhunter, that feature change was documented in one of the update docs for L8.

    Score Editor>Layout>Global tab>bottom area checkboxes
  5. zerobeat

    zerobeat Senior member

    Correction: You need select the REGIONS you want to view, not the TRACKS.

    However, there is a preference feature (that I always have turned off) whereby when you select a track it'll also select regions on the track (and if cycle is turned on, it only selects regions inside the cycle zone). This feature totally screws me up, and it was only in Logic8 that it could actually be turned off!

    By the way, if you press OPTION, then you are temporarily reversing the behaviour of the above preference.
  6. Doug Zangar

    Doug Zangar Senior member

    And right you are. I'm going to edit my post so it's not misleading to others. Good call.

Share This Page