Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 EXS24 can't find samples, stalls indefinitely

Discussion in 'Logic 8' started by jbz, May 21, 2009.

  1. jbz

    jbz New Member

    Hi All,

    I've got a perplexing problem for one of my composer clients that recently popped up. When we load an instrument into EXS24, it's fine the first time we load it. However, if you close that session, and try to reopen it, Logic stalls forever on whatever that first EXS instrument is, searching for the first sample it needs to find. This is occurring across the board on all EXS instruments.

    I did some poking around his sample drive, and it appears that all the samples in question are in .wav format. This doesn't appear (nor should it) to be a problem, and the sampler opens the given instrument - and corresponding samples - just fine upon first loading. However, when reopening the song - at the point where Logic stalls - I noticed it's looking for that first sample as an .aif file! (i.e. It's the same sample name, with just the incorrect suffix. That sample doesn't exist anywhere on the drive as an .aif file.)

    Have any of you seen this before, and have any light to shed? FYI, he's using EXS Manager, and I tried directly relinking library by library, to no avail. Also, we've left it running for four hours hoping it'd relink, but it doesn't - it's definitely a full stall. I'd love to hear any thoughts or suggestions! Thanks much.

  3. Andrea Gozzi

    Andrea Gozzi New Member

    Hi Jbz,
    maybe he is using the "wrong" version of ExsManager, or simply is using wrong settings.
    Please send an email to and we'll quickly solve this.

  4. Colin Shapiro

    Colin Shapiro Senior member

    Just for the record, I did a re-linking session the other day with EXS Manager - an essential app for any Logic user.

    I found that many of the Logic Factory instruments showed up as incomplete. After some investigation, I found that the sample files that should have been found did not have file extensions (.wav or .aif) and this seemed to be the problem. I added the extensions to the problem files and now every instrument is linked and working well.

    Hope this helps....
  5. Andrea Gozzi

    Andrea Gozzi New Member

    Hi Colin,
    you do not have to manually add suffixes. Just enable this setting in ExsManager:


  6. John DeBorde

    John DeBorde New Member

    I had a problem where something similar was happening, and I managed to track it down to a problem with Spotlight not being able to find the files it was looking for - in my case I think it was IRs for Space Designer in addition to EXS.

    Spotlight had hung while indexing one of my drives and I had to exclude a few folders in order to get it to stop. If you search the web there are instructions on how to check the logs to see which ones it is getting stuck on.

    I don't hear of this problem often and it was a pain to figure out, so I try to chime in with my experience whenever I hear something similar in hopes that this info will help someone out.

    good luck!
  7. Colin Shapiro

    Colin Shapiro Senior member

    Hi Andrea,

    Yes, I had done that but even so, certain files were not found until I added the suffixes in the Finder.

    Looking forward to the new releases of EXSManager & Keymap......

    Regards - Colin
  8. jbz

    jbz New Member

    Hi John,

    That's very interesting - indeed, we're having a problem with Spotlight indexing, so the chances are good that they're related. Now, as for finding instructions on the web, I've found three or four sets of instructions - some of which look really risky and more draconian than the solution you've described. (Meanwhile, all of them are disputed by somebody or other.) Do you have a specific set perhaps you could direct me to? It's a quad Mac Pro, running 10.5.6. Let me know if you can point me in any further direction. Thanks much!

  9. Colin Shapiro

    Colin Shapiro Senior member

    I can add something to the Spotlight issue as I also had a problem recently.

    I saw in Activity Monitor that [mds] was always running and seemed to take up a whole CPU at 100%. After lots of web searches, I found this solution:
    1. Try to isolate the drive which is causing the problem
    2. Add all folders on the top level of that drive to the Privacy Tab in Spotlight prefs.
    3. Spotlight should now run perfectly.
    4. Remove one folder at a time from the Privacy Tab and watch the mds process in Activity Monitor. If it moves up to 100% and stays there for a long time, you have found the problem folder.
    5. Repeat this process for the contents of the folder until you have isolated the problem file(s).
    6. Trash the files (or move them off onto a CD).

    This worked for me.

    Regards - Colin
  10. John DeBorde

    John DeBorde New Member

    Let's add to what Colin wrote, I believe what I did was double click on mds (or whatever it's called) in the activity monitor, and click on the "open files and ports" pane...if you sift thru the log there you can get an idea what directories/folders are hanging the spotlight search and hopefully cut down on the trial and error necessary for isolating what's hanging spotlight.

    this is what ultimately worked for me despite multiple attempts to re-index and running a few Spotlight cleanup utilities. I don't think you have to do anything too drastic, just figure out what is hanging spotlight and exclude it from the list of items to index.

    hopefully this'll help...just keep googling this problem and you should eventually come across a more detailed description of how to fix it, and if you're still stuck, i'll see if I can find it myself, but it's been awhile, so my memory of how i fixed it is vague.

    good luck!
  11. bela

    bela New Member

    I don't know if I understand properly, but last week it happened a similar problem (not finding the samples) to me as I changed a drive and copied all my samples in the new position. After a while I could solve the problem via project manager reindexing the directories. I am on Logic 7.1.
  12. jbz

    jbz New Member

    Thanks to you all for your input. The spotlight problem helped a ton, on other issues surrounding Logic's performance. Turns out Mach5's library was not being read correctly, file transfer times were going extremely slowly; iTunes had been acting horribly - these problems and more were solved by the Spotlight fix.

    I think we might be dealing with a double-blind though; the core problem - of EXS loading correctly the first time, but hanging upon reopening the session because it's searching for .aif samples instead of .wav samples - is still unchanged. I've sent in a support note to Redmatica as well, in case it is indeed an EXS Manager issue. Any other thoughts any of you have would be welcome - I'm stumped. Anybody know what I'm missing?
  13. Roger Jackson

    Roger Jackson Member

    If anyone is having problems of this this sort, you need to get EXS Manager. Andrea is too modest to say so, but you are wasting a lot of time if you don't have it. It is an essential companion to EXS 24, and will repay it's own investment very quickly.

    Roger Jackson
    Film Music
    Oxford UK
  14. jbz

    jbz New Member

    Thank you for your input Roger; I'll second your thoughts. Once again, regarding the specifics of *this* case however, we do already have EXS Manager - here the problem is happening in spite of (or, far less likely but still possibly, because of) EXS Manager. But yes, it is an essential companion, and well worth purchasing.


Share This Page