1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixing permissions on Yosemite -driving me crazy!

Discussion in 'Mac OS' started by beatattitude, Nov 24, 2015.

  1. beatattitude

    beatattitude Member

    I've been having trouble when trying to save Logic 9 files in Yosemite. I tried right-clicking the master folder, selecting "get info" , unlocking it, setting all permissions to read/write/exe for all users, and then applying that to all the contents of that folder. But some files still won't let me save them without manually finding it within finder, and setting the "everyone" setting to read/write/execute. ("everyone is a user which does not appear in the folder properties, only in some file properties)

    I've tried running "repair disk permissions" but that doesn't seem to bring up any issues.

    I've got a few user accounts, but all of them are set as having admin privileges, and I'm not working on files which I've created as other admins. Some files WERE created on another mac, though.

    I've been looking around and note that there is a way using terminal and something called CHMOD to edit all the permissions of a folder. Is this something I could do? I just want my music folder to be completely free to read/write/execute on all current files, and also on all new files I create.

    I've got an app called "Path Finder" which I have used in the past instead of finder, but I'm trying not to use it now, in case it's messing things up...

    Any tips?
  3. bayswater

    bayswater Senior member

    First: unlocking the folder? How did it get locked? It shouldn't be locked. That would stop you from accessing it for saves.
    Second: CHMOD is just a command that does more or less the same thing as repairing permissions, although with many more options. I doubt that will solve your problem.
  4. beatattitude

    beatattitude Member

    I've no idea why the folder and file settings change.

    I ran a resetpassword thing from the terminal in recovery mode, but I'm still noticing that some files have a "custom" setting for the username "everyone" so that it looks like this:

    NAME ....... PRIVILEGE
    everyone - Custom
    greg2 (Me) - Read & Write
    staff - Read & Write
    everyone - Read & Write

    I don't know where this "custom" thing came from, or why files have different privileges from folders. But currently, when I save a logic file I'm working on, sometimes it will say the file is read only, so it can't be saved.
  5. bayswater

    bayswater Senior member

    So, you're unlocking the permissions for the all the folders where your logic files go, (not the folders which shouldn't be locked in the first place), changing them to read and write, applying that to the contents of the folders, and then locking the permissions? After that, does it say you, Greg2, can read and write? That should do it. But that custom permission: can you remove it? Maybe it is overriding all the permissions that are listed below it. Or change it to read and write?
  6. beatattitude

    beatattitude Member

    I'm not locking the permissions after I change them. Should I do that? By that, do you mean that I should click the padlock closed again?
  7. beatattitude

    beatattitude Member

    The "custom permission" only appears on files, and not folders - therefore, I don't know how to change them on a file except doing it manually, one by one.
  8. bayswater

    bayswater Senior member

    I lock them because they are locked in the first place. Seems to me that would be the way to stop them from changing back to the way they were before you edit them.

    I haven't seem custom permissions. It appears these indicate an unusual set of permission flags that can't be described with the usual labels, like read and write. Sorry, but I don't know how to deal with these, or whether you have to.

Share This Page