1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Has Piano Roll CC1 automation stopped?

Discussion in 'Logic 9' started by David51, Sep 14, 2012.

  1. David51

    David51 Senior member

    I used Hyper Draw in the Piano Roll 2 years ago to switch articulations of the strings in Jam Pack 4, it worked beautifully but it doesn't seem to be working now,even entering the CC1 changes in the event list has no effect on the GB string articulations. In the event list I can see the attempts I made to automate the articulation change. Could this be something in 9.1.7 that has changed from 9.1.5? I could use the two track method, one track for arco under it a track for Pizzicato but the Hyper Draw was so great, I would really appreciate hearing if anyone else has noticed something like this.
    Thanks in advance.
    Another thought, am I just doing it wrong? I open Piano Roll and click lower left to open Hyper Draw and select Modulation and put in nodes to make it possible to raise the measures with Pizz. to 118-127, the arco is legato so it remains at 0-9 CC1,that should work, NO?

    EDIT: I just checked the previous use of this which was in a Logic instance installed on my now dead[Radeon graphics crap] iMac, and it works there! So I suppose the instance of Logic on my MBP,which is now by default my only Mac that works, has a singularity which causes this not to work, I will move the whole Project that isn't working to the dead iMac's finder and using that instance of Logic should make the Hyper Draw work, thank God I was using an external boot on that old iMac cause I can use the 1TB external boot on the MBP[NVIDEA GeFORCE graphics GPU] and then I have access to the other copy of Logic,will report back to avoid "RTFM" 's and such.

    EDIT Back again, it doesn't work in this instance of Logic pro 9.1.7 either, I accidentally hit next instrument in the EXS and that was a solo clarinet, it did respond to Hyper draw, but only switching around 63 from legato to staccato,no whole or half step trills as it should do. The cellos do not respond as they should,any ideas?
  3. CSeye

    CSeye Senior member

    Drawing in CC#1 in HyperDraw in L9.1.7 works here with OSX 10.7.4 and 10.8.1.

    Start a new project with the Empty template, load the EXS24 etc, draw in CC#1. Does it work?

    If not, then maybe the file is corrupt.

    You can trash your preferences by the selecting the menu item in the Logic menu to the right of the Apple menu. But first, I would drag the existing preferences to your desktop in case you want to restore them.
  4. David51

    David51 Senior member

    CSeye, thanks very much for the help. When you say "load the EXS etc., draw in CC#1" don't I need some notes in the piano Roll to see if CC#1 changes them? I just tried removing the Logicpro.pref,but there was no change in any of the 5 songs I tried out to see if the CC1 worked,I am still in 10.6.8 and just went through the bit about finding the right up date to make SL save passwords, it may not be saving something else but I would expect you all to know if that was an issue[SL not saving]since I don't have a great deal changed from the default way Logic runs I guess that is why trashing that pref didn't do anything. I have had many troubles with corrupt Logic files but never could locate the source,a clean install didn't change the behavior,that is why I fear my original DVD's for Logic from Studio 1 have some corrupt files so every instance installed from those DVD's will have corrupt files. The basic structure of Logic isn't completely revamped by each new version is it? The versions pile up on what is already there,but I am speculating in an area that is FAR out of my understanding. Thanks again, if you think of something else to try I will follow your instructions, otherwise I must limp towards the finish with what I have.

    Back again, the settings are not being saved, even after replacing the plist and re-setting some things like drag only in one direction in all 3 editors. As soon as I have re-set that pref it is gone,not saved. There was probably an update in Lion and ML to fix this but it is too late for me to move up I believe, and it would bring me all the joy I read about after googling Logic Pro 9 + Lion or ML, looks like Apple is happy to leave this as is,PITA.
  5. CSeye

    CSeye Senior member

    You do need to add notes. "etc" was short-hand for setting up a MIDI Region with recorded, step entered, or pencil drawn notes with which to test out CC#1

    Did you start a new project using the Empty template with MIDI notes and newly drawn in CC#1?
  6. David51

    David51 Senior member

    I thought that was what you would say and that is what I did,but no joy. I googled the problem and got a post from Logic Pro help from Eric Bradly,and it is from 2010 and says this new framework[5.1] is to replace the corrupt framework delivered with the up date to 10.6.6. I am very certain it is a snow leopard fault and I am SOL to have missed the chance to upgrade Logic since the fixes only are offered months after the initial release and so are only available to those who follow the orders they are given by this Corporation.
    I was able to get Snow Leopard and that is where the 5.1 was installed,if I had been a good soldier and followed Apples demands I would have a copy of 9.1.7 that worked. I have a screen shot of that post of Eric's but no time to go jumping through a series of hoops to get it to a URL for posting here,how backward this forums' set up is!
  7. CSeye

    CSeye Senior member

    I'm confused. What is that you need? An earlier revision of Logic? Or of SL?
    They're still available for download.

    Enter what you're looking for here:
  8. Atlas

    Atlas Senior member

    Drop the coffee man! You are all over the place and nowhere!
  9. David51

    David51 Senior member

  10. CSeye

    CSeye Senior member

    If I knew which version of the Prokit was most compatible with 10.6.8 I would certainly share that with you.

    Why not ask about this over at the apple discussions forum as it is a very apple-specific question?

Share This Page