1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Have Audio but no visible waveforms on playback!

Discussion in 'Logic 9' started by mjh45, Mar 24, 2010.

  1. mjh45

    mjh45 New Member

    Has this happened to you? Installed 9.0 & did the 9.1 upgrade.
    Whenever I'm tracking or doing an internal bounce ( thru my interface and back into logic) I can see the waveform while in record. As soon as I hit stop
    the region LOOKS blank yet the audio is there. Frustrating as hell when i need to edit.

    Went into the library/prefs, etc and trashed the com.logicstudio.etc, etc...to no avail.
    Anyone have an idea?

    Logic 9.1.1
    24"iMac / 2.33GHZ core 2 duo/ 2 GB Ram
    Metric Halo 2882 2d interface
  3. David51

    David51 Senior member

    Hi, very frustrating, I get this too but not as often since 9.1.1-I haven't recorded yet in 9.1.1 but had this happen in 9.0.2 very often and never found a fix, sometimes opening the audio editor would give me a look at the wave form and a chance to edit it, but even in that situation it was no pick nick.
  4. mjh45

    mjh45 New Member

    A fix to this issue!!!

    Ok folks...
    I've seen a few of you on here- myself included- dealing with the issue of recording tracks- seeing the waveform while tracking- only to see the Regions go "blank" once you hit stop and went to playback...the audio was there-but nothing in the GUI to allow proper editing...frustrating indeed.

    I noticed this happened around the same time that I started getting this error-
    "midi core server failed to quit" or something to that effect.

    So I thought they might be related. So I searched the LUG for a fix to that-
    very easy if you happen to also have pro tools installed:
    go to: Mac HD/Library/audio/midi drivers- and remove all digi midi drivers.
    I didn't trash them - just created a folder elsewhere to store them.

    Once I did that I had no more issues with shut downs being cancelled by this error.

    So, then I fired up logic and did some test recordings- both in old sessions where I experienced the blank region problem and in new sessions with no
    content at all.

    In both cases waveforms appeared in the regions upon playback:thmbup:

    Yet another case of Digi gumming up the works!!

    It's beginning to be a happy monday.
  5. David51

    David51 Senior member

    Hi mjh45, Glad to hear of that fix, I don't have pro tools so maybe one of the other drivers is the culpret-I haven't a clue as to what to do'
    Any one have a non pro tools fix for this?
  6. Gio

    Gio Member

    had this happen to me too, waveforms not appearing but audio playing.
    Use the waveform slider on the bottom right of the screen to "wake" up the GUI.
    Slid the slider all the way up and then back to default and all the waves popped up in their regions.
    Good Luck
  7. David51

    David51 Senior member

    No wave forms visible on playback?

    Great idea Gio, thanks for sharing that. I wonder though if the MIDI drivers in my Mac might be the problem, I don't have any pro tools so it could be version
    2.2 from EmagicUS or KorgUSBMIDI Driver v. 1.0.8, or M-Audio USB Support.plugin v.3.4, that's all that is there, any idea how to find out which one? the RDUSB is the Edirol tht connects the AKai breath controller to the iMac, so I don't want to remove it, its' just the korg that is not in use at the moment so where would I put the new folder to try recording without it and see if it was the Korg driver interfering with the audio wave forms visibility?
  8. doghousenyc

    doghousenyc New Member

    I recently had the same problem and none of the above fixes worked.

    I'm on a power pc G5 using logic 9.0.1 and protools 8 with an HD2 accell system.
    I'm writing this for the next poor sap to say that this was fixed (for me) by finding and installing the Protools 8.0.1 **CS2** update.

    Prior to that, I investigated delay settings, disk permissions, preference files, different combinations of audio drivers, the waveform zoom button and all kinds of other voodoo. Good luck if this sounds like you! best, Nathan
  9. drblowthingsup

    drblowthingsup New Member

    Hey guys!

    Was reading this thread to troubleshoot the same problem, and came across a solution elsewhere, so I thought I'd let you know how I fixed it incase anyone is still wondering.

    Same as you, the waveform showed up when recording and in the waveform editor, but not in the arrange window. I went into preferences>Audio and set the sample rate to 0. Not sure why this works, but it did it just fine for me, all is well again!


Share This Page