PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Key commands not working

Discussion in 'Logic 9' started by jayfolland, Feb 11, 2011.

  1. jayfolland

    jayfolland Member


    I have just upgraded to Logic 9 and all of a sudden none of the key commands work, Nothing works really. when I toggle through screen sets that doesn't work, I can bring the mixer window up with X but It wont go back down by pressing X again, same with the Audio bin, it folds out up by pressing B but wont fold back, Command 1 doesn't work to bring up the Arrange window. I think I must of pressed something. Does any one know what might fix this? as this is a rather big dilemma..........:confused:......

  3. jayfolland

    jayfolland Member

    Why don't I just kill 2 birds with one stone!!! Now I've just realized that the same glitch that was happening with 8 is still going on.>>>

    When ever I move an Audio region the next time I press play nothing plays it's like everything is muted but No mutes switches are on NOTHING. The only way I can get it to play again is by pressing solo on and off (S)......Ok, this is logic 9 on a different computer, a brand new computer. ?????? I've got nothing?
  4. georgelegeriii

    georgelegeriii Senior member

    A few questions:
    1) Is this a session brought from Logic Pro 7?
    2) Do you have custom key commands from a 3d party or yourself?
    3) Have you tried to simply reinitialize your key commands yet?
  5. jayfolland

    jayfolland Member

    The session is from Logic 8. I have customized my own key commands from Logic 8. It seems to be back to normal now a few restarts and it seems to be fine. COMPUTERS!!... But I am still having trouble with the solo problem....It's like it's carried the problem over from 8 some how?
  6. Eli

    Eli Senior member

    There is a well known bug (just had a client experience it yesterday) when opening older projects (L7) in L9 where the Klopfgeist track defaults to being in solo safe mode. This is what's causing your odd "no sound" behavior; because we don't normally see the Klopfgeist (Click) track.

    Solution: open your mixer. Set the display to "All" Scroll to your highest number software instrument track. You will see the Klopfgeist instantiated on it, and it will be in solo safe mode (a line through the S button. Control click the solo button to disable solo safe mode. The behavior should return to normal at that point. It may recur again though in these old L7 projects.

    Not sure why it is happening for you in an L8 project. But it sure sounds liek this is the problem. Is it possible it originated in L7 before you worked on it in L8?
  7. jayfolland

    jayfolland Member

    The Klopfgeist was in solo safe mode but it still happens, this has been driving me crazy for about a year now.

    I just figured out that once I move a Midi region/Audio region and when it stops playing that when I Command Z that event it plays again. And if I Command Shift Z the undo event it will still play.

    This is really weird, if I didn't figure out that by toggling solo on and off I wouldn't even be able to use logic, ever! this would deem it un useable for me.

    I wish I could say yes to the "I was using logic 7 before" Eli, but It was Cubase before this. So now I really have no Idea. It's driving me crazy i thought surly this would not of happened in 9 AND on a new computer? The new computer was the closer for me, I was certain this problem was behind me forever? :confused:
  8. georgelegeriii

    georgelegeriii Senior member

    I would suggest a complete trashing (or removing to the desktop) of all Logic preferences, then restart Logic and see if it is still an issue.

    You are describing behavior which I certainly don't see in the dozen or so systems I regularly maintain. So I suspect corrupt preferences, or maybe a system.

    One other thing to try is a new user account. It is often a good way to verify wether issues are preference or settings based. I have a MBP that will not play with Reason in my main user account, but if I make a new user account, everything is perfect. Go figure...
  9. jayfolland

    jayfolland Member

    I think I understood you correctly George I opened a new account in accounts>System preferences. I also tried deleting the file> and also tried moving it to the desktop, unfortunately it still happens.

    When I press S (solo)Activate solo, then move an Audi region/Midi Region, then Press S again it will play fine. So I'm assuming it has something to do with Soloing?
  10. georgelegeriii

    georgelegeriii Senior member

    Actually you did 2 things rather than 1 at a time...

    Try to delete all the prefs and see if that works... then if logic is still not working right, make the new user account.
    You can't alter another user account, as I'm sure you just realized.
  11. jayfolland

    jayfolland Member

    I didn't explain my self properly, I'm not the best at explaining (I confuse myself) I actually done all of these things individually.

    Any suggestions? This in my opinion is one hell of a problem!
  12. georgelegeriii

    georgelegeriii Senior member

    Here's another suggestion: apply the latest combo system upgrade... make sure it's the combo, not the little updater. You are using 10.6.? right?

    2) If that doesn't work, delete all Logic Prefs and key commands, and the Logic Pro app. (I would actually just move them into a folder on your desktop as a bu). Reinstall the Logic Pro app from the master disc, then update to the latest version.

    You should have to redo your prefs and your key commands should be the default ones after you complete this. If they aren't either you missed something, or you have duplicates in another location that Logic is looking for.

    Let us know if that helps... as for me, I'm almost out of ideas.
  13. MatzeMillion

    MatzeMillion New Member


    I have the same problem (x opening mixer but not closing it) and found it to be related to the i/o plugin.

    I have two Apogee Ensemble interfaces running as an aggregated device and the driver seems to submit wrong default I/O Labels. eg. Line 1, Line 2, ... , S/PDIF 1, etc. At some point there is only garbage (like "'ø#") shown in the I/O Labels window in the Logic. If you open the I/O plugin then (which is always showing the default labeling, even if you put in your own names), it seems to completely mess the key commands. X, B and N for example open the corresponding tabs, but don't close them when pressing the key again. The Loops ("O") are ok, so are Cycle and Click. Even Command-Q is highlighting the Menu but doesn't quit Logic. If you open the "Logic" Menu with the mouse and then press command-q it works. Thats all so confusing.

    The bug is 100% repeatable. I tried a lot (deleting prefs, system reinstall, etc) The cure is not to use an aggregated device.

    [EDIT] I'm using Lion 10.7.3 and Logic 9.1.6 (32 and 64bit)
  14. Kendalph

    Kendalph New Member

    A Little Trick that Worked

    Hi everybody !

    I had the same problem with (Apple) Logic Pro (9) :
    some very useful Key Commands / Keyboard Shortcuts
    (such as COMMAND + A, COMMAND + C, COMMAND + X, COMMAND + V,
    were not working :
    these commands highlighted the menu bar, but did nothing else.

    After much hair-pulling and forum-surfing,
    I tried to open a LogiKCS file with Logic.

    For me, the file was named "French with Numeric Keypad.logikcs".

    I found it in the following directory :
    /Library/Application Support/Logic/Key Commands/

    Then, Logic opened,
    and (not surprisingly) told me it cannot open that kind of files.

    After I closed this message box,
    I opened a standard template (Electronic Music).

    And then... I don't know exactly why, but... it WORKED !

    It was a joyful great moment for me :) :)
    So I you have a similar problem, maybe you can try this trick for yourself.

    Hope I helped. :hippy:

    ~ KENDALPH ~

Share This Page