1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 L9 Track Import issues: THE SEQUEL

Discussion in 'Logic 9' started by posthorn, Dec 4, 2009.

  1. posthorn

    posthorn New Member

    I am starting a new thread because my posts from a few days ago on this issue made it appear that a simple 9.0.2 update had solved the problem. But, alas, after further investigation, no.

    Here's the deal:

    I am trying to import a set of ten tracks that are assigned to a single multi-timbral instrument (each with corresponding MIDI channel 1-10). The tracks (and their content, plugin, I/O, etc.) seem to come across fine. However, the new tracks that were created in my destination project each have their own separate instrument plugin - meaning that I now have 10 instances of that instrument rather than a single one assigned to 10 different MIDI channels. When I try to import them without the plug-ins column checked a similar thing happens where each track is assigned to a new instrument rather than a single instrument set to MIDI channels 1 to 10. Hopefully that explains it clearly enough.

    It would seem that the root problem is that the instrument track(s) on my original project are multi-timbral and the tracks that end up in the destination project are not.

    Here are the questions:

    1) Is there a way to import multi-timbral tracks with their instrument and midi channel assignments in tact?

    2) If not, is there a way i can quickly reassign the new tracks to a single multi-timbral instrument and its various midi channels?

    btw, the reason this is such an issue for me is that I have an orchestral template with each track intricately named. It's a workflow-killer for me to rename all those tracks every time I bring in a new multi-instrument. It's so much quicker to just import them from another project.

    Any help is much appreciated!

    My system: Mac Pro 2X2.8 Quad-core, 10GBRAM, OS10.5.8, Logic 9.0.2
  3. Jay Asher

    Jay Asher Senior member

    I just did this here importing from my Stylus RMX template and it worked perfectly.
  4. posthorn

    posthorn New Member

    Thanks so much, Jay.

    I just tried it with Stylus. Actually, in terms of MIDI channel assignments, you are correct. The imported tracks are assigned properly. However, each of the 10 imported tracks is assigned to its own audio instrument. Therefore, I now have 10 identical instances of Stylus loaded rather than one multi-instrument assigned to 10 different channels like my original tracks.

    Maybe I'm missing something...
  5. Jay Asher

    Jay Asher Senior member

    I think if you check you will find that they APPEAR to be different instruments (the same way they do if you open a multi-timbral software instrument with the + sign) but in reality they are 1 with different MIDI channels.

  6. posthorn

    posthorn New Member

    Thanks again, Jay, for helping me with this.

    The inspector window is indicating "Core Audio: Inst 1", "...Inst 2", "...Inst 3", etc. as I select the different imported tracks. Also, if I un-assign stylus in, say, track 5, it only un-assigns for that track and not all ten. Therefore, I'm pretty sure there are ten separate instruments there.

    If you're not experiencing this problem, perhaps you could tell me what versions of Logic and OSX you are in. Maybe I've just got a bug here.

    Again, my system: Mac Pro 2X2.8 Quad-core, 10GBRAM, OS10.5.8, Logic 9.0.2
  7. Jay Asher

    Jay Asher Senior member

    OK, there are 2 simple ways to know for sure. In the Mixer, under View, make sure that All Tracks with Same Channel Strip/Instrument is unchecked. Do you see 1 or 10? Secondly, un-instantiate one.. Does 1 go away or do all?

    If only 1 goes away, then I do not know why on your rig it is not working, because, as I say, it works here.
  8. posthorn

    posthorn New Member

    ok, I did all those things and I can now unequivocally confirm that I have 10 different stylus instances each assigned to its own channel strip, rather than one instance assigned to 10 MIDI channels...

    I have a feeling that this is a bug in my particular Logic/OS combination. Maybe I'll take the plunge to Snow Leopard just to see if it solves this problem.

    That's why I asked for your version numbers in my last post. If you are in OS10.5.8 with Logic9.0.2 then this really is a mystery.

    Thanks again.
  9. Jay Asher

    Jay Asher Senior member

    OK, posthorn, good job of sleuthing.

    Yes I am on 10.6.2, LP 9.0.2.
  10. CCTMusic

    CCTMusic New Member


    I found exactly the same thing.... Didn't work properly in 9.0.0, "fixed" in 9.0.1 such that you get multiple instances of the instrument plugin instead of 1 multiple channel instance.


  11. CCTMusic

    CCTMusic New Member


    Further to this, I just checked with OSX.6.1 and Logic Pro 9.0.2.

    On track import, I got multiple objects in the Environment (all NAMED Inst1, all assigned to the correct MIDI channels) but actually on separate instances and discrete channel strips (Instrument 2 through 9).

    In other words.... I got 8 instances of RMX, not one.

  12. CCTMusic

    CCTMusic New Member


    Just checked with LP9.0.2 and OSX.6.2.... same result.

    Not an OS issue imho


  13. posthorn

    posthorn New Member

    If Jay's is working and yours is not and you guys have the same versions...the mystery lives on.

    It's feeling like this one ain't gettin' solved.

    Since CCTMusic is the most current, maybe you could report the bug...


Share This Page