PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 7 & earlier Logic 5 will not start. Error = "Multiple XSKeys detected"

Discussion in 'Logic 7 and older Versions' started by the27man, Feb 2, 2010.

  1. the27man

    the27man New Member

    if someone knows where this has already been answered, i would appreciate a link.

    i have installed Logic RPC Pro (ver 5.1.3) on my WinXP machine. when i plug in the dongle, i get the error "Multiple XSKeys detected."

    i have two SI-24 boards installed. one came with Logic, the other with Sonar LE, thus i have two Emagic dongles. i do not know which dongle goes with which program. (i have loaded Logic on an older machine (Win2K w/ 2 GHz Pentium 4 and 1 Gig memory). on the Win2K machine, it runs with either of the dongles.)

    i have attempted to launch Logic with the following permutations: one dongle, the other dongle, both dongles, and neither dongle. without a dongle, i receive the appropriate message "Emagic XSKey not found." with either or both dongles, i receive the aforementioned "Multiple XSKeys detected" dialog.

    i have tried the dongle in various USB ports; each time the Device Manager is populated with only one instance of the XSKey. i have uninstalled the driver, re-inserted the dongle, and have been met with the same results.

    the machine in question is:
    Dell Optiplex GX280
    Windows XP Professional
    ver. 2002 SP2
    Pentium 4 (3.2 GHz)
    1 Gig memory

    two (2) RPC-1's
    two (2) Roland SI-24 boards

    i'm not even certain what the correct question is, but generally speaking, what do i need to do to get Logic opened on my WinXP machine (patches, updates, hardware configuration, etc.)?
  3. AlanJ

    AlanJ New Member

    Multiple XSKeys detected

    I am trying to install logic 5 on my dell laptop with XP pro, and get the 'multiple XSKeys detected error, on startup of the program.
    It will not start, and the only option is to quit.
    I have also tried with/without the dongle/various ports etc, and cant get around the problem.

    If anyone can help - please advise.
  4. mmm42

    mmm42 Senior member

    Disconnect all devices and check. I also remember (Logic 5 is a "few" years old), that a Logitech (or other 3rd party) device driver for a mouse or joystick messed up the communication. That was a driver bug on their end, which IMO was fixed at some point.
  5. djstkora

    djstkora New Member

    I think it might have something to do with some other music software, either behaving as TSR, or its licensing mechanisms. But not sure...

    [EDIT] What I wanted to say is, checkout your "running process" list, and try to kill some, that you can see are related to Sonar. [EDIT]

    DANILODACA New Member


    to avoid problems crashing with multiple XSKeys detected error, ---> just use a ps/2 keyboard and a mouse and the problem will be fixed. danny boy
  7. mmm42

    mmm42 Senior member

    If I remember this issue occurred with certain custom drivers from Logitech for e.g. their joysticks. They think the XSKey is a keyboard...

Share This Page