1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic 9.1.8 still unreponsive in OSX 10.8.4

Discussion in 'Logic 9' started by Martijn, Jun 7, 2013.

  1. Martijn

    Martijn New Member


    I'm Martijn and I'm new on this forum.
    I have a problem that I hope someone here has an answer for.

    I have a 2009 Mac Pro 8 core Nehalem, 20gb internal memory with Logic 9.1.8 installed. After updating to OsX 10.8 I had this problem of Logic becoming unresponsive for 30 sec/1 minute while playing. I've found a lot of users having the same problem and it seemed to be an OSX 10.8 issue.
    However, after updating to 10.8.3 I have the idea that almost all users found their problem solved. But my problem stayed.

    I'm using 3rd party plugins like waves platinum 9, Native Instruments Komplete 8, Spectrasonics Omnisphere, East West Play and Antares Autotune and I have the feeling that one of the ones mentioned might be causing the problem. I tried to figure out which one it might be by disabling them in the AU manager, but I can't put my finger on which one it is.
    The error sometimes seems to be occurring randomly.

    Now here comes the question:

    Is there anyone out there using one of these products that also didn't see his or her unresponsive Logic problems solved with the OSX update?

    Or does anyone have a suggestion what could cause this problem?
    Please note that I already re-installed Logic Pro from scratch, removed all Logic preferences and I've updated all the plugins to the latest version.

    It's an issue that has been talked about a lot but Im not sure if I should post it in the existing threads because I'm not sure if the cause of my problem is Mac OSX. So that's why I started a new thread.

    Hopefully someone has an answer for this.


  3. HKC

    HKC Senior member

    Hi I don't understand what Logic becoming unresponsive means but I use Play quite a bit and don't have a problem so rule that one out.
    Do you mean that Logic freezes maybe.
    If there's a problem in Waves Platinum it will take quite a while to establish where the problem is since that's a pretty huge bundle, same thing with Native Komplete.
    Have you tried to uninstall these, and are these fully updated.
    There has been problems with Spectrasonic some time ago but I don't know if that was solved.
    Sorry I couldn't help but at least I could rule one out :)
  4. Martijn

    Martijn New Member

    Hi HKC,

    thanks for your reply. Indeed I can rule out East Wet Play now:)
    What i mean with "unresponsive" is that I can not control Logic for 30 sec to 1 minute after I press play. It keeps running but I can not stop it or do anything in the interface until the 30sec to 1 minute is over. It seems to be this GUI lag that a lot of users have problems with....
  5. HKC

    HKC Senior member

    I would consider the fact that many users don't have this issue and try to find the problem outside of Logic which would be in your plugins. It may still be a Logic issue but since I and many others don't have it, it must have something to do with a 3rd part thing.
    I have a current thread here myself where I have found a bug in 3 plugins, something to do with the way they behave with automation and auxes. I had to spend an entire day checking every single plugin out so I understand your frustration.

    Good Luck
    Henrik Krogh
  6. gdoubleyou

    gdoubleyou Senior member

    Is your system drive nearly full?

    I've actually seen a Logic performance boost, with 10.8.4

  7. michaelo

    michaelo LUG Emeritus

    This is a long standing problem in Logic. I have many friends with similar systems who experience this unresponsiveness. It has bugged my system for several years. I wish I could cast some light on it. I find it is confined to it sometimes being difficult to edit during playback as it tends to start ignoring mouse or keyboard inputs. It gets worse and worse then I just restart the computer and its ok for awhile. Some days it doesn't happen, other days i can hardly work. No real understanding of cause at this point.
  8. Martijn

    Martijn New Member

    Hello again!

    @gdoubleyou: no the drive has 50% of space left and it's a latest generation SSD.

    But there's something that happened a few days ago that I want to share here:
    After the 10.8.4. update I saw that one of my 2 displays doesn't work properly. (according to Apple forum it's a 10.8.4 bug and not fixed by Apple yet) After starting from an old 10.6.8. disk it was all fine again. So I decided something might be wrong in the update regarding the video card driver. In an attempt to fix the problem with a separate driver (right brand and model) the system became completely unbootable so after booting the mac with my Macbook disk in Target mode, I tried to replace the system folder of the damaged and unbootable os with the working one from my laptop.
    Didn't work, but the result was that I replaced the OLD system folder with a NEW one. My Mac Pro came from the OSX 10.6 age and was constantly updated but never ever had a clean install ever since. By throwing away my old system folder and trying to replace it, i threw away old stuff that might be the cause of this Logic problem. Because after I completely damaged my system and did a clean OSX re-install with the rescue partition and online install, my Logic problem seems to be solved. So maybe this problem that a lot of users still have, might be caused by older OSX versions that are updated (and leaving old system files active) instead of being installed from scratch. Well, for now I'm kind of happy with my setup despite the display problem. Hopefully this info is useful to others!


  9. gdoubleyou

    gdoubleyou Senior member

  10. HKC

    HKC Senior member

    Still it is interesting that not all users experience this so it must have something to do with a 3rd ware thing or maybe, like suggested above, something to do with not ever doing clean installs.
    I use Logic maybe 40 hours a week and I have never had that exact problem. I have a mid 2010 Mac Pro which has never had a clean install but of course it's a fairly recent machine so the problem could go further back.
    It can certainly be an Apple issue but until somebody takes the time and finds out where the problem is it will be hard to solve the problem. I don't think Apple has the patience to go through every single plugin out there :)
  11. An early beta of the Mac Dropbox client caused massive slow-down in Logic's plug-ins pop-up selector. I don't know that it affected anything else. The Dropbox guys got it fixed quickly and mentioned Logic specifically in the release notes. So it's definitely possible for something completely outside of Logic or its plug-ins to cause trouble in Logic, and only in Logic.

    Does Logic need to be more robust in this regard? Also possible. :)
  12. charlie

    charlie Senior member

    FWIW, I too use a 2009 MacPro (from & currently running OSX.6.8) and I have had the same issue where Logic sometimes seems to ignore my key-commands, letting Logic play & play unless I stop it via a mouse click on the transport bar... :confused:
    Martijn, do you use a wireless keyboard or mouse by chance, that is connected via USB?
    Here's why I ask;
    About a year or so ago, I bought a fancy Logitech mouse that used some proprietary Logitech USB connectivity to work with my Mac Pro. (not Bluetooth.)
    After I bought this mouse, for some reason, ANY Logic Pro session I would try to open that was created BEFORE the Mouse was introduced would not open UNLESS I REMOVED the USB receiver prior to selecting my Logic project...:eeek:
    Once Logic opened my session, I could re-connect the USB Dongle.
    Lo & behold there was another Logic Pro upgrade, (to 9.1.8) and the issue minimized to barely ever happening.:thmbup:
    Feeling confident, I bought Logitech's wireless computer keyboard that works with the same proprietary USB connectivity as the mouse.
    A short time later I began to notice the keyboard would "seem to stop talking to the computer," (my assumption,) and I would lose control of Logic for a short time.
    This would seem to happen 30-40% of the time I am in Logic and when it does, it may last for a few seconds to a minute or so, much like how you describe.:eeek:
    After that moment or two of me cursing, it usually then works again.
    I do not see this issue when I run Avid Media Composer on the same system (or any other software,) it only happens in Logic...

    This may have nothing to do with your issue but brought it up because we're both running machines from the same relative era and if there's some sort of firm-ware issue regarding wireless USB dongles, it might give you some insight & me some peace of mind. :rolleyes:

    All the Best!
  13. mt100uk

    mt100uk Senior member

    Well my mac seems a lot happier at 10.7.5 with this issue (than with 10.8.x). When bad it would take up to 20s to respond to the space bar to stop (although it was always prompt from my mackie control) and forget about trying pull down menus when playing back.
  14. There was indeed a bug in the Logic 9.1.x + OS X 10.8 combo that did exactly this. I experienced it a few times myself, and it seemed to be related to spectrum analyzers in Channel EQ, Multi-Comp, etc. You can turn the Analyze function off in the EQ to avoid it most of the time.

    But despite the OP's issue, which appears to be different, this bug was fixed for most in Logic 9.1.8 and OS 10.8.4 (latest versions). I've spent many hours mixing in this combo, with no "loss of control".
  15. mt100uk

    mt100uk Senior member

    Have to disagree, definitely had this issue with a fresh 10.8.4/9.1.8 install on my 2011 iMac. I previously had this issue (with 10.8.3/9.1.7/8) and upgraded through, thought it was solved but it came right back!
  16. Ugh! I wonder if it's related to unique GPU or GPU drivers, then? If so, fixes may roll out slowly. With any luck, the graphics changes in 10.9 (OpenGL/OpenCL) may have some effect. And/or Logic X with All New Clean Codeâ„¢ will be out by then as well. :)

Share This Page