Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic 9 corrupted- playback issues/freezing

Discussion in 'Logic 9' started by beatattitude, Aug 10, 2012.

  1. beatattitude

    beatattitude Member

    Hi guys, a little urgent help is needed!

    As is typical, Logic 9 works fine for months, and then a client comes to record, and it all goes pear-shaped...I've sent him away, hopefully I'll have it fixed by this afternoon.

    When I load up any song file, and try to press play, Logic acts buggy.

    I usually press play with the "number pad Enter" button, but this instead acts like a left-click of the mouse, drawing a selection box on the arrange window when I move the mouse.

    The mac then becomes totally unresponsive to mouse clicks. I press Cmd-Alt-esc, and that seems to let me get back in, and I can close any open windows.

    Logic can be controlled a little with e.g. the space bar, to make the music play, but even then, it is erratic.

    The issue started yesterday when I happened to be playing with the ES2, and using my novation49SL MkII controller keyboard, with the automap software. I rarely use this, but it always boots up with logic automatically, and the novation keyboard usually works fine. I'm not sure if this is connected, or if it's incidental.

    I'm wondering if somehow the keyboard settings or key commands have been corrupted or something?

    What I've tried:

    1. Removing the and, and then booting into a song (same issue)
    2. Removing the Logic Pro application from the Applications folder, and reinstalling it from the CD (installation failed-no explanation why)
    3. Using Time-Machine to copy the old Logic Pro Application file from a month ago. (same issue)

    Model Name: iMac
    Model Identifier: iMac11,1
    Processor Name: Intel Core i7
    Processor Speed: 2.8 GHz
    Number Of Processors: 1
    Total Number Of Cores: 4
    L2 Cache (per core): 256 KB
    L3 Cache: 8 MB
    Memory: 8 GB

    Running Snow Leopard with latest version of Logic 9.
    Soundcard is a Prism Orpheus.


    Should I be reinstalling soundcard drivers?
    Should I be completely reinstalling Logic? Why did the installation from CD fail?
  3. beatattitude

    beatattitude Member

    Update: Tried booting with core audio disabled. Same problems with keyboard/mouse control. I suspect that it's something to do with the keyboard/mouse drivers, or even key-commands settings.

    My keyboard is wired, and my mouse wireless. The batteries on the mouse got replaced yesterday.

    Both have been working well for a couple of years.
  4. Pete Thomas

    Pete Thomas Administrator Staff Member

    You say it's typical. I don't think it is generally, though obviously it is for you, or rather your system.

    If it's typical, how did you resolve the issue when it happened before?

    Yes, trashing preferences is the first thing to try.

    Check if it happens on all projects, and newly created projects (from scratch as well as previously created template)

    Things that get corrupted are preferences and project files, I think it's rare for an application, though I think the dock shortcut or alias can.
  5. beatattitude

    beatattitude Member

    Sorry, by "typical" I meant it as a general recognition of life's ironies, or "sod's law", rather than being about Logic specifically!

    It happens on previously fine projects and also on newly created empty projects.

    Which preferences files do I have to trash?

    Is there a key commands file that I should trash?

    Many thanks for the response.

  6. Pete Thomas

    Pete Thomas Administrator Staff Member

    The ones you mentioned are the files to trash. I would actually trash them rather than just move, but maybe just moving them is fine.

    Key commands are included in

    Sorry I can't help you more, apart from advise having an external drive with bootable backup of a system with a stable Logic, especially if you are working professionally and have client/deadlines.

    These days with SSD drives and Thunderbolt, you can easily work off bootable external drives.

    The problem with Time Machine is you need to know what is actually causing the issue in order to restore, with a bootable backlup of a Fresh working install, you just go easily back to a state before anything dodgy happened.
  7. Gravity Jim

    Gravity Jim Member

    If you have any kind of third party control surface running... Get rid of it, trash both the .plist and .cs files, and it should clear up. My identicall woes were traced by an Apple tech to an anomaly in the Tascam Mackie Control emulation... When I ditched the Mackie Control in Logic it ran perfectly and has for a couple of 10-hour days in a row.
  8. beatattitude

    beatattitude Member

    So I should look for Novation 49sl stuff, and automap files with .cs suffixes in that preferences folder, and delete those?

    That's what I'll try. I've since set up a new user account on the imac, and Logic is working fine within that (albeit with the default key command set...can anyone remind me how to restore my own key command set?)
  9. Pete Thomas

    Pete Thomas Administrator Staff Member

    Put back the original file

    Hopefully it wasn't something else in there causing the issue.

    Glad you got i sorted.
  10. beatattitude

    beatattitude Member


    Fixed the issue: it was caused by using the number pad as a mouse... Found this on another forum...

    "Go to System Prefs > Universal Access > Mouse, and see if the Mouse Keys ON button is selected.

    That lets you use the numeric pad instead of your mouse."

    That was the problem. Using the keypad caused the mouse itself to stop clicking, thus creating the impression that the system was hanging.

    Thanks for the suggestions above, appreciate it.

  11. dreamteam

    dreamteam New Member

    Problem Solved - AC-7 Core

    Logic would crash as soon as it would launch. I really did not want to restore from backup.

    I just want to thank you. I was using AC-7 Core. It killed my logic however I have used it earlier this year with no issues.

    I have been trouble shooting this for hours upon hours and this finally solved my problem.

    thank you!
  12. Roger Jackson

    Roger Jackson Member

    Thank you very much for sharing this solution. That's the great value of this board.

    Roger Jackson
    Film Music
  13. doofus

    doofus Member

    probably obvious but before trashing prefs, open your key commands and export them to the desktop so you can re-import them after you trash prefs, otherwise you'll lose any custom key commands.

Share This Page