1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic 9 + Mackie Control

Discussion in 'Logic 9' started by mk3, Apr 12, 2011.

  1. mk3

    mk3 Senior member

    Hello, all -

    I just acquired a brand new Mackie Control Universal Pro, firmware 4.02 with the new Alps faders.

    All is working beautifully except for one concern:

    Playback of automation from Logic leads to jerky stop-start stepwise motion of the faders on the Mackie, especially for slow automation moves. This is true whether the curves were drawn in, or recorded from smooth fader moves on the Mackie. Fader moves on various YouTube videos seem to be very smooth.

    Any advice would be much appreciated!

    Tech info:
    Mac Pro 2008 8-core 2.8GHz 18GB RAM
    Mac OSX Snow Leopard 10.6.7
    Logic 9.1.3
    Mackie connected directly to USB port

    Troubleshooting attempted:
    - restart
    - remove all MIDI drivers
    - disconnect all other USB devices
    - try different USB cable
    - try different USB port
    - Delete ~/Library/Preferences/com.apple.logic.pro.cs
    - restart under different new user account
    - remove all third-party Audio Units
    - blank Logic project
    - turn on and off "Touchless Faders"
    - delete and re-add Control Surface to Logic
    - run Onyx (rebuild permissions, caches, etc)
    - connect to laptop (MacBook Pro) instead -> same problem
    - cursing
    - sweet-talking
    - shot of vodka

    Thank you for any guidance!

  3. tigerman

    tigerman Senior member

    i think it's a limitaton of logic control, mine does the same, basically a fader won't move until it has reached a certain step from the latest move, dunno why, maybe in order to avoid faders motors always active, or midi floods...

    also remember that logic automations for third party plug-ins has a very bad resolution stucked to 127 or even 100 steps, i this case stepping is a consequence of it.
  4. mk3

    mk3 Senior member

    Thank you for the reply....
    I have seen videos online of completely smooth motion, though, such as this:

    So that was what I expected when I bought the unit. I did insist on buying the latest version, with the Alps rather than P&G faders. Mackie support actually told me that the Alps faders are quieter than the P&G, addressing the common complaint of fader noise in the MCUs, but that the P&Gs may actually have the smoother motion. So perhaps the video shown is a unit with the P&G faders. Still, Mackie told me the jerkiness should be subtle, and that one would have to look closely. My unit has jerkiness that is far from subtle!

    Does your unit have the Alps or P&G faders?
  5. tigerman

    tigerman Senior member

    on the video you posted movement are quite large and fast, you can get the same on yours with no problems.

    the stepping is visible on very thin e long automations as you have already said.

    the Alps and P&G difference i think have no effect on how the controller works, as mackie have said to you they are only more quiet than older ones.

    mine is a logic control, first version, old firmware, can't switch to mackie control, never upgraded, i have xt expansion aswell, 8 more channels.

  6. mk3

    mk3 Senior member

    Unfortunately mine is steppy even at moderate speeds.

    Is that really the best I can expect? Truly surprising, if so.

    Thank you again for any suggestions!

    All the best,
  7. tigerman

    tigerman Senior member

    mmhh it looks you have more stepping as expected, but to be sure i would like to try the same and see differences on mine compared to your videos, but it looks you have something wrong, do you have any midi port to try if it does the same using it by midi ?

    i've never connected them by usb to be honest

    also when you light it on does the faders go by steps aswell? or is linear ?

    EDIT: ok i've tried, no, you have something for sure, best would be trying using it by midi if you can and see what happens

    also there's a "midi bandwidth" option in logic, dunno if it applies to usb aswell but try putting the slider at 100%
  8. mk3

    mk3 Senior member

    In the meanwhile I just got the word back from Mackie tech support, who took a look at my videos as well. They informed me that this behavior was normal for the new revision with the Alps faders! Apparently, the belt-drive Alps faders move in these increments. The older design with the P&G is probably what you have. (Alps only added to MCU version 4.02; version # appears at startup). The P&G were string-driven, which was smoother, but apparently the strings would eventually stretch and lose tension, leading to all sorts of technical and reliability issues. Also users complained about the noise of the P&G faders. So these Alps are quieter, but it looks like the steppy motion is something one must just live with.

    I have the unit connected directly via USB. I also tried connecting it to a laptop (with no other USB devices connecte), with the same result. I can try with MIDI cables as well, but I suspect it will not help...

    When I turn it on the faders snap very fast into place. So such very fast sudden motion is fine.

    Is yours indeed a P&G unit?
  9. tigerman

    tigerman Senior member

    yeah for sure, i've bought it in 2003 :)
    i would give midi a try anyway... who knows at this point :D
  10. tigerman

    tigerman Senior member

    when you light it on they does not do the test? faders goes all the way up and then down like a wave, maybe new firmwares does not do that ?
  11. mk3

    mk3 Senior member

    For this model, they just all go up and down once, quickly, but all together, not as a wave. That motion is smooth, but it's really probably moving at the maximum speed, just snapping into place, so it does not show the stepping problem at all. I wish there were a more full hardware self-test, which would help troubleshoot. At least then I would know whether I should bother any further software (on the Mac) or USB troubleshooting, etc. If Mackie is right that this is a hardware limitation, then there is not much I can do. I would still love to know from other users with this same Alps unit whether they have the same performance, just in case I have a lemon unit, or there is something wrong with how I have configured matters.

    I can try further optimizing settings within Logic's control surface settings, but nothing I did there thus far made any difference!

    All the best,
  12. mk3

    mk3 Senior member

    I just tried it via MIDI connection instead of USB.
    I let Logic automatically add the MCU with its default settings.
    Same steppy motion!

    But worth a try, as you said.


Share This Page