Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic 9 recording glitch and the Tascam DM4800

Discussion in 'Logic 9' started by GaryJackson, Aug 28, 2012.

  1. GaryJackson

    GaryJackson Member


    I have Logic 9 and a Tascam DM4800. All my automation and console functions work however there is a strange issue sometimes when I press the record button on the DM4800, the recording starts but when I press stop, it stops and starts to re-record over the last few bars of the recording. I try and stop it by clicking the stop button on the transport control in logic 9 software, also the transport control on the mixer but it keeps trying to lay more and more tracks over the last few bars..

    Anyone have any ideas why this might be going on? The only thing I can think of is that Logic and the Tascam are not quite talking together properly or that I have missed a simple setting in Logic somewhere.

    The error is inconsistant and only happens when I use the transport contols on the mixer so I think its that rather than Logic but when it happens it dicks up the whole recording so I have to exit without saving, subsequently loosing everything.

    Any help would be appreciated.
  3. Gravity Jim

    Gravity Jim Member

    Hi, Gary. I use a DM3200, and just recently switched from DP to Logic Pro.

    First, if you're running Mountain Lion on your Mac, you may have unfixable weirdness between Logic's transport and the DM's drivers no matter what you do. I didn't get my system stabilized until a kindly Apple Pro Apps tech essentailly told me to go back to Lion until things shake out.

    But if you're still running an earlier version of OS X, then the problem is easy to fix.

    Under Preferences, go to Controller Assignments, and from the list on the left hand side choose "Transport/V-Pot Overlay." Then, in the list in the center, one at a time choose the basic transport functions: Stop, Play, Record and Scrub. Each time, you'll see the controls complete mapping in the panel on the far right.... and at the bottom, you'll see that the default for each of these if to have the "Key Repeat" box checked.

    Uncheck it, and Logic will stop doing that crazy stuff. :) I got this from another DM user I knew from the now disabled Tascam boards who also haunts this forum.

    BTW, a group of us who used to hang on the Tascam foums are slowly starting back up from scratch. Join us, if you like.
  4. GaryJackson

    GaryJackson Member

    Thanks Jim,

    I have Lion and didn't upgrade to Mountain Lion yet. Tascam said that they have not sorted out any drivers for it yet etc...

    Thanks for the tip, I will give it a try this weekend and let you know what happens. Will join the Tascam forum as well, is there any reason that Tascam took down the old one? Just curious....

  5. Gravity Jim

    Gravity Jim Member

    The old one wasn't an official Tascam forum. The guy who started and ran it for many years had been ill for a long time, and when he died last year nobody was prepared to pick up the slack. His survivors supposedly have the content from the old site, and a placeholder name for resurrecting it, but nothing happened for so long that one of the guys from that forum established a replacement. Not much there, as it has just begun, but more members will mean more content.
  6. GaryJackson

    GaryJackson Member

    Cheers Jim,

    I unchecked all of those annoying boxes and it worked. Problem solved...Thanks ! :)
  7. Gravity Jim

    Gravity Jim Member

    Alright now! Same deal here... Even with OSC and LPTouch drivers installed, the transport controls (even the jog wheel) on the DM Work perfectly.

Share This Page