PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic Can't Find EWQLSO Gold

Discussion in 'Logic 9' started by Billious, Sep 20, 2010.

  1. Billious

    Billious Member

    Hi there,

    I've recently upgraded to Logic 9, bigger & faster HD, more RAM, etc. I've been transferring everything from the old HD manually, so I can leave out the 2.5 years of accumulated junk. Re-installed Akoustik Piano and EWQLSO Gold, and updated them. They both work fine in stand-alone mode, but when I try to use them from within Logic, Akoustik Piano is there, but Logic simply can't find EWQLSO Gold.

    Does anyone know why this would be and, more importantly, what I can do about it?

    More details: I did a custom install of EWQLSO Gold, leaving out the VST and RTAS versions but including the AU version. The 'puter's a Macbook 2.4GHz Core 2 Duo, 4GB RAM, OS 10.6.4, Logic 9.1.1

    Any help would be most appreciated.

    Cheers, Bill Canty
  3. sonnykeyes

    sonnykeyes Senior member

    When I recently bought EWQLSO Silver, the package and documentation all referred to an authorization method that involved Challenge/Response, but apparently the Play plug-in only works with iLok now. Not sure if this is the problem you're having, but I was only able to discover this by trial-and-error, and I ended up with a red-faced tech at EW agreeing that stickering the box might be a good idea.
  4. georgelegeriii

    georgelegeriii Senior member

    Is it the Kontakt version or the play version?
  5. Markdvc

    Markdvc Administrator Staff Member

    Just to add to George's very sensible question, could it be that you tried to validate in 64 bit mode, and the EWQLSO player you installed is 32 bit only?

    As an aside - this isn't directly related to your problem - bear in mind that, if you are using the EWQLSO with Kontakt in Logic, you need to load some EWQLSO preset in Kontakt standalone in order to complete authorisation before attempting in Logic.

    kind regards

  6. Billious

    Billious Member

    It's the Kontakt (Kompakt?) version, thanks George.
  7. Billious

    Billious Member

    Thanks for your response, Sonny, but I don't think that's the problem. It's the original version of EWQLSO, i.e. before Play was released, and I've easily been able to authorize it using N-I's Service Centre; it runs fine in stand-alone mode.

    Cheers, Bill
  8. georgelegeriii

    georgelegeriii Senior member

    What version of Kontakt are you running? I have always had a real challenge installing and updating any of these old libraries.

    Here are a few things I do know: go to NI's site and make sure to download the latest installer, and read all the notes about authorizing. If I remember, you have to authorize things first, but the authorizer app is not compatible, and will often crash during the process.

    I am unsure IF you can actually do this anymore...
  9. Billious

    Billious Member

    Thanks Mark. According to Logic's "About Logic Pro" window it's in 32-bit mode, and my EWQLSO version was bought, AFAIK, before 64-bit mode was available, so I'd be surprized if it even *can* run in 64-bit mode.

    I've tested in standalone and it works fine. Does it make any difference that I'm using Kompakt, not Kontakt?
  10. georgelegeriii

    georgelegeriii Senior member

    Kompakt is not compatible with Logic Pro and Mac OS 10.6. I suggest you upgrade to Kontakt Player 4 which is free.
  11. Markdvc

    Markdvc Administrator Staff Member

    Bill,if it is Kompakt, this I believe is PPC only, so you won't be able to run it in Logic running natively on an Intel Mac.

    FWIW, I have an older version of the EWQLSO Platinum orchestra. I authorized it using the Kompakt player that came with it running standalone in Rosetta on my Mac Pro, but I use it with the full version of Kontakt in Logic. If you don't have this, you could ask NI about whether your library will work with Kontakt Player 4

    kind regards

  12. zerobeat

    zerobeat Senior member

    NI and Eastwest abandoned Kompakt years ago and haven't worked in Macs since around 2006. You need to use those libraries in the free Kontakt Player (or buy the full version of Kontakt).
  13. Billious

    Billious Member

    Thanks for the info, George and Mark! :)

    That's it, mystery solved. Akoustik Piano works standalone *and* within Logic 9 because it's a UB. EWQLSO works standalone (under Rosetta, which I installed to run SoundDiver) but not within Logic.

    Lesson learned: finish projects before the constant improvement of technology makes it impossible.

    Cheers, Bill
  14. Billious

    Billious Member

    Ah, f-erenc! Good to see you're still around! :)

    Thanks for confirming what George and Mark have said.

Share This Page