PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic crashes when bouncing or saving on Snow Leopard - help needed!

Discussion in 'Mac OS' started by soundmonger, Jul 5, 2011.

  1. soundmonger

    soundmonger New Member

    Hi there,

    I've recently upgraded to Snow Leopard and have ever since not been able to run Logic Pro properly. It crashes every time I try to bounce anything or save the session as a new project. Since I was still running Logic 8 I thought an upgrade would do the trick, but I've just installed the latest version of 9 (9.1.4), plus Pro Kit & Pro Applications updates but still get the exact same issues (screen flashes, then logic quits 'unexpectedly').

    My system is as follows:

    MacBook Pro 2,2
    2.33 GHz Intel Core 2 Duo
    3 GB 667 MHz DDR2 SDRAM
    Mac OS X - 10.6.8 Snow Leopard
    Sound Card: Mbox 2
    Logic Pro 9.1.4

    I've looked at the error report, but am unable detect the problem from it. Also can't seem to find any clues in any other forums.

    I'm quite desperate to sort this issue out, as I have some tracks to submit soon, so if anyone has experienced a similar problem and knows how this can be fixed, please let me know! Your help is much appreciated.

  3. daveyboy

    daveyboy Senior member

    Try trashing your logic preferences and rebuilding permissions. Also try a new test project to see if you're having issues with a clean slate.
  4. ffd39

    ffd39 New Member

    Hi...Have the same problem. :brkwl:Had to upgrade from Leopard to SL due to the new Duet2...Have to "force quit" Logic when trying to save or bounce.
    However, I cannot find the preferences file. Find the PREFERENCES but there is NO file related to Logic...?
    Quite "problematic" not beeing able to save the!

    Would it help with upgrading to LP9?...

    Thanx for ANY help!

    My system:
    Imac mid 2007, OSX Snow Leopard, 4GB RAM, Logic 8
  5. crunchie

    crunchie New Member

    Since I upgraded from 10.5.8 to 10.6.8 both of my Logic Pro apps (8.0.2 and 9.1.5) crash when I try to bounce a track. The only way I can create a mixdown is to do it in realtime (pressing Play) and recording the stream to the hard drive using AudioHijack.

    This is crazy! There must be an easier fix than wiping my hard drive and reinstalling Snow Leopard from scratch.

    Please help!
  6. ffd39

    ffd39 New Member

    I couldn´t agre more...! What is Apple thinking?...
    There MUST be a workaround without a NEW install (I have dozens of Plug-ins etc. I am not able to find back to...)

    I have to write Steve...!:cool:
  7. crunchie

    crunchie New Member


    I emailed Topher at MacFixit ( and he was very helpful and told me to do this:-

    "Go to the /Macintosh HD/System/Library/PrivateFrameworks/ folder and move the "Prokit.framework" folder (and the "ProKit(SnowLeopard).framework" folder if also present) to the Desktop. Delete the original(s). Then download and install Prokit 7.0 from this link:
    Restart and launch Logic". All should now be well again.

  8. ffd39

    ffd39 New Member

    YESS! FInally got it from Simon...!
    THANX to ya all!
    I owe u one (ok..two then)...!
    Hope I can be of assistance to others later on.
    Take care!
    Harald :)
  9. DB74

    DB74 New Member

    Thank you so much for posting this reply, i've been going out of my mind trying to get logic pro 9 to stop crashing when i import audio or try to save.

    I've been searching every forum on the net for three weeks until today.

    This fix worked first time, no stress, no hassle!!

    Happy days.
  10. belee

    belee New Member

    THANK YOU! This worked. THANK YOU.

    ""Go to the /Macintosh HD/System/Library/PrivateFrameworks/ folder and move the "Prokit.framework" folder (and the "ProKit(SnowLeopard).framework" folder if also present) to the Desktop. Delete the original(s). Then download and install Prokit 7.0 from this link:
    Restart and launch Logic". All should now be well again.""
  11. oisindub

    oisindub New Member

    Logic crashing on save

    I had the same problem and am glad to report that Topher's solution worked.
    I did all the usual deleting preferences etc and none it worked until I deleted the ProKit files and updated them as described in the post above.
  12. Jeffro

    Jeffro New Member

    Thanks crunchie, I had similar problems with Logic 8 crashing in OSX 10.6.8

    Installing protoolkit 7.0 fixed my issues (so far)

    Wonder why this updated was not pushed automatically by Apple software update?
  13. jparadise

    jparadise New Member

    Thank You SOOOOO MUCH!
  14. Atticus

    Atticus New Member

    Hello Savvy Users,
    I installed Snow Leopard yesterday and today I'm unable to SAVE or SAVE AS my Logic 8.0.2 Projects.
    I tried to apply the above solution but I apparently do not have a "Privateframeworks" folder. Any other ideas...?
  15. Atticus

    Atticus New Member

    PS I did a spotlight search and I also apparently do not have ProTooKit.
    Everything worked beautifully with plain old Leopard. Aaaargh.
  16. Atticus

    Atticus New Member

    I clicked on the above link to download Prokit 7.0 and was unable to because I have a newer version already installed... Not sure what to try next...
  17. Atticus

    Atticus New Member

    Thank YOU Crunchie!

    Finally found the folder and the problem is fixed!!!! Thank you SO MUCH!
    One question:
    Is it safe to entirely delete the Prokit folders that you had us drag to the desktop?

    Thanks again:)
  18. markov

    markov New Member

    Hey Atticus i got exactly the same problem as you i cant find the folder that contains the prokit and when im trying to install prokit 7 i got the message that i got a newer version.How did you manage to find the file?I really need help this is driving me crazy!!!
  19. Atticus

    Atticus New Member

    Markov, I replied to your private message. In a nutshell, check again. I did, and they there were... :)
  20. pentagramwookie

    pentagramwookie New Member


    Tophers solution worked for me too, thanks for posting that!!! :D

    Spotlight doesn't find files in the system folder so you manually have to go to /Macintosh HD/System/Library/PrivateFrameworks/ to find the files to erase.

  21. Patric

    Patric New Member

    Thanx a lot! Now it seems to work. The files I placed at the desktop, what should I do with them?

Share This Page