Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic/Mackie Control Behaving Erratically in Logic 9?

Discussion in 'Logic 9' started by christophertin, Sep 23, 2009.

  1. christophertin

    christophertin New Member

    Hey Logic gurus,

    I was wondering if anyone else was having trouble with their Logic or Mackie Controls, or if anyone might be able to spot what it is that might be causing me trouble.

    The shuttle on my LC has suddenly started behaving crazily. If I rotate it just one notch, it jumps ahead 60-something bars. Another notch and it jumps ahead to the end of the session... etc. etc. Moving it back, it seems to get caught on bar 4.

    Is there a preference file that's gone corrupt or something? Anyone else have any similar problems?

    (Note, that it's not the hardware either--I have both a Logic AND Mackie control, and they're both doing this.)


  3. Markdvc

    Markdvc Administrator Staff Member

    I haven't noticed anything like this, am using a MCU with XT and c4, connected through a Unitor 8 Mk II, running Logic 9 in OS 10.5.8 and testing 10.6.1.

    Can you provide some more systemdetails?

    kind regards

  4. christophertin

    christophertin New Member

    Well, in the 20 minutes since I created this thread, I trashed my preferences--and that seemed to solve the problem.

    Amazing. Sorry to clutter the forum--maybe I should have tried harder before posting in a panic like that! Mods, feel free to delete this thread.
  5. Markdvc

    Markdvc Administrator Staff Member

    Well done!

    Absolutely no need to apologize.

    Actually, it is worth leaving it stand, deleting prefs is often the solution - as you have illustrated. It would be interesting to be able to fathom just what can cause a pref file to get in the state where it seems to result in such behaviour.

    kind regards

  6. Robert Wilson

    Robert Wilson Senior member

    Not exactly the same issue but I had similar problems with my yamaha 01x shuttle wheel on L9.0.0. Upgrading to 9.0.1 seems to have fixed it.
  7. Valis

    Valis New Member

    For some reason they have chosen to save Logic prefs on exit of the application, instead of just when you close prefpanel. Should logic perhaps not exit completely gracefully things can really go awry, though I imagine some of the corruption also occurs when saving a heavy project while closing the app. At least that's been my experience, and carefully saving then closing a project before closing Logic seems to have made the issue more rarified...

Share This Page