1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic Pro 10.0.7 released

Discussion in 'Logic Pro X' started by Markdvc, May 13, 2014.

  1. Markdvc

    Markdvc Administrator Staff Member

  3. Orren Merton

    Orren Merton Logic Samurai / Administrator Staff Member

    That is a huge list of enhancement and fixes!

  4. Kim Olesen

    Kim Olesen New Member

    Color me impressed.
  5. Colin Shapiro

    Colin Shapiro Senior member

    Huge and impressive…though it's a little scary to find out just how many things were faulty! :eeek:
  6. Eli

    Eli Senior member

  7. Antaren

    Antaren Senior member

    Yeah. We've been beta testers. They should pay us for it!:D

    Anyone try it yet? Hopefully they haven't created other problems! ;)

  8. Colin Shapiro

    Colin Shapiro Senior member

  9. Antaren

    Antaren Senior member

    I know this one is going to make a lot of people happy!
  10. Eli

    Eli Senior member

  11. Colin Shapiro

    Colin Shapiro Senior member

    Nice Eli - thanks!
  12. Orren Merton

    Orren Merton Logic Samurai / Administrator Staff Member

  13. daveyboy

    daveyboy Senior member

    That's an insane list of changes to digest! I downloaded it immediately and started using it immediately on a new song. I had a good 3 crashes but auto save "saved" me as always. I'll look forward to diving in deeper soon.

    Sent from my iPad using Tapatalk
  14. mt100uk

    mt100uk Senior member

    That's a great list of improvements, the elves have been busy. A good mix of fixes and new features, hopefully they can keep up this momentum!

    Sent from my iPhone using Tapatalk
  15. lpmusic

    lpmusic New Member

    App Store fails to download Logic after Mavericks 10.9.3

    Hey guys,
    I've been trying to download Logic X from the App Store for the past 6 hours and the download gets interrupted.
    I've tried different locations with WI-FI and Ethernet. Tried every suggestion posted on online forums and still nothing.
    Does anybody else have the same issue?
    I've found hundreds of posts from people complaining about this in the past months but nothing recent.
    I'm stuck!
    I had Logic 10.0.6 installed then after attempting to update so many times, one of the suggestions was to remove it and download it freshly from the APP Store. Now I have nothing...

    Thanks for your help!

Share This Page