1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic Pro 9 Update???

Discussion in 'Logic 9' started by shauns303, Oct 21, 2010.

  1. shauns303

    shauns303 New Member

    ive been searching this forum for a while now to solve a couple of issues ive been having. I was first looking to find why my Native Instruments plug ins were not showing up in Logic as a plug in. I tried the Au Units Manager, did all there is to do there, and nothing.

    Then I came across a thread saying that curtain Plug Ins only work in 32 bit or 62 bit, but I was not sure which one I was running. I tried finding it, but Im clueless. So I thought id try and update my Logic Pro 9 to 9.1.2 because Im currently running 9.0.0

    So I downloaded the update. went to open it and it was telling me there is no eligible version of logic pro in my applications folder... So...... I came back to this forum and found that people were having to rename the app back to Logic Pro.app and it must be in your App folder... So i do this, but to no provale. By Application Folder, do you mean the app icon in the side bar? or the App folder in the User? because that folder is empty. I tried putting It in both with the name Logic Pro.app but still no succes. It still tells me that there is no eligible version in the app folder.

    Why is this? Why??? Iv been running and using this logic for almost 2 years now and have a legitimate key. So why is it not letting me update. Do I need to update? Any other suggestions on where to find my plug ins? What is this 32 bit? 62 bit stuff? Im a bit new at this so... yeah. Sorry for the long thread with lots of questions, but I just want to get to the bottom of this and start using Logic Pro at its full potential.
    Im using a Macbook 2.4ghz, 2gb ram. Snow Leopard 10.6.4

    Thanks in advance for any help and info.... Peace
  3. Pete Thomas

    Pete Thomas Administrator Staff Member

    First, don't worry about 64 bit (NB it's 64 not 62) unless you need to address more RAM. Let us know more about your system and plugins and you will get a more specific answer. But currently your Logic 9.0 is 32 bit so that is not the issue anyway, and also you will only benefit from 64 bit if/when you get more than 4 GB ram.

    It's normally the main application folder, not the user one. Unless you have different users with different software, don't worry about that.

    What happens when you try the automatic update from System Prefences>software update? Does it offer you a logic update there?
  4. shauns303

    shauns303 New Member

    Thanks for the quick reply. Well when i try and do the software updates, Logic does not apear, so thats why I had to down load it from apple. The plug in im using is Battery 3. I use it fine as its own app, but I just cant find it in Logic. Is there a curtain path I should be giving it? Im not sure what other information I could give you about my system. Sorry. Anything specific? I have been having some thoughts of recent to update to a new macbook pro with the 4 gig of ram etc... Would that be worth it? The old macbook is getting a bit slow now. especially in Logic. Sorry if im not giving enough info. Im not really sure what else I can say.

    Thanks again
  5. Jay Asher

    Jay Asher Senior member

    If you are using Logic 9 64 bit, you need to temporarily turn it back to 32 bit to scan for new plug-ins.
  6. CSeye

    CSeye Senior member

    A while back I modified the name of Logic Pro in the Applications folder to reflect Amplidood's GUI mod.

    Software updater didn't "see" Logic and neither did the 9.1.2 updater. It was telling me I did not have a valid version in the Apps folder.

    Yet I could log into the Logic download area at the Apple website using my Logic 8 serial number. The only update it offered me was 9.1.1. ???

    So, two things needed to be done:
    1. I returned the name of the app to just Logic Pro in the Apps folder.
    2. I removed the Logic Studio System ID
    Macintosh HD>Library>Application Support>ProApps> Logic Studio System ID.

    As a result of #2;) I was required to enter my Logic 8 serial number the next time I launched Logic. The 9.1.2 updater then did it's job. :thmbup:
  7. shauns303

    shauns303 New Member

    I appreciate everyones comments but Im not sure if you all understand. I have tried all of these suggestions. I do not have a Pro Apps Folder anywhere on my mac, and I cant for the life of me see where there is an option to change between 32 bit or 64 bit. Assuming its impossible for me to have 64 bit even available. There is two questions....

    1) How can I get my Logic Pro 9 to update???? Im running 9.0.0.....

    2) Why cant I see any of my Native Instrument Plug ins???? They are apart of the Komplete 7 pack. Not the current versions but the ones before...

    I didnt need a serial to download the update from the apple site. I have changed the name back to Logic Pro.app , put it in the apps folder. Should i try getting the update from else where? Im running the latest version of Leopard, (which i wouldnt be surprised if this has something to do with, for just about every app i have stuffed up once Leopard was installed). Should I uninstall and re install anything? I dont want loose any projects though. Should i update my mac to get the 64 bit version? I dont know... Im out of ideas which is why am here...

    Any help would be amazing, Thanks again everyone
  8. Markdvc

    Markdvc Administrator Staff Member

    The Folder that logic pro needs to be in is not called pro apps, it is called applications, is to be found on your system HD and should actually contain all your apps. Look where safari, itunes or mail reside on your Mac. That should be the applications folder, and that is where logic pro needs to be. Make sure it isn't in any subfolder in applications either.

    You need to find logic pro on your system. Then, press Command + i (Apple + i), this will open a dialogue window in which you can switch from 32 bit to 64 bit. Alternatively, command click or right click logic pro, then click on "get info" to open the same dialogue.

    If all the criteria everyone in this thread mentioned to you are fullfilled, you will be able to update. Incidentally, this is mentioned in FAQ 13

    Again, this may be dues to having Logic pro running in 64 bit mode, in which case it wont AU Validate any 32 bit Plugins. You need to establish this first of all. If after that, you still don't see your NI Plugins, you need to start troubleshooting. Can you open them standalone?

    OK, please describe the full path of the apps folder you refer to. It seems that this is not the applications folder we are all mentioning to you.


    That sounds very much like your system has some fundamental problems. FWIW, every app I have here is running fine under SL, including all the Apple Pro Apps (Logic Studio, Final Cut Studio, Aperture, Shake) as well as Adobe CS 3, Capture NX 2, NI Komplete 4, 5, 6 and 7, , Spectrasonics stuff, Korg KLC stuff, Nuendo 5, the usual bread and butter apps such as Safari, Mail, iLife - the list goes on.

    Perhaps you need someone able to troubleshoot your Mac to have a closer (meaning on site) look at it.

    kind regards

  9. shauns303

    shauns303 New Member

    Ok Look,

    1) Im well aware of what the Application Folder is and where it is. I use it more times a day than i scratch myself. I never said I couldnt find it. I just said that others on this thread mentioned to delete the system ID from the Pro App folder which i do not have...

    2) As I said in the first post, I tried to do the get info on the app to see if i could switch between 32 and 64 but it is not there... Again I said that I possibly do not have 64 bit running. The only option it gives me is to "open using rosella" which doesnt do anything.

    3) I know how to use my mac well and keep it very clean and updated. Please dont make me sound like a nuff. Snow leopard did play games with alot of my apps, and I have followed criteria from numeras sites and forums on these issues, For about a week before posting this problem.

    Could someone reply with some new HELPFULL information please.... PETE THOMAS??? You still there??? Anyone???

    I would like to add some screen shots to show you what im doing step by step. I have the shots ready but is there a way of posting them here???

    Thank you
  10. Markdvc

    Markdvc Administrator Staff Member

    Sorry if all that was of no help. Reading through your posts again, one thing is now clear to me - you still have Logic 9.0.0 installed, this only runs in 32 bit mode so you are right, at present you will not see an option to switch between 32 and 64 bit mode. Logic has the option to run 64 bit since 9.1.0, but not on every Intel Mac. My first generation Core Duo Mac Book Pro won't run any apps in 64 bit mode, AFAIR this is possible with Core 2 Duo Notebooks. How old is your Mac Book?

    Incidentally, running 4 GB RAM, you wouldn't see any benefits switching to 64 bit anyway. It is all about being able to address very largte amounts of RAM.

    What remains unclear is why you can't update.

    kind regards

  11. shauns303

    shauns303 New Member

    Well here is my macs specs?

    Model Name: MacBook
    Model Identifier: MacBook4,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 3 MB
    Memory: 2 GB
    Bus Speed: 800 MHz
    Boot ROM Version: MB41.00C1.B00
    SMC Version (system): 1.31f1
    Serial Number (system): WQ81227P0P1
    Hardware UUID: 36174B24-E138-50C6-8673-36B2BA78687E
    Sudden Motion Sensor:
    State: Enabled

    Is there any way of me posting those screen shots???

  12. Markdvc

    Markdvc Administrator Staff Member

    Yes, if they are not too large, they may be posted in the forum. When you answer this, scroll down below the body of the message you are writing, you will see an "attach files" menu. How this works should be fairly self explanatory. Please note that graphic files are restircted to a mximum of 600 x 600 pixels and 97.7 kB.

    For larger stuff, we highly recommend skitch.com. UPload your files to skitch, then paste the URL into the forum using the "Insert Image" tag above the text body. It is the little icon showing a mountain range.

    BTW, this has already all been explained in more detail by my Admin colleagues here:


    kind regards

  13. shauns303

    shauns303 New Member

    Here are those screen shots...



    Removed by Admin - Serial Number visible!


  14. Rounik

    Rounik Member

    Hello shauns303,

    Don;t worry there is a simple solution to your problem. the Logic.app MUST reside in the Applications/ folder and be named "Logic Pro"

    DO NOT place it in a sub folder like you have done.

    The Logic updater will not look inside sub folders or other locations, so simply drag it back to Applications/ run the updater and you should be good to go.


  15. shauns303

    shauns303 New Member

    Well there you have it. It worked. I didn't really think about the sub folder. I didn't think it would matter, but it does. Thank you so much. Cant believe I didn't notice that.

    Now the big test, weather I can see my Plug Ins, I'll let you know...

  16. Markdvc

    Markdvc Administrator Staff Member

    I'm glad it worked out. As I mentioned, the FAQ does cover this, it is well worth reading these things very carefully.

    I removed one of your screenshots, you really don't want your Logic Serial Number to be visible on the internet for all to see.

    kind regards

  17. shauns303

    shauns303 New Member

    Thanks, yeah me too. But I still have my main issue of my plug ins not working. Iv opened Battery 3 and Kontakt 2 but they dont seem to work in Logic. I had Guitar Rig 3 for a while now and that has always worked. But not these new ones? Heres another screen shot of what I mean...

  18. Markdvc

    Markdvc Administrator Staff Member

    I note that in one of your screenshots, you show the "open using rosetta" checkbox as being activated. That is a very bad idea for Logic 9, and completely unnecesary on an intel mac. It would also prevent logic loading any Intel compatible Audio Units, which could be the reason why your NI plugins aren't available. I strongly suggest that you uncheck this and try again. You might also find that logic will run a lot faster - and in deference to your comments about having problems with SL - a lot more stable. Did you by any chance migrate from a PPC Mac?


  19. shauns303

    shauns303 New Member

    NO NO.. Iv never had that box ticked. I was just showing it in the picture so you could see what I meant.

    Iv always just been on the macbook. So could you see what I meant in the last screen shot I put up? In the Audio Units Manager?
  20. Markdvc

    Markdvc Administrator Staff Member

    Ah, OK.

    No, actually, that screenshot of the AU Manager indicates that Logic recognizes the Plugins and they have been succesfully scanned. I don't see it showing that something might be wrong

    Can you make a screenshot of the Audio Unit pull down menu you use when trying to load an instance of one of the missing Plugins?

    kind regards

  21. shauns303

    shauns303 New Member

    ok, what about this one???

    And what does the nodes boxes unchecked mean, in my previous screen shot?
    It wont let me check them...


Share This Page