Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic remote

Discussion in 'Logic Pro X' started by djqwikcut, Aug 27, 2014.

  1. djqwikcut

    djqwikcut New Member

    Since I upgraded to the latest osx 10.9, the iPad logic remote app no longer connects. Does anyone know why? I can run a different remote app on my iPad and Logic finds it and The app can control logic. If anyone can tell me how to get this working, I'd appreciate it.
  3. Atlas

    Atlas Senior member

    Which versions of Logic Pro X and Logic Remote app are you running?
  4. djqwikcut

    djqwikcut New Member

    It's the latest remote app and the version of logic x before the update thAt was just released
  5. stv_collins

    stv_collins New Member

    I had a problem with Logic Remote when first came out, and tracked it down to an interaction with a 3rd party iPad logic control app. I think it was touchosc, but I'm not 100% sure. I had to make sure that Logic "forgot" about its linking to the third party app. This was quite a while ago, so I can't remember the details. Just wanted to get you pointed in the right direction.
  6. djqwikcut

    djqwikcut New Member

    I have done all of that. I made sure no other app is linked to LOGIC.. this all worked fine prior to OSX 10.9 .. This is the first time I have used it since 10.9 ...10.8 worked fine..
  7. stv_collins

    stv_collins New Member

    Sounds like you may have done this already, but about the only other suggestion I can offer is to follow these steps as outlined in the Apple support article:

    They specify the following sequence:

    Quit the Logic Remote app if it is running.
    Open Logic Pro X.
    Choose Logic Pro X > Control Surfaces > Setup.
    In the Setup window, delete any Touch OSC devices listed.
    If there is an existing Logic Remote in the setup window, delete it.
    Launch the Logic Remote app and connect to the Mac.
    Accept the connection when prompted in Logic Pro X.

    Note that they delete Logic Remote from LogicX's setup also, and then reconnect it. I have a vague recollection that there was a little twist like that necessary to solve my problem. There is also a link in that support article to a possible interaction with OSX's firewall settings.

  8. djqwikcut

    djqwikcut New Member

    Already tried this but thanks. Any other ideas?
  9. stv_collins

    stv_collins New Member

    Bummer! I think I may be tapped out. Sometimes people will try to use a bluetooth connection. Have you tried that? (maybe to help identify if it's a wifi network problem or not)
  10. mt100uk

    mt100uk Senior member

    Have you tried (backing up then) deleting logics control surface preference file? in;

  11. DeeJay SchmeeJay

    DeeJay SchmeeJay New Member

    In addition to what has already been suggested, some have had success by toggling the firewall settings in the Mac OS system preferences. And others have suggested turning off Bluetooth on the iPad and toggling the iPad wifi off and on before attempting to connect. It may also be worth creating an ad hoc wifi network on the mac and connecting the iPad that way. Good luck.

Share This Page