1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 LOGIC TAKES AGES TO BOOT UP 'scanning ESX instruments'

Discussion in 'Logic 9' started by Bigdawgbigal, Mar 26, 2012.

  1. Bigdawgbigal

    Bigdawgbigal New Member


    On the Logic system I'm currently working on, it takes a long time to boot up.
    It seems to take ages to load ESX instruments.
    On booting on the boot window when it gets to 'scanning ESX instruments'
    it stays on this for a long time and then boots.

    Please excuse my ignorance, but is there a way to fix this?

  3. georgelegeriii

    georgelegeriii Senior member

    Sure: toss a bunch of your EXS files (if you have a huge library or amount this happens).

    Or try Redmatica EXS Manager to help optimize your EXS files. It's likely they have been moved around and Logic is trying to figure out where things are.


    They also have some very very good apps for sampling, and other functions.
  4. Bigdawgbigal

    Bigdawgbigal New Member

    Hey George, thanks for your reply.
    I had a hunch that this was the only way to solve this problem.
    One thing I don't understand is, why does Logic need to scan all of these files at boot up.
    Say for instance, I am just opening Logic to work exclusively with audio and I have no plans at all to use ESX yet LOgic still scans ESX at boot.
    Sorry if this seems dumb, but I am used to using other DAWS, where on boot, sampler instruments are not scanned, and are only loaded when opened by the user.


  5. Colin Shapiro

    Colin Shapiro Senior member

    +1 for what George said re Redmatica.

    I have a lot of EXS files and Logic boots very quickly. The instrument files need to be re-linked to the samples.

    As to why Logic does this...well, I'd rather have it done before I start working, rather than have to wait a longer time whenever I want to load an instrument.
  6. Eli

    Eli Senior member

    Al, have you recently upgraded from Logic v.9.1.x to 9.1.6? That could also be part of the explanation. There is a known bug that _some_ users experience. When booting Logic 9.1.6 on an OS 10.6.8 system, the boot up is extremely slow (spinning beach ball, etc). Many of us (myself included) have downgraded back to Logic 9.1.5, and all runs well again.

    It probably is the EXS 24 instruments locations not being linked properly, but just thought I'd throw this out there, in case it might be pertinent to your situation.
  7. Bigdawgbigal

    Bigdawgbigal New Member

    Yes this is true in the case when you want to use ESX, but how about for those times when you know you won't use it?
    Is there a way to disable it?

  8. Bigdawgbigal

    Bigdawgbigal New Member

    Hey Eli, thanks for your reply.

    This system I am working on is actually someone else's setup, but it is running 9.1.6 on an OS 10.6.8 system.

    I will try sorting out the samples first, and if it is still slow, then try this.


  9. Colin Shapiro

    Colin Shapiro Senior member

  10. pkm

    pkm Member

    Also take any samples out of the exs instruments folder and then relink. Usually it takes a while when it's also scanning samples.
  11. Serpentsea

    Serpentsea New Member

    I use logic with east west's "play" sampler, which is very similar to the esx. When I would load up a song, I noticed that the samples that would load, would only be the ones associated with the song which I loaded logic with. For example if the song had one violin sample, and an audio track (and when I started logic I double clicked that song file to start up); logic would only load that sample. If I load the full orchestra with the 200 gig piano, strings, horns and percussion by double clicking on its logic song file; it would take about 10 minutes. I realized this and removed some unused instruments(piano) and reduced the load up time.

    hope this helps
  12. Bigdawgbigal

    Bigdawgbigal New Member

    Hi guys, first off thanks for your replies, very informative!

    So I have got Pro-manager now and have created a new folder with the samples for ESX.
    Logic definitely boots up quicker now, but it still seems to take a while when scanning the ESX instruments.
    The chap I am working with has a massive ESX library, I'm not sure how many instruments there are, but I will check on Monday.

    The sample folder that I created with the samples in, resides in another folder that also has a folder that contains the ESX instruments.
    Is it better to have the ESX samples in a totally separate folder, or on another hard drive to speed up loading?

    Also is there any way to disable Logic from scanning the ESX instruments?

  13. pkm

    pkm Member

    The problem here is before a project is even opened. Just launching the application is slow.
  14. Colin Shapiro

    Colin Shapiro Senior member

    Logic creates default folders as follows:
    Yourdrive/Users/yourname/Library/Application Support/Logic/EXSamples
    Yourdrive/Users/yourname/Library/Application Support/Logic/Sampler Instruments

    (and by the way folks, it's EXS, not ESX.....)

    The instrument files (.exs) are small so you could keep all of them in this default location. If you're short of drive space, the samples can live anywhere, but then you need to re-link all the Instrument files to the samples - that's where Pro_manager comes in.
  15. CSeye

    CSeye Senior member

    Better Disk I/O performance and less wear and tear on the system/application hard drive if the samples are on a separate hd.

    I've left the factory samples in their default install location on my MBP for ease of use. (The fewer hardware cables and peripherals the better:D...) But the larger collection of third party or custom-made instruments via Redmatica are on a separate drive.

    +2 for George's recommendation. With ProManager, I converted a 100GB EXS library (on a separate drive) to 11 GB copied to the MBP. Small(er) footprint with a great sound. Works great for quick mock ups.

    Check out Chapter 4: EXS Library Compression of the ProManager video here...
  16. Serpentsea

    Serpentsea New Member

  17. Colin Shapiro

    Colin Shapiro Senior member

    You can specify the action you want Logic to take when it opens.

    Go to Preferences.
    Click the General tab, then the Project Handling tab.

    The first option is Startup Action - select from the pop-up menu.
  18. Serpentsea

    Serpentsea New Member

    beautiful, thanks Colin I'll try this out. I have had to wait a few times when I opened the wrong song file and then simply closed it, after the lengthy load up.

Share This Page