Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Logic X not sending to MIDI port

Discussion in 'Logic Pro X' started by grovephil, Apr 28, 2016.

  1. grovephil

    grovephil New Member

    I have a strange problem. I'm using a MOTU microlite 5 channel MIDI interface, LogicX 10.2.2 on MacPro 10.10.5.
    Logic seems not to be able to send MIDI properly to Port 2 of the interface. I can send existing MIDI tracks to all the others successfully. The panel indicators of the interface show MIDI out for all but the second port. However Logic will send MIDI sync to this port (when turned on) as indicated on the interface. There appears to be an object in the environment attached to this port.
    The interface works totally normally in Pro Tools, port 2 works as it should.
    When I create a new track in Logic, the port is not available as an option, however it is available in the track parameters of existing tracks.
    I've updated MOTU drivers, reset all except key commands, tried opening new empty project, checked MIDI setup, restarting. No luck.
    It seems that somewhere in Logic it has blocked the availability of this port for key information. It recognises it for sync output.
    Any suggestions?
  3. grovephil

    grovephil New Member

    Additional information : I can send metronome information to port 2 successfully also
  4. CSeye

    CSeye Senior member

    You've completed many troubleshooting measures.

    When you say you've checked the MIDI setup, do you mean the OSX Audio MIDI Setup utility? Is everthing testing as ok there?

    You indicate an Environment object is attached to the port. Can you upload a screen shot this object, and the Environment inspector?

    Are you using hardware sound modules with External MIDI tracks? If so, post a screen shot of the track inspector for the MIDI track assigned to port 2, as well as the Library when the External MIDI track is selected (click the letter "Y" to open it).
    Last edited: Apr 28, 2016
  5. grovephil

    grovephil New Member

    I just managed to find the cause of this problem, thanks for your reply though. For some reason Logic had reassigned the (USB) MIDI port that it uses for control surfaces to the MOTU hardware one. By disabling control surfaces the problematic MOTU port came back and functioned as it should.
    To quickly answer the questions above in case anyone else has the same problem - yes I checked the OS X audioMIDI setup, yes I'm using hardware modules, the track inspector showed this port available but from memory the library didn't.
    It would appear that if this port was used for a control surface (as Logic thought it was) the port would be available for tracks to send MMC or similar to it. However creating new tracks to this port would cause issues when note information was sent to it, hence it was not available. I'm not sure why Logic changed the control surface setting, perhaps it was unavailable at some point and Logic reassigned it.
    Anyway, problem solved after a few hours of hair pulling rather than songwriting..
  6. CSeye

    CSeye Senior member

    Great to hear you resolved this.

    Very considerate of you to post the solution for the benefit of others who may run into a similar situation.


Share This Page