Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 LP9 Mackie Control issues

Discussion in 'Logic 9' started by timblade, Jul 29, 2009.

  1. timblade

    timblade New Member

    I've posted this on Apple's support forum and submitted a bugreport on I haven't really received any responses on the support forum, so I thought I'd try my luck here.

    I've included a link to a video below - so people can see exactly what I'm doing/seeing. It seems that LP9 decides to stop sending data to the correct MIDI port on my MOTU MTP AV. I'm wondering if this just happens on my setup or it's happening on other peoples setups too.

    Anyways, here's the conversation from

    26-Jul-2009 08:17 PM Tim Blade:
    I'm having an issue with LP9 forgetting that my control surface exists. The only fix is to go into the Controller Setup page then either delete and readd the controller or change the MIDI ports it's on (it's on port 7, I switch it to port 6 then back to 7 and it initializes).

    I have to do this every time I start Logic.

    28-Jul-2009 10:53 AM Akil King :
    Please know that our engineers have not been able to reproduce this reported behavior.

    Logic Control does work as expected here with Logic Pro 9.0.0.

    Please try to remove the Logic Control Surface preferences, and then start Logic Pro 9.0.0 with powered up and connected Logic Control. This should trigger a rescan of the Logic Control and set the Logic CS setup to the expected state.
    The Control Surface preferences are located at ˜/Library/Preferences/

    Please also check the MIDI cables that are connecting the Logic Control to your MIDI interface.

    Should you continue to encounter this issue, please provide any information that would assist engineering in reproducing this reported behavior.

    28-Jul-2009 07:58 PM Tim Blade:
    I've tried the following:

    * removed file
    * removed *logic* from ~/Library/Preferences
    * performed a "repair permissions" using the disk utility

    I've verified that:

    * the MIDI cables are good (they're brand new)
    * the USB cable is good (it's brand new)
    * the MIDI interface is plugged directly into the computer (eliminating any potential problems/latency from a hub).

    My setup is:
    MacPro2,1 Quad-Core 3ghz Xeon w/ 8GB RAM
    MOTU MTP AV USB MIDI Interface
    Mackie Onyx 400f
    Logic Control w/ Mackie Control Universal firmware upgrade running in Mackie Control Universal mode plugged into Port 7 on the MIDI interface

    This is what I do to produce this problem:

    1) Remove all Logic preference files.
    2) Start Logic Pro 9.
    3) Open a session that was created in Logic Pro 9.
    4) Observe that Logic notices that the Mackie Control Universal.
    5) Dink around with the session. Verify that MCU works. Verify that Port 7 on the MIDI interface is sending/receiving data.
    6) Quit Logic Pro 9.
    7) Start Logic Pro 9.
    8) Open same session as in step 3.
    9) Observe that the MCU's faders do not initialize. Observe that the scrub wheel works. Notice that the "IN" port 7 LED indicator works when I scrub on the MCU. Notice that the "OUT" port 7 LED indicator is no longer lit up. Notice that the "Net" port on the MIDI interface is lit up.
    10) Go to Preferences -> Control Surfaces -> Setup. Click on MCU. Change "Input" port from 7 to 6 to 7. Notice the MCU initialize and data being streamed on the "OUT" port 7.
    11) Observe that after 10-30 minutes the MCU stops functioning properly.
    12) Quit and start over at step 7 ad infinitum.

    This issue does not happen in Logic 6, Logic 7, and Logic 8. If I open the same session in Logic Pro 8, after I accept the warning that it was created in a newer session, the MCU initializes 100% of the time.

    I took the time to record a video of the issues I'm running in. I basically run through Steps 1 - 11.

    You can watch the video at
  3. Eli

    Eli Senior member

    Hi Tim,

    I know this isn't much help - but I just wanted to report that I tested my new install of L9 with my MCU for the first time and it seems to work fine. I watched your video and obviously see your problem.

    Is the behavior the same on a fresh blank template? Is it possible your problem is project specific - with that one project you are demonstrating with in the video?
  4. Eli

    Eli Senior member

    Hey Tim,

    I am experiencing some related strange MCU behavior with L9. Can other MCU users check this out as well and see if the problem exists on other systems; it's absolutely repeatable on mine:

    * Launch L9 with the MCU active
    * Invoke the key command option Y to open the project sync settings
    * Communication with the MCU is interrupted

    The first time it happened, it lost communication with my MCU completely. Subsequent times, the faders seemed to get re-calibrated to a different scaling. Rebuilding defaults restored the proper calibration.
  5. timblade

    timblade New Member

    Eli, I'll give it a try when I get home.

    Also, I do run into this problem with a new session - from a template or a blank one.
  6. timblade

    timblade New Member


    After getting my MCU to work (by changing the MIDI Port back and forth) I tried going into the project sync settings. It did not interfere with the MCU. I tried it while a project was playing and while the project was stopped.
  7. Eli

    Eli Senior member

    Thanks for checking.
  8. john.seguin

    john.seguin New Member

    Same issue here

    Hi Guys,

    I don't have a multi-out interface for MIDI, so I'm not having exactly the same issue as Tim, but it is similar in that my Mackie Control under Logic 9 is not pumping out the MIDI data as it should though it IS transmitting it back to Logic. Horribly frustrating, as you can imagine.

    I am trying to figure out when I *can* get it working in order to be able to repeat the process enough to submit a bug report. Similar to Tim, it has worked flawlessly on Logic 6x-8.

    Tim, did you get any resolution?

  9. paulnajar

    paulnajar Senior member

    Eli, I've had similar behaviour from Logic 8 as well. I use MCU + XT + C4. I've just tried this with L9 and I think I made it happen once. Rebuild Defaults fixed it like you but subsequent attempts did not cause a problem. Even quitting Logic and starting again could not make the fault happen.

  10. composerguy78

    composerguy78 Member

    HI All,
    I saw your post and thought I would ask you guys this:

    I have an MCU and I've found that since moving to snow leopard, the device is behaving differently.

    In short, some of the buttons no longer work as they should.

    1) It no longer will go into Arrange mode (even though it say it is in control surface setup)
    2) Because of that I can't scroll by banks or select tracks with the MC.
    3) The automation buttons don't work, If I press one, they all light up.

    It's as if the MCU thinks I'm using pro tools or ableton?

    I have tried 3 different midi interfaces with it but there is no difference.

    Thanks in advance for reading this, any suggestions gratefully received!
    Best regards
  11. Brian

    Brian New Member

    Sorry I can be much help for your specific problem. I have a Logic Control as well and when i upgraded to 9 I had to restore the defaults and its been fine since, BUT i did hear you mention it would be nice to have a pdf version of Logic Pro 9 manual...well here you go...

    just control click on where it says view as pdf
  12. paulnajar

    paulnajar Senior member

    I'm using Snow Leopard and Unitor 8's and now Logic 9.1. I have MCU + XT + C4 and since the latest Unitor 2.5 driver update this whole system is the best it's ever been. I also use LC Xmu to split out monitor functions to RME Totalmix for the MCU so it's a fairly involved setup. It please no end to be able to say that I'm having no issues at all. Even the save button goes out after hitting it.

    There have been many little anomalies with this setup across different OS, Logic and Unitor8 driver versions, but for now it's really good.

    Tim do you have any other USB midi devices attached to your computer. You can verify this by looking at the physical input object in Logic's environment. If you do, try checking if the load order changes from one Logic boot to the next. Also try unplugging these other devices that create MIDI ports in you system.

    Check in AudioMidi Setup as well to see if any virtual ports are being created via IAC and make sure network MIDI is disabled in MS as well. In fact try trashing the AMS prefs as well...

    it's a long shot but worth a try.

    Kind regards
  13. composerguy78

    composerguy78 Member

    HI All,

    Tim - I think I have a similar problem to you. I also have MOTU usb midi devices and it would seem to me that that is where your problem lies -with the MOTU midi drivers. I have a motu 828, 2 X motu ultra-lites and an emagic MT4 and a few other midi port devices. Since I have stopped using the motu's for midi, my problems, touch wood, seem to be going away.

    In fact, I don't mean to trash MOTU, but all their midi drivers seem to be problematic in snow leopard! I find that the midi driver crashes whether I'm using the port on the motu 828 or the ultralites that I have.

    I have since stopped using them for my MCU and the problems seem to have gone. I write 'seem' to have because I haven't been running with the new devices for very long.

    I also found that trashing old midi drivers helped a lot (I had some old unused ones in there).
    I hope that helps!

  14. composerguy78

    composerguy78 Member

    HI Paul,

    I just wanted to say thanks for your post. I'm now using my MT4 and it's working great so far thanks those new drivers and yes...the save button on the MCU goes out!


  15. smartinez5878

    smartinez5878 New Member

    Did you get your automation button issue resolved? I have the same issues and more.
  16. composerguy78

    composerguy78 Member

    I did! It was the midi drivers for my motu midi devices. Even the most recent drivers did not work well, they would continuously crash.

    Changing my midi interface fixed the issue. I am now using my old MT4.

    Even in OS 10.5 the midi drivers were unreliable btw.

    Does that help at all?
  17. Schwander

    Schwander New Member

    I too am experiencing the EXACT same problem. Thanks for posting the video. I will try your solution to the temporary fix tonight as well as a few other things and post my results.
  18. rokapiedra

    rokapiedra New Member

    I've been reading your posts regarding this matter.
    My MCU starts working fine with Logic Pro 9. After a couple minutes, the master fader will go all the way down. Everytime I set it back to 0 db, it will do the same after a few passes.
    I removed file. What else should I try?


    Mac Pro 2X2.66 ghz dual core
    Motu Fastlane MIDI interface
  19. composerguy78

    composerguy78 Member

    Okay firstly, I'm assuming that you followed sequence above from Schwander's post right?

    If so, and that still didn't work. Then from what I can tell, you may well have a faulty fader. But I am no expert, I'm just reporting what happened to me.

    When your master fader goes all the way down, what does the master fader in your logic session do? Is it also down? I guess not, but check (bear in mind it is not the stereo out!)

    Also when you move your master fader (on the MCU) with your hand, does it follow accurately onscreen? or is it way off?

    Does the unit calibrate okay? or does it give an error when you turn it on?

    I had this happen with one of my faders and I just ordered a replacement part and it fixed it fine. You can also get it done through a mackie repair center.

    Let me know what is happening, give me more details, I hope I can help.

Share This Page