1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Mackie Control Universal Touch automation

Discussion in 'Logic 9' started by zerobeat, Nov 24, 2010.

  1. zerobeat

    zerobeat Senior member

    Whenever I press the Touch, Latch, Write or Read buttons on the MCU, all 4 will light up. And Logic only goes in Read mode no matter which of these buttons I press.

    If I use the mouse and change the track to Touch (or Latch or Write), then it does in the appropriate mode and works fine.
  3. Markdvc

    Markdvc Administrator Staff Member

    If it is of any help, this is not normal, and it isn't happening here, with a setup of a Mackie Control Universal, XT and C4, connected to the Mac through a Unitor 8 Mk II. Touch, Latch, Write and Read all work as expected. Have you tried deleting and re-installing the C4 in Logic's Control Surface Setup ? Could the CS Pref file be corrupted?

    just a few thoughts - though I expect you will already have tried these trouble shooting basics ...

    kind regards

  4. bresnark

    bresnark New Member

    I also get this emulating MC on the AC-7 app on my iPad. It's very annoying and definitely seems to be something wrong in Logic's Mackie Control settings (unfortunately, not configurable, as far as I can see).
  5. zerobeat

    zerobeat Senior member

    I did all the usual troubleshooting things, and more. The MCU works fine on another Mac/Logic rig. The next step is to install a parallel MacOS/Logic on a spare hard drive.
  6. Eli

    Eli Senior member

    Hey zereobeat,

    I'm sure you're way ahead of this already, but just in case: have you tried the rebuild defaults command?
  7. bresnark

    bresnark New Member

    Hi, Zerobeat

    Have you had any more luck with this yet? I'm really keen to find an answer, too...


  8. syncan

    syncan New Member

    Found the answer! Here it is if you never figured it out:

    1. While still in 64-bit mode in Logic, delete all control surfaces from the Preferences>Control Surfaces>Setup page
    2. Quit Logic
    3. Trash the control surface preference file: [user]/Library/Preferences/com.apple.logic.pro.cs
    4. Tell Logic to open in 32-bit mode (selected in the application's Get Info window in the Finder)
    5. Open Logic in 32-bit mode and setup/scan for your surfaces
    6. Verify that everything works properly
    7. Quit Logic and set it back to 64-bit mode
    8. Open Logic in 64-bit mode, and the control surface should now still work properly

Share This Page