PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Melodyne stuck in Playback mode

Discussion in 'Logic 9' started by foxymoron, Apr 14, 2011.

  1. foxymoron

    foxymoron New Member

    I have been through the wringer with Celemony tech support to address a problem of Logic not using Melodyne correctly and it appears that I may have to do a system restore or reinstall Logic. We have tried EVERYTHING on the Melodyne end of things and it's still not working. So my questions are these: which would be more likely to resolve this problem, a system restore or a Logic reinstall. From what I've read of Logic reinstalls, they are tricky because of the receipts being in some off the wall place and needing to know how to use terminal script, (which I do not.)

    Any ideas or suggestions would be very much appreciated!

  3. georgelegeriii

    georgelegeriii Senior member

    Have you tried to un-instantiate Melodyne for now, just to get rid of it? I don't really understand the issue, not enough details.
  4. foxymoron

    foxymoron New Member

    Well, I have talked with Celemony tech support. As of now we have tried: taking Melodyne off my computer (uninstall), repairing permissions, trashing preferences, downloading a fresh version of Melodyne, deleting the ilok license, installing the fresh version, reauthorizing it through Celemony, and after all that, when I open Melodyne, it still only opens in playback mode and will NOT transfer any audio.

    Their tech support is baffled at this point and are blaming OSX. So, I'm wondering which would be the smarter (or easier) to do: uninstall Logic as completely as possible and reinstall it, or to reinstall Snow Leopard. I'm not really versed in either of these things. I have a Time Machine disk that I'm using to backup my entire system, so I'm not entirely paranoid about losing stuff, but I really don't want to reinstall all of my applications, etc.

    Any advice? Thanks!
  5. georgelegeriii

    georgelegeriii Senior member

    Look, I understand the things you tried.. my question is: what is the issue and how is it being manifested?
  6. foxymoron

    foxymoron New Member

    The issue is that Melodyne is not working. It's supposed to transfer the audio from my Logic tracks to itself and blobs are supposed to show up on its grid, but none of that is happening because it is in playback mode (the mode that it is forced into when it's not registered.) However, my copy IS registered. We have tried all these fixes to no avail. So, Celemony says it's an OSX problem and I should reinstall that. I was wondering if it could be a Logic problem, too, and if I should reinstall that as well. Not having done either before, I'm worried about screwing up my setup, so I am also asking for advice on that front.

    So again, every time I open Melodyne, in any project on any audio track, it comes on in playback mode and is unusable. That is how it's manifesting. The transfer button is on, but when I push it and run Logic, nothing is transferred.

    Thanks for your help!

  7. georgelegeriii

    georgelegeriii Senior member

    Did anyone suggest you try a new user account to test if there might not be something wrong with your current user account?

    Have you tried to run the current 10.6.6 combo update rather than the one from the software update? You can download it from Apple.

    One thing about melodyne: are you sure Logic is actually in play mode before you start to transfer audio? I have a client who had an issue and that was the reason: if they went into melodyne and tried to transfer, they did it before they started playback in logic, so it would go out of record all the time.

    Where are you located?
  8. foxymoron

    foxymoron New Member

    Okay, George, which User Account are you talking about? The Celemony one? I was able to go there and download the most recent build just fine. They were very helpful, though unable to solve the problem, so maybe not really that helpful.
    Alas, George, it was not that I wasn't starting playback in Logic first. I drove home from work wondering if it was something as ridiculously simple as that (hoping actually, after this nightmare.) But I tried it both ways and the darned thing is still always in playback mode.
    So, I took your other suggestion and downloaded the most current combo (10.6.7) from Apple. I installed it and again, no such luck. The only thing I can think of that I haven't tried is to uninstall Logic completely and do a complete reinstall of it.
    Is there some sort of document somewhere that tells one step by step how to do this without screwing up your computer and your files?
    Thanks, George for trying to help. I really appreciate it. To answer your last question, I am located in the Bay Area, about 50 outside of SF. Thanks again.

  9. Eli

    Eli Senior member

    Hi Foxymoron,

    Please take this in the spirit it is intended - I am not judging. But, if it is possible there may have been a previous krack of Melodyne on this system before your current legit install, that could be the cause of the problem. I've seen this before, specifically with Melodyne.

    You need to dig through all your prefs (in both the main Library and the User Library) and throw out anything related to Melodyne, including old [k]'d authorization keys. This could be causing the conflict that is not allowing your version to run properly.

    Also, try George's suggestion. When he suggested a new account, he meant a new fresh OS X user account on your Mac. Go into your accounts prefs and set up a new user, and start from there. This will truly give you a fresh start where you can rule out any OS conflicts.
  10. foxymoron

    foxymoron New Member

    Hi, Eli!

    I understand what you are saying and I'm not offended. However, I did purchase this software legitimately. Why else would I have been communicating with Jorg Hutten (forgive the missing umlauts) for the past week trying to resolve the problem?

    Be that as it may, I tried a new OSX user account. Wow. That really is starting all over. Logic opened in 32 bit and crashed as soon as I switched to 64. I would not open in 64 bit at all.

    I'm starting to think it's a problem with Logic. Any ideas? Thanks for your help, Eli.

  11. Eli

    Eli Senior member

    Is the problem with Melodyne the same when you start in 32 bit as well as 64 bit mode? (on your original system).
  12. Ming

    Ming Member

    Did you ever get it to work at all and it then stopped? Or has it never worked after installation? It seems as if a Trial is still running. Did you use a Trial earlier? It could be an iLok issue and you can try installation without iLok using a serial number.

    Try run Melodyne from GarageBand since it rules out the Logic issue. If you have GB, create a track and load an audio or audio-loop and instantiate Melodyne (it's under the GB's Edit-tab) and press Transfer. It should work just as good in GarageBand. Creating a new Mac-user account (in the Mac System preferences) and start from there is also good way of ruling out many OSX user settings.

    If nothing works after you've created and started from a new Mac-account, use Melodyne in GarageBand and it doesn't transfer you probably should look at your iLok. Even if you then re-install everything and plug the iLok back in, it would still look the same.
  13. foxymoron

    foxymoron New Member

    Well, I finished my project on the laptop, since that was working correctly. I saw the new Melodyne update today and was encouraged that maybe it will work correctly on my desktop once I'd installed that. So, I downloaded the new version, trashed preferences for all Melodyne stuff that I could find (in the User library), and repaired permissions, shut down and installing, the 32 bit version works, but the 64 bit does not. Since you asked about this in particular, I'm wondering what your suggestion would be. Thanks!

    I'm sorry for lagging on getting back to you Eli. I had to finish the project first. Thank goodness for that laptop!

  14. foxymoron

    foxymoron New Member

    Melodyne stuck in Playback mode (in 64 bit)

    When I got to a new user account and set up Logic to run 64 bit, everytime I open Logic now, it crashes. It's not even a Melodyne issue at this point, I don't think. When I open Melodyne in Garage Band, it doesn't work on my old account, but does on the new account. When I open Logic in 32 bit on either my old account or new account, Logic opens and Melodyne works.

    I am baffled.

    What would you do?

  15. Eli

    Eli Senior member

    When Logic is crashing in 64 bit mode but not 32 bit mode, are you launching the app itself, or a specific project?

    I would go through the third party plug-ins and pull them out one at a time to rule out one of them being the culprit causing the instability.
  16. foxymoron

    foxymoron New Member

    When you say pull them out the 3rd party plugins one at a time, are you referring to disabling them in the Audio Units manager or actually uninstalling them? I tried disabling all of my 3rd party plugins in the AU Manager under the new account and it still crashes in 64 bit, launching from a project or straight out of the application. (I normally have Logic set up to do nothing when I launch it.) So, I'm beginning to think a clean install is in order on my system drive. I have my system backed up to an external drive. Would it be advisable to just reformat my system disk and start all this over with a clean install of the OS and Logic? My main problem with that is reinstalling all my other stuff, the apps, email, etc. Is there a smart way to go about it that wouldn't involve two weeks worth of frustration?
  17. Eli

    Eli Senior member

    Hey FM,

    Unfortunately it looks like you are getting to that point. You are running out of trouble shooting tests. :(

    You can use migration assistant to bring across system setting, email, bookmarks, etc from your backup. But I wouldn't suggest using it for apps or plug-ins or anything like that. Best to reinstall those from scratch.
  18. georgelegeriii

    georgelegeriii Senior member

    try this: grab a new external firewire disc, put a system on it, the audio card drivers, then Logic Pro.

    Boot up from the FW drive

    Test how Logic works.

    Add melodyne to the system, make sure to boot Logic in 32 bit mode the first time you use it, then go back and forth between 32 bit and 64 bit melodyne and test to see how things work.

    After this, which isn't all that time consuming (other than the Logic install, and you really don't need to add all the samples to the install, keep it very clean and lean), you shoudl have some kind of an idea wether or what is going on.

    A) if everything work as it is supposed to do, something is wrong with your MacHD installed system, or B) if this still don't work, and you are getting crashes, I would highly suspect a hardware issue. I tech about 5 or 6 Macs running Logic and Melodyne on a regular basis, and don't see the type of behavior you at getting, so it is system specific.

Share This Page