Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Memory issue

Discussion in 'Logic 9' started by Ming, Jul 8, 2012.

  1. Ming

    Ming Member

    I have got memory issues using Mac OS 10.6.7, Logic 9.1.5 (64-bit) with Melodyne 2.1.0 as a plug-in. I have 12 GB RAM installed that my computer recognizes and the hardware control accepts. But it seems it's only using 4 GB. That is indeed a general Mac question to which the guys in the Mac-shops unfortunately haven't got a clue. It becomes a problem when using Logic so then they conveniently tells me it's probably a Logic issue and I should ask Logic people.
    What happens is: I run Logic with a couple of Melodyne plug-ins. The Mac activity monitor tells me the computer is using say 3 GB of RAM totally (never more than 4 GB). After a while Logic alerts me "out of memory" unable to save data and so on and I have to force quit. The activity monitor usually says Logic is using 400-500 MB and never more than that. So I wonder doesn't plug-ins memory consumption show up as part of the Logic software? Cause there's no specific plug-in usage (Melodyne in this case) in the activity monitor. In such case it would suggest that plug-ins memory consumption is unaccounted for in the computer which would be really bad. Could that really be the case?

    Should anyone have a clue to why my iMac doesn't seem to utilize my 12 Gig it would of course be fab. I have tried to start the OS holding down 6 and 4 but to no avail.
  3. georgelegeriii

    georgelegeriii Senior member

    1) are you sure you are running Logic in 64 bit mode? do this: hold down the command and i keys while selecting the Logic Pro icon to open "get info" and uncheck the 32 bit mode.

    2) When you are in 64 bit Logic, you can open either the 32 bit or 64 bit versions of plug-ins. Make sure you select the 64 bit one, the one that is NOT in the 32 plug-ins list when you go to select a plug-in.
  4. Ming

    Ming Member

    Yes I have unchecked Logic's 32-bit mode and the Logic info box says it's in 64-bit. I use Melodyne Editor in 64-bit as well and use the plugin that is not in the 32-bit list. I wonder if any Logic preferences can block things? Are there any prefs I can delete safely? When using heavy plugins like Melodyne Editor in polyphonic mode, having enough memory and 64-bit is recommended but the activity monitor doesn't seem to indicate Logic is using any and that puzzles me. Unless Melodyne's unique and probably heavy memory usage somehow goes unnoticed by Logic causing spectacular crashes in the end if the Melodyne plugin is unable to allocate memory on its own and Logic is unaware of the situation?
  5. georgelegeriii

    georgelegeriii Senior member

    The what is your Logic audio buffer size? Melodyne wants a larger buffer size when being used.

    "we recommend that you set the I/O buffer size to 1024 samples"
  6. Ming

    Ming Member

    Yes it's 1024. My best bet now is: are there any preferences in Logic (and perhaps the OS) to delete to force writing new ones? I add tracks one by one and transfer into polyphonic. I can transfer 4 tracks which is a lot. "Out of memory" comes up followed by "can't insert or delete data". But Logic's CPU is very low despite the heavy load at about 5% CPU (as it would be if it played the 4 clean audios) and the Real Memory use is also minimal. It doesn't seem to detect what's going on in this AU-plugin. Logic uses max 1.3 GB and the total computer 3 to 3.9 GB and after that it crashes.
    Then something unexpected happened once: I was able to delete the last transferred Melodyne after an "Out of memory" and suddenly the computer was using 6 GB just like that and Logic was using 3 GB all on its own.
    I thought I'd been able to force new preferences? I continued to transfer one more track to break the 4 GB wall, now with total memory usage of over 5 GB. Then it crashed and now is back on low memory only - It will start but the computer now uses max 2.5 GB (gone down again) and Logic max 1.3 GB and transferring more just results in an unexpected crash.

    Virtual Memory is high 120 GB but the Real Memory usage is very minimal and won't climb. Looks like there is a wall with low memory and low CPU actually at about 10% of the computers resources despite such a demanding load. That's why I wonder about resetting OS and Logic preferences since Logic seems to be unaware and the plugin don't allocate resources from the host. I would not complain over low memory usage if it didn't produce "Out of memory" from invisible processing and memory limits that I can neither adjust nor allocate manually. I don't know what to try next other then preferences since memory allocation did jump ones but only ones.
  7. georgelegeriii

    georgelegeriii Senior member

    I'd contact Celemony, or check out their forum, that is unless you seem to be having the same memory issues with something like Kontakt 4 or 5, EXS with the memory server turned on, or any other big memory using plug-ins.

    I use melodyne all the time, never seen the issue you have here, and I have a client who uses Melodyne with about 6 or more tracks in Protools, which is 32 bit, and doesn't have the same issues as this.
  8. bruno garza

    bruno garza Member

  9. Ming

    Ming Member

    Alright thanks guys for the input. I'll continue to look into it. It became a problem when there is a build up of memory usage but it's not being detected anywhere, neither in the system or in the host. Lack of integration might be at the bottom of it. If Logic isn't asking this plugin for unorthodox memory usage and can't allocate memory for it and the plugin doesn't provide it, there's a crash or sudden out of memory message instead that the activity monitor won't reveal in any way. I'll use experience to stay within the limits and bounce down.

Share This Page