1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Midi glitch on Logic Pro X start up

Discussion in 'Logic Pro X' started by Alan F, Nov 6, 2015.

  1. Alan F

    Alan F New Member

    When I load Logic Pro X it pushes out a low single midi driven piano note which I think is note C0, and probably via a GM piano?? It is loud!! - max volume 127 by the sound of it.

    I have had this problem for a while now and it is annoying me. Any ideas??

    Is the an 'all notes off' function or better still a proper cure to stop this?
  3. Alan F

    Alan F New Member

    Wow. It gets worse. Now when I try to record an AUDIO track the mid piano note booms out at a regular interval but NOT in tempo with the track.... and the metronome doesn't work either. This is weird.
  4. CSeye

    CSeye Senior member

    Some troubleshooting steps to consider:
    1. Try resetting MIDI: Click on the MIDI In/MIDI Out indicator section of the Control Bar. (Control Bar LCD has to be set to Custom) If that doesn't fix the errant MIDI note, then try #2 below.

    2. Power everything down. Disconnect your audio/MIDI interface and other peripherals. Then power up your Mac, set up the Mac OSX AudioMIDI Setup utility to use the built-in/out audio. Start up Logic. Is the problem still there? If no, then hook up your USB MIDI controller keyboard or other if available. Able to play/record MIDI without issues? If no, then hook up your hardware interface.

    Regarding the Metronome, look at its preferences (File>Project Settings) to make sure everything is as you expect it be.

    Post back what is working or not.
    Someone else may be able to resolve this for you.
  5. Alan F

    Alan F New Member

    Thanks CSeye - much appreciated.

    I tried both options but sadly the problem persists. I have however worked out that it is my M Audio Pro Keys 61 keyboard / MIDI controller producing the sound. It has internal sounds and GM sound bank. Whenever I hit 'record' in Logic it triggers the C0 piano note - even when 'local notes off' is selected on the M Audio keyboard. On Logic's Control Bar I can see MIDI OUT displaying "2 C=0127"

    I have checked with M Audio; no software / firmware upgrades available.

    I have tried to reset all Midi within Logic but it makes no difference.

    Interim solution - Simply pulling the Master Volume fader on the M Audio keyboard to zero seems to solve the problem. i.e. I can't hear the sound! But I will keep trying to find a way of stopping Logic pushing out this random midi signal. I'm not sure if this caused by El Capitan upgrade or not. Weird.

    Any other suggestions anyone?

  6. volovicg

    volovicg Senior member

    Quit logic and hold the option key down while starting logic up... Does the problem occur?
  7. Alan F

    Alan F New Member

    Thanks volovigc, Tried it. Same problem occurs. But thank you anyway. I cannot believe I am the only person who has upgraded to El Capitan. Is any one else having these issues????
  8. CSeye

    CSeye Senior member

    That's indicating MIDI channel 2, note C0, velocity 127.
    The questions is, what's triggering it?

    Are you using External MIDI tracks? Software Instrument tracks? Both?

    In the Environment Clicks & Ports layer, what does the Input View monitor show? A mix of channel 1 and 2?
  9. volovicg

    volovicg Senior member

    Can you send us your project that is behaving this way... Greg@Volovic.com or other upload method that works for you
  10. Alan F

    Alan F New Member

    Just checking a few more combinations of Logic / M Audio / Yamaha AG06 etc. I am trying using differing input and output sources. I think I can discount the Yamaha Mixer as the source of the problem. It seems to be the M Audio keyboard and Logic.

    Arming a track to record (midi or audio) sets it off and produces a single C0 note from the M Audio keyboard, and then the actual recording process makes it produce a series of notes (interestingly C#0).

    But maybe El Capitan has impacted on Logic?? I will try to send an example of the problem. Meanwhile I am chatting with AppleCare to see if a downgrade to Yosemite would help - or not!!
  11. volovicg

    volovicg Senior member

    Can you send me the logic project used in your video example?

    Also - could you please quit automap if you are using it.

    And try Logic Pro X->control surfaces->bypass all control surfaces.
    Last edited: Nov 10, 2015

Share This Page