1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X MIDI TIME OUT - Fatal - Help!

Discussion in 'Logic Pro X' started by JamesBRey, Oct 24, 2015.

  1. JamesBRey

    JamesBRey New Member

    Having huge issues here as I try to migrate into Logic X. No problems in 8 or 9.

    Dreaded MIDI timeout in Logic X prevents any work getting done - forces QUIT and reboot. Same in Yosemite, Mavericks or Mountain Lion even with fresh installs of OS on external drives.

    Same with all different MIDI interfaces - I have tried three - NI Komplete Audio, Unitor-8 mkII and generic. Using latest available drivers in ALL cases.

    Anyone have anything new to offer on this? Using Mac MINI i7 server, Logic 10.2.


  3. CSeye

    CSeye Senior member

    If you've set up extensive customized settings, drag your Logic preferences to the desk top, then try Logic menu>Preferences>Initialize All Except Key Commands.

    If that's not the case, then just use the above menu command.
  4. JamesBRey

    JamesBRey New Member

    Thanks for weighing in on this. It is a good suggestion but one I've already tried and failed with.

    In the interim I have traced the problem to bugs in Logic X environment that crashes the system - whereas all these things worked perfect in v 4-9.

    Very disappointing to see Apple make such a mess of this aspect of the program. Very unhappy here and no recourse. Apple's bug reporting system only allows like a few sentences as well - So I cannot even fully inform them of the problems.

  5. composerguy78

    composerguy78 Member

    Try opening Logic without Core Audio (hold down ctrl key when opening logic) Then delete All Track automation, save and reboot. Open as normal. Hope that helps.
  6. JamesBRey

    JamesBRey New Member

    Thanks for weighing in. Sorted this out about a year ago - but cannot remember the fix.


Share This Page