Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.


Discussion in 'Studio Techniques' started by LovesMusicHatesTech, Jul 20, 2012.

  1. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    Thank you ahead of time for any effort to give me some help here.

    I purchased an MPK88 yesterday, primarily because I loved the feel of the weighted keys...all the other controls were not a must for me..but if I have them I want them to work if I can.

    I read much about this product before buying, and if you do a search on google you will see MANY people having issues getting Logic and the MPK to play nicely. BUT others were convincing when they said they had solved their issues, like the guy in the youtube vid who demonstrates how use the environment to get the desired results (like making the knobs and faders work).

    Maybe I don't understand and my expectations are wrong but this is what I did, and they were exactly the steps that I followed from the downloads on AKAIs' on website.

    I was able to get it to sync with logic, so my arpeggiator and what not all follows logics tempos and that is all working well and good. Transport Keys work.

    My problem comes directly from the Controller Assignments. I tried making several templates and they would always start fine and then things would go wrong. For example:

    1. I created 16 midi tracks in a new project and open up the mixer.

    2. Open the Controller Assignments window and activate Learn Mode.

    3. Click the fader of track 1 and then move my F1 MPK fader, click track 1 pan and then move the corresponding MPK knob.

    4. I do this for the rest of tracks 2 -8. Disable Learn Mode.

    I now have the knobs and faders working and its great! Now I repeat the process with tracks 9-16 after switching from bank A to bank B on the MPK.

    This also works great. For about 15 seconds. I'm not sure if its a bug or if its SUPPOSED to work like this, but heres what always happens:

    1. If I have track 1 selected in my mixer then it seems that I can bank from A to B all day long and the knobs and faders will correspond to the correct track.

    2. If I have track 9 selected in my mixer and then switch from bank B to bank A, fader F1 will now move track 1 AND track 9!

    This screwiness will happen to every and any tracks depending on which track I have physically chosen in my mixer....even though bank A and bank B send entirely different CC #s. Some how logic gets confused after this happens and I have to start over...but then it just happens again so its just a maddening cycle. My oxygen 49 did this and I figured its because its cheap. Now I believe the problem is with logic itself.

    I tried the work around of using the environment and I did everything in the youtube video (where the guy explains how to set up transformers and use those to get communication between the MPK and corresponding tracks).

    I spent hours setting all that up only to realize that doing this means losing pickup mode and my faders jump all around instead of waiting to move when I reach the current level.

    So I went back and just tried to reprogram the Controller Assignments again, but added to the issues I was having before is that pick up mode seemed to not be functioning even though it was checked :brawl:

    So sorry for the length of this post! But I have one more thing to mention that may be the cause of all of this (at least I'm praying it is because I need to find an answer before my head explodes!):

    Google search showed me that people with similar issues to mine are told to delete some type files (can't remember the exact ones at this time) because they could be corrupted. These files are supposed to be in the Library>Preferences folder. I cannot find these files ANYWHERE! People with this problem were told to Repair Permissions, and so I did that too...but still those files are nowhere to be found. One person said now a days they are in the Users folder, but again, nowhere to be found! Out of everything this is the worst part I think, because its like they just do not exist.

    Thank you so much for any help, and again I apologize for the long read :(.
  3. Atlas

    Atlas Senior member

    This is indeed a very long post, but it is to my taste pretty well described, which we are not often granted!
    My first hunch would be to think that the fader bank selection MIDI control assignment got screwed up somehow in the process. So I would go check in the Controller Assignment window (expert view) to see what it is actually programmed there... Here is a link of interest to read/assist you:

    Another approach would be to use some MIDI monitoring (either from the Environment/monitor object or preferably from a more elaborate app like snoize) to check what your MPK is actually sending. If you dont have other controllers connected (which, by the way, could interfere and cause this kind of issues), I would start to troubleshoot on a new/clean project with resetting all controllers.

    Regarding the pickup mode (does the parameter in Preferences/Control Surfaces/General) still enabled?
  4. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    Thanks very much for your patience and reply! Much of my problem was solved when I found out that the file was hidden, and I had to hold down alt with the Go drop down list in finder to access the appropriate Library/Preferences folder. Once I trashed that file and started over then things went relatively smoothly, albeit not as much as I would have liked. I won't go into it for the sake of time, LoL.

    Alas, I had to return the MPK88 anyways because it ended up having a completely separate issue and ultimately instead of exchanging it for another one I picked up a digital piano (Yamaha P155) which is supposed to have Midi capabilities, though I can't get that to work either (I think the midi to usb interface I bought is complete junk) :brawl: Since my main priority was 88 weighted keys for piano vsts in logic, I saw this piano as a good way to also play without turning on my recording gear when I just wanted to write.

    I plan on buying something from the list of controllers that Logic knows and likes, like a Mackie, when I decide I absolutely need fader and knob control.

    If somebody knows a good way to get the P155 talking to my computer so that I can, for example, use EWQL standalone and what not I'd be very grateful!
  5. Atlas

    Atlas Senior member

    I use a C4, a Novation SLMK II, Korg nano and Eucon and all work relatively well... Each have their strength and quirks...

    If I understand well from the published features, the P155 would require the use of a MIDI interface... Which one do you use?

    Usually the MIDI cables run from the MIDI output of your P155 to the MIDI input of your MIDI interface; and another MIDI cable connect from the MIDI output of the MIDI interface to the MIDI input of your P155. Creating some kind of loop connection between your MIDI interface and your P155. Usually one USB cable does the connection between your Mac and your MIDI interface... Setting the same MIDI channel on your P155 and EWQL (or Logic) should now make them "talk " together...
  6. pfloyd714714

    pfloyd714714 Senior member

    Once you have the various pieces cabled together, you can establish a connection by using Apple's "AudioMidi" program. You'll find it in Applications: Utilities." At least that's where it's located in 10.6.8.

  7. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    I was pretty much handed the MConnect USB-->MIDI interface, from ARTcessories (I had never heard of them till now), and told it would do the trick. I haven't found much about it on the internet and supposedly when I plug it into my Mac for the first time its supposed to install its drivers and I'm on my merry way, but it doesn't do a darn thing when I plug it in.

    The only reference to this interface I've found was vague in some forum where a guy said something to the effect of "the one with the musical symbol on it didn't work at all" and mine does have a bastardized version of a treble clef on it so I'm assuming its the same one. The large sticker that covered the Made in China symbol fell off as it was being unboxed so yeah, lol.

    I believe I need a better USB to MIDI interface. I'm currently using a Macbook Pro OS X 10.7.2 and Logic 9.1.6, just as a general FYI.

    Thanks for the tip pfloyd, I'm as Mac/Logic user as of last November so still pretty green, and not very tech-y to begin with!
  8. pfloyd714714

    pfloyd714714 Senior member

    I assume this is the interface:

    I'd be a little concerned about the whole "drivers automatically install" idea since that might suggest that updated drivers for new operating systems may not be available. I checked out ART's website and couldn't find a driver download area for this product.

    Again, though, the AudioMidi application can tell you if the thing is working. If it isn't fear not: simple, reliable midi interfaces are inexpensive. Just get one from a manufacturer that updates their drivers.

  9. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    pfloyd- Yep thats the one...there website was about as useful as their product was, today I'm up and running with an UM-ONE from Roland. I do not recommend that Art Pro Audio "artcessories" interface, so should anyone in the future be in a similar situation, just spend the extra 10 bucks or so and buy from a trusted brand. I know the sales guy was just trying to save my a couple bucks, but anywho...

    The install went without a hiccup, and I pulled up standalone Play (ewql) and jammed out on the piano vst....I was even happy to find that the sustain pedal functioned without me having to program it...which I guess after all this just made me happy..LoL.

    I did get a hung note literally just now when I called up a keyswitch patch of violins, and I had to delete the instrument from Play to get it to stop, but I haven't tried it inside of Logic yet...but will here soon.
  10. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    Atlas- I was going to pick up one of those Korg Nanos today but forgot while I was there!! It looked perfect for sitting on top of the yamaha for basic transport operations (since I'm to lazy to just swivel to the right and hit spacebar). At $60 bucks it seems too good to pass up and Korg is reliable enough for sure.

    As per my hung note situation, I just had it occur with a different patch. I've heard about hung notes in midi before but I've actually never experienced it myself, so I never really dove into what causes it and what the fixes are.
  11. Atlas

    Atlas Senior member

    Korg Nano Kontrol works very well and is programmable. The new version (2) offers only 8 faders (instead of 9 on version 1, which was useful as the 9th one could be used as a master fader). The one I am using is version 1, and I am very satisfied with it.
    Korg Nano Kontrol requires some drivers installation and also a software to customize the controllers assignments (if you wish). However, it comes already pre-programmed (or you could download the setup from their support site) to work with Logic.

    Hung MIDI notes are very common! Almost every MIDI instrument (software or hardware) has a panic button in order to alleviate the problem.
    Hung notes occurs when the note off message is either not sent or not received for various reasons arising along the data transmission route.
    If that problem occurs regularly and/or is repeatable steadily from a specific procedure, then there are reasons to be concerned and troubleshooting and seeking a viable solution is necessary.
  12. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    Unfortunately I've been able to reproduce the hung note quite frequently. In play I just have to delete the instrument...not sure if play has a panic button. When using piano sounds though it seems the problem is that I will start playing and then some keys don't do anything and then the sound comes back.

    Using Kontact 5 (free) I also randomly get no notes for piano sounds, and stuck notes when using string sounds. In Kontact, though, I can see the stuck note is still "pressed down" on the virtual keyboard. And by hitting the corresponding key on my p155 the note will shut off.

    Pretty sure the p155 doesn't have a panic button, but if it did I couldn't imagine trying to push it 20 times during a take, lol.

    So since this happens in play and kontact (as both standalone and logic plugins) is it probably a hardware issue?
  13. pfloyd714714

    pfloyd714714 Senior member

    Stuck midi notes are voodoo--at least to me. I had a cheap little Edirol midi interface which I used to connect my Yamaha S08 synth to Logic. Worked like a charm. Then I bought an RME Fireface UC audio interface, which had midi built into the box. With the RME box I had stuck notes all over the place. RME was little help in resolving the issue. So I use the RME box for audio (which is what I really bought the thing for anyway) and went back to the plastic Edirol for midi. It's a drag that the pricey RME didn't work as advertised, but all I care about is that both audio and midi work for me.

    You could contact Korg and describe your problem. That didn't change anything for me, but it doesn't mean it won't produce any usable results for you. Also look at Korg's online forum. Someone out there should be able to confirm--or not--your experience. Finally, try using the interface from within Logic. What happens then?

    All of this can be irritating, especially if you "LoveMusicHateTech." Once it's all working, though, all of your concentration can be dedicated to the music.

  14. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    Definitely still getting the same results using these engines as plugins in Logic.

    The controller I'm using now actually is a Yamaha, the p155 is a digital piano that was recommended to me at sweetwater sound as a good option in place of the ominous MPK88...sorry for the confusion! I just brought up the Korg nano as something I may try in the future. I may try the Yamaha forums for some insight. I was on hold for 20 minutes with sweetwater tech support just now then they came on and took my name and number so I'm just gonna try and write some music for a bit and wait on a call from them.

    When I chose my user name I was trying to filter out ones with 4 letter words in it, LOL...I was so angry at the time because this stuff is frustrating to me!
    I never used MIDI at all up until a little over 3 years ago when I incorporated a Ground Control Pro, GCX, and Mini Amp Gizmo into my live guitar rig. Its funny how intimidating that was looking back on it now for me, but honestly that was a walk in the park compared to the last several days!

    Many sincere thanks for the suggestions and comments so far guys, I appreciate you making the well as lending some sympathies! LoL
  15. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    Just got off the phone with their tech support and they were very help/patient with me in trying a few different scenarios and the consensus is that my Yamaha p155 is causing the problem.

    So! Back to the drawing bored. My back is killing me from hauling these giant things up and down the stairs, but this thing has to go back! It's a fantastic digital piano, but a lousy midi controller.

    Somebody needs to make an improved MPK88...something with a killer key bed...if this yamaha GHS key bed was in a Logic friendly sort of MPK88 thingy....I would probably sleep with it!:D:D:D
  16. Atlas

    Atlas Senior member

    One way or another, once you make it to the store to get your other keyboard, acquire a reliable MIDI interface (to achieve the connection between you Mac and you new keyboard). I keep thinking the problem you described, was related to some cabling issue...
  17. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    The Roland um-one I mentioned in #8 actually is a much better midi interface than the first one I used so I'm confident I should be ok moving forward. The keyboards I'm now looking at now all have a strait up USB to host midi connect so in the end I might not need one. (won't need a wallet by that time either as I'll be spending twice as much, haha)
  18. Atlas

    Atlas Senior member

    I noticed in your signature that you are running Logic v.9.1.6...
    The most recent version is 9.1.7...
  19. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    Yes, and I wish I never updated past 9.1.5, TBH.
  20. Atlas

    Atlas Senior member

    Problems related with OSX Lion, maybe?
  21. LovesMusicHatesTech

    LovesMusicHatesTech New Member

    I'm gonna be hitting up some Mac friends (I'm as new to them as I am to Logic) and I'm gonna completely reinstall everything from operating system to logic, everything.

    I get some weird happenings inside of Logic no matter what controller I use. For instance, I went out and grabbed a Korg Nanokontrol2, and while I think it's has also showed me that there is a problem somewhere in my computer/logic. Nomatter what controller I use I get this:

    Adjust the level of track 1.
    Adjust the level of track 2.
    Upon adjusting fader 2's level, a little gremlin in my computer decides to kick track 1's level up or down a fraction of a db or so.

    It doesn't matter what track I start with or anything, as long as I adjust one, subsequent adjustments to other tracks nearly always causes the track before it to be adjusted by some mysterious force. Never more than a fraction of a db.

    I've been able to repeat this with any controller I use (tried 3 so far). I honestly think I'm going to stick with a mouse until I get around to reinstalling everything. I haven't written any music in over a week, and to me thats the worst part of everything!!!

Share This Page