1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 No access to plugin parameters on Auxes with Mackie Control

Discussion in 'Logic 9' started by garethJones, Sep 14, 2011.

  1. garethJones

    garethJones Member

    Hello Group.

    I cannot seem to "selects" Auxes with my Mackie controls - this means that although I can see the plugins on the Auxes I cannot access their parameters via the control surfaces.

    Which is a pity.

    I can of course select Tracks and access plugin parametes on tracks from my control surfaces. But not Auxes

    LOGIC 9.1.5

    Any comments or guidance appreciated.
  3. Markdvc

    Markdvc Administrator Staff Member

    Hi Gareth

    I just tested this on my Mackie Control and it is working fine here, I'll run through what I did:

    Create an arrangement with 6 audio tracks. Add two Aux Sends, creating two Aux Channel Strips and giving a total of 8. Setting up 8 Channel Strips is purely for testing/convenience purposes, matching the number of channels on the Mackie control.

    Open the mixer, ctrl click on each Aux and select "Create Select Arrange Track. Alternatively, select the Aux Channel Strip in the mixer and hit ctrl T.

    The aux channels are now showing in the arrange window and should appear on the Mackie Control. You should see audio tracks 1 to 6 occupying channels 1 - 6 on the Mackie Control, Auxes 1 and 2 are Mackie Channels 7 and 8 respectively. Insert some effect into slot one of Aux Channel Strip one. Now press the "Plug-In" button on the Mackie Control. On Channel 7 you should see "ChEQ" under "Aux 1"- Press the V-Pot and the parameters of the Plug-in should appear distributed over the 8 channels of the LED display.

    If you have more than one effect in an Aux CHannel Strip insert, pressing the Plug-In button a second time will show all the plugins on the Mackie Control LED. Press the V-Pot below whichever Plug-In you want to access and it's parameters will be displayed and can be adjusted as usual. I notice that this does not seem to work if the Aux CHannel Strips are not showing in the Arrange window as described above

    FWIW, I actually never resort to this, I use the Mackie C4, which is brilliant for tweaking Plug-Ins. In fact, I find that using it and listening, as opposed to mousing and watching has a subtle but significant effect on how I perceive or hear what a Plug-In is doing to a sound. It's a very interesting experience ....

    Just FTR, these are the Mackie Control Universal Models, the old, Midi equipped ones, not the newer USB ones, although that should not make a difference as far as their integration into logic is concerned.

    Here are some relevant System Details:

    Logic Pro 9.1.5
    OSX 10.6.8
    MCU, XT and C4, connected through a Unitor 8 Mk II

    HTH, kind regards

  4. paulnajar

    paulnajar Senior member

    Very thorough Mark.

    I'm guessing that what Gareth meant is that when you first open a bus in the mixer an aux is created. This also appears on the MCU. If you try to edit the plugins on the aux via MCU it doesn't work. You just get blank dashes where the parameters would normally be.

    Mark your test worked because you added the aux channels to your arrange track list. THEN it will work, and Gareth this my workaround for your issue.

    It's a shame there isn't a mode where the MCU follows the mixer and not the arrange. As it stands the MCU has full support for whatever you have in your arrange track list. It's really annoying when you're mixing with multi output instruments like Ultrabeat. You end up with two tracks for kick, two for snare etc....

    I've sent several feature requests to Apple regarding this to no avail. Being a lover of my MCU +XT + C4 system I also have a list of other features I wished it had but mainly for the C4.

    Kind regards
  5. paulnajar

    paulnajar Senior member

    PS: Mark we have exactly the same control surface and MIDI interface setup. noice..
  6. mattrixx

    mattrixx Senior member

    Yes, as has already been stated... you need them as part of your arrange. Like Paul says, this is a PITA with multi out instruments, but not too bad with a 30" monitor.
    Now, I wish I could find an old version XT! ... anyone know where I might find one!? :)
  7. garethJones

    garethJones Member


    Thanks for your wonderful and detailed response - a real sign of what a marvellous resource this Forum (and you!) are.

    As Paul mentioned what I am looking for of course is ability to access those AUX plugins without adding the AUXES to the Arrange page. I (sub) route everything to Auxes and in Global View/Aux I can quickly see just my Auxes and it is here that I would love plu-in access

    I appreciate the reminder of the workaround though - and you have inspired me to search for a C4!

    Thanks again
  8. garethJones

    garethJones Member

    Matt - I am still using a small monitor :)
  9. garethJones

    garethJones Member

    Hey Mark

    Thanks for the C4 inspiration. My (secondhand) C4 arrived from eBay today and I cannot believe I have worked all these years with Mackie Controls without adding the C4. Wonderful.
  10. Markdvc

    Markdvc Administrator Staff Member

    Glad you found one Gareth! Looks like I'm on good company with Paul's and your setups!

    I had intended to come back to this topic, as I was in fact able to access plug-ins in the 1st insert on an aux channel strip without having to have the strip in arrange. With more than one plug-in inserted this was not possible, the aux channel strip then did need to be in the arrange window. I'll take another look. I do agree with everyone that it would be a help to be able to access these without having to use the arrange window.

    kind regards

  11. garethJones

    garethJones Member

    Mark - I cannot access (with my Mackie Controls) even the first plugin on an AUX unless it is in the arrange page. How are you doing it?
  12. garethJones

    garethJones Member

    Actually I just checked with my new C4 :)

    I can access the AUX plugins with the C4 whether or not the auxes are in the arrange page, also with multiple inserts. Just not with the Mackie Control or XT.

    So thanks to the discussion of this thread I think I am now happy with this issue because of my new (old) C4.

Share This Page