1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X No MIDI!!

Discussion in 'Logic Pro X' started by Daniel Seguin, Aug 15, 2015.

  1. Daniel Seguin

    Daniel Seguin New Member

    I use Logic Pro X (10.1.1). Since yesterday, none of my MIDI input devices are working in Logic. I tried with Sibelius and the MIDI works as it should. Also, after I try to play notes on my keyboard, I get the beach ball in Logic and I have to force quit Logic. The next time I go to launch Logic, it freezes on launch on; "Updating information on Audio Unit plug-ins...". I've tried connecting the keyboard to different USB ports. I also tried using my MidiSport 4X4 but nothing is working. I reinstalled the drivers for my keyboard (CME UF80) but still... When I launch the Audio MIDI Setup application, it also hangs and I have to force quit that as well!! Any suggestions?


  3. CSeye

    CSeye Senior member


    Troubleshooting tips here:

    Open the MIDI Environment (⌘0). Is there a connection from the the Physical Inputs Sum to the Input Notes Keyboard, to the Input View Monitor, and finally to the Sequencer Input?
  4. Daniel Seguin

    Daniel Seguin New Member

    Hi, thanks for your reply. The connections are there. This is definitely a strange problem. I even tried to reinstall Logic and trashed the preferences but it did nothing. I think I might have to re-install my system!!
  5. CSeye

    CSeye Senior member

    The Troubleshooting tips cover are a good starting point.

    Disconnect your keyboard.
    Start Logic without audio drivers as describe. I would disconnect the audio interface.

    Can you enter MIDI using the Musical Typing keyboard?
  6. Daniel Seguin

    Daniel Seguin New Member

    Hi, yes the Musical Typing Keyboard works!! The MIDI keyboard works if I use Sibelius but not when I use Logic... I checked the environment and the virtual connections are there and everything looks right.
  7. Daniel Seguin

    Daniel Seguin New Member

    When I launch the Audio MIDI Setup App, the MIDI window shows "Loading..." and I have to force quit! I suspect that there is something corrupted with its Preferences or something to do with Core MIDI maybe??
  8. CSeye

    CSeye Senior member

    Disconnect your keyboard controller.
    Navigate to your Mac HD Library>Audio>MIDI Drivers. Copy your drivers to a folder on your desktop. Then Delete the drivers in the library.

    Restart Mac OSX.

    With no programs open, can you now open the AM Setup?
    If so, in the MIDI window, create a New Configuration in the upper left of the window.

    Still Ok?
    You can now drag back into place your keyboard controller MIDI device plugin. Or, use the installer to be sure it's a fresh version.

    Does your controller appear as a MIDI device in the AM MIDI window?
    If so, now open Logic, play some notes.

    Sidebar questions: Your original post indicates the problem surfaced recently.
    Everything working OK prior this?
    If so, what changed???
    Last edited: Aug 16, 2015
  9. Daniel Seguin

    Daniel Seguin New Member

    CSeye, you just saved the day!! It totally worked! I guess the MIDI setup in AM Setup was corrupt somehow. I kept the MIDI drivers of my MBox out of the drivers folder for now (my Focusrite 18i20 is in the shop for repairs since June!!). It could have been those drivers that were corrupt perhaps... Thanks again for your help!!

  10. CSeye

    CSeye Senior member

    Good to hear this issue was resolved! :thmbup:
  11. Eli

    Eli Senior member

    Now I know why you use the handle CSeye. Great sleuthing!
  12. CSeye

    CSeye Senior member

    Hey Eli,

    I'm going to print and frame this one!:thmbup:

    Thank you!

Share This Page