Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Please Help! "Damaged Project"!

Discussion in 'Logic 8' started by mk3, Jun 4, 2009.

  1. mk3

    mk3 Senior member

    Hello, everyone -

    A Logic project now refuses to open properly. Logic immediately gives a "Damaged Project" warning upon attempting to open. If one clicks past this, one is greeted with a further dialogue about "Minor Repairs" with the option to fix. If one fixes, then the project opens with empty tracks. If one chooses not to fix, then the Track Folders appear, and many empty tracks assigned to "no output". The Folders are still empty.

    Nota bene: This problem occurred now that I moved from a G5 (dual 2.3 early 2005) to an Intel Mac Pro (8-core 2.8 2008).

    I have multiple backups of the project. All give the same result.

    Troubleshooting I have attempted:
    - deleted Logic prefs and allow Logic to re-create
    - Disk Utility: repaired all disks, repaired permissions
    - removed ALL plug-ins from the Components folder (System and User)
    - moved project to different drive
    - moved only Logic project file to different drive, without Audio, Bounces, etc; dismount original drive containing all that project data
    - Reorganized Memory
    - stepped all the way back in Undo History (which gave all sorts of errors such as "this track cannot be modified" and "out of memory")
    - tried all backups in Logic's own backup folder
    - tried my own backup versions saved elsewhere

    Result: No luck!

    Fortunately, I still have the G5, so I moved the music drive back into the G5...and the project opened. <insert moderate sigh of relief here>

    The problem is how to make the project work in the Mac Pro, which is now the machine wired into the studio.

    The Mac Pro and the G5 have the same versions of all software:
    - OS 10.5.7
    - Logic 8.0.2
    - MOTU drives (using MOTU PCI-X card in the original Mac, PCIe in the Mac Pro)
    - all plug-ins (irrelevant anyway as the problem persists with plugins disabled)

    Some further comments on this project:
    - It is quite a large project with many audio regions and tracks
    - Could Track Folders be the problem?
    - Other projects, including older ones created in Logic 6 or 7, work fine
    - This project was originally generated from an OMF and SMF exported from DP (as were others that work fine)
    - There are a lot of plug-ins (Kontakt, Arturia, Toontrack, etc), but this should not be the problem as I tested with all components disabled

    This is now a mystery. The most important goal is to transfer a working version of this project to the Mac Pro. Any suggestions on how to save a (simplified? consolidated?) version of the project which would launch on the Mac Pro?

    I searched around the Web for info on this problem. There were some discussions on Apple's site, but no resolutions ever posted.

    Thank you for any help from the experts here...

  3. peterlemer

    peterlemer Senior member

    is it possible that, despite removing all the plugins - the Intel version didn't like having them in the lookup list of the loading song? Have you tried AUManager?

  4. mk3

    mk3 Senior member

    Dear Peter -

    Thank you for the suggestion. I just tried it out. I put the components back in their proper place, restarted Logic, disabled all but the Apple plugs in AU Manager. Quit Logic again and restarted Logic.

    Still the same problem with this project.

  5. mDay

    mDay Member

    ever since switching to an Intel Mac and L8 from a PPC G5 and L7, i've experienced various "Damaged Project" and unexplained crashes. i've seemed to figure out a workaround that works for is unconfirmed by any other user, so maybe i've just been lucky.

    so here it a new project or any project that loads with no problem, then open the "Damaged Project" WITHOUT closing the currently open one. in other words, when it asks you "Do you want to close the current project?" "Don't Close". once the "Damaged Project" opens successfully, close the first one and you should be good. i then save an alternate named version of the "Damaged" one and usually don't have a problem again.

    i really hope this helps....again, maybe i've just been lucky, but it's worked for me everytime. keep us posted. :)
  6. mk3

    mk3 Senior member

    Thank you for the suggestion!
    Unfortunately, it didn't help. I tried both with a brand new blank project open, and later again with an existing undamaged Logic project open. In both cases, when opening the problem project, the same old "Damaged Project! Repair method - Encapsulate/Repair" dialogue appeared.

  7. Colin Shapiro

    Colin Shapiro Senior member

    Hi mk3,

    I seem to recall some folks discussing this kind of problem a while back on the old list. I think there were issues with corrupt Environments involved.

    Check your Environment layers: Are there any duplicate objects or layers? Sometimes these arise from importing objects or layers. (Perhaps delete anything not in use). You may get an alert that some objects are in use, even if they are not - just re-assign the tracks correctly.

    Also clear the Undo History - that can cause problems in some cases.

    Finally, check that you have installed all Pro-App updates on the new Mac.

    Hope this helps.....
  8. Howard W

    Howard W Member

    A few stabs in the dark!

    Does this project's audio files, or the project name use long filenames?
    That would be 30 characters or over. Any of the audio files truncated with a # sign and a seemingly random number?


    If you open the project without effecting repair is there anything visible in the AudioBin? Have you combed this project's environment (on the G5) for any anomalies, objects serving no use and that should not be there.

    Have you tried opening the project with Logic set to the Mac's Built-in-audio


    p.s. I see Colin posted someting about the environment as well, I also have a similar memory regarding a problem in the environment that gave the Damaged Project error.
  9. mk3

    mk3 Senior member

    Good ideas all. I went through each step as you no avail!

    Thank you, though...

  10. mk3

    mk3 Senior member

    I checked the names. There were indeed a few regions with such names. I merged these on the G5 and deleted all unused audio, re-saved.

    Yes, there are audio files visible in the audio bin. But of course they are not in the tracks! The tracks all appear as blank.

    I did also try using built-in audio. No go.

    I suspect this issue is somehow related to either track folders or auxes. This was the first project on which I extensively used folders and routing via Auxes. All other projects transfer fine to the Mac Pro.

  11. leytonnz

    leytonnz Senior member

    seeing as every suggestion is failing id start bouncing out individual tracks on the g5 one by one...using a very methodical labelling system
    id also save channel strip presets for those tracks that need them.
    when finished id save three versions of the project-A without any audio - B without any plugins -C without both
    and see if these transfer to the mac pro
    then start rebuilding the project on the mac pro on a new session if those others dont work

    have you tried opening the project with the audio engine turned off? start logic with ctrl held down
  12. Howard W

    Howard W Member

    The files with the # sign cannot succesfully be transferred to a different drive without causing some problems although it sounds like you now have an idea where the problem is so it's probably not related. Be sure and keep file names under 30 characters, while it shouldn't cause the damaged project error if they're moved to a different drive Logic won't be able to find them and they will need to be loaded manually.

    The audio files are in the AudioBin?? The project doesn't play of course, it's not blank regions, but compeltely blank tracks.

  13. mk3

    mk3 Senior member

    I did try with Control down (Core Audio off) as you suggested. Thank you for the tip...but...No difference.

    At this point I exported the project as OMF, AAF, and SMF, and am about to start reconstructing in a blank template. That's what I call the rock&roll lifestyle!

  14. mk3

    mk3 Senior member

    When I see the stunning understatement of the message "Minor Error in Data", I don't know whether to laugh or cry.

    I would say that losing all tracks of MIDI, audio, and automation qualifies as something more than a "minor error". Of course, in the universal perspective of infinite time and space, this life is a "minor error" as well...

  15. mk3

    mk3 Senior member

    By the way, does AAF only export audio as split stereo? OMF gives an option whether to split or interleave, but the AAF export does not.

    The manual advises that OMF does not export automation, so I assumed AAF to be more useful in this case, as I hope to rescue the extensive volume and pan automation.

    Thank you for any info...

  16. mk3

    mk3 Senior member

    If anyone happens to be interested, I found no solution to this problem. Maybe the following steps will be useful for those who suffer this same disaster.

    I had to rebuild the entire project, as follows:

    - cleaned up the project on the G5 by merging audio in tracks where possible
    - deleted all unused audio
    - On the G5, took screenshots (with Apple Grab utility) of various Arrange windows and mixer windows
    - saved all Kontakt instruments
    - saved Channel Strips of other instruments
    - exported SMF and AAF
    - copied everything (AAF, SMF, Kontakts, Channel Strips) to new Mac Pro
    (I used AAF instead of OMF since AAF transfers automation)

    - created a new project on the Mac Pro from my blank template.
    - NOTA BENE: set the tempo of the new project before importing anything! (I forgot to do this, and worked on clean-up for 3 hours before realizing that all the audio was out of time. Setting the tempo afterwards does not fix this. Apparently AAF imports audio with time-based placement, rather than a more musical measure-based placement. So I had to start over, this time setting the tempo first).
    - Imported OMF and SMF
    - converted split stereo tracks to interleaved (why do they import as split stereo?)
    - reset Channel strips for imported SMF tracks (why do all import with an EXS piano instantiated???)
    - rebuilt routings based on screenshots
    - reorganized order of tracks (they imported completed randomly; no idea why) by instrument types
    - reinstatiated Kontakt plug-ins
    - reloaded Kontakt instruments
    - reinstantiated other instruments from Channel Strip settings copied over
    - re-applied colours to tracks
    - re-named all tracks
    - checked and cleaned up automation
    - rebuilt markers from screenshots
    - set key in global track
    - reset all mixer volumes (approximate, from screenshots; luckily I had not really mixed this project yet, so those volumes were just a sketch)

    Probably a few other steps I can't recall now.

    The entire process took well over 12 hours to complete. This was not fun. To put it mildly.

    I've thus far checked numerous other projects, including older ones which were begun in Logic 7 or even Logic 6, and others imported from DP, and none of those had any trouble loading on the Mac Pro. Just this one particular project. Go figure.

  17. studioj

    studioj New Member

    I ran into this exact same problem last year when trying out L8 for the first time on my dual 2.7 G5. Scary! The only half solution i could find was to immediately start "undoing" (commd z) when the damaged project opened, region-less. Magically, my regions started reappearing one by one. I still lost quite a bit of MIDI but all my audio came back so i got back about a days worth of work that I thought I had lost...but it took me about 3 hours to figure out...

    Its possible that different backups behaved differently with the undo trick, I can't remember.

    I nearly left Logic for good because of this one...don't know why it happens. Definitely stayed away from L8 because of it. I wish apple would check this one out, I sent feedback about it but they have certainly never confirmed it.

    Sorry I'm a little late on this one...don't check the list as often as I used to before the forum switch...
  18. mk3

    mk3 Senior member

    StudioJ -

    Thank you for the reply...

    I did Undo as far back as the history would allow (30 steps), to no avail.

    No worries about lateness. I would hope others who have had similar experiences would also contribute; maybe we can begin to trace down a diagnosis and find a way to avoid such future disasters.

  19. 6xstringer

    6xstringer New Member

    Damage-proofing the workflow

    Does anyone remember the phrase, "Beam me up, Scotty"? The Star Trek Transporter turned people into energy beams, then re-assembled them perfectly on a planet far below, and repeated the process to bring them back - again, in perfect working order!

    Talk about "science FICTION"!!

    The most bulletproof solution that I have found (though it's a bona-fide PIA), is to export or copy-paste MIDI and audio regions out of the older file into a fresh file when transferring from one version of Logic, or from one computer to another. Tedious for sure. Doing sub-mixes can speed the process.

    Logic 8's "Export Track" function can help too - though it does not export the send effects on the signal. Only bouncing does that. For external MIDI instruments, or for external signal processing of tracks within a mix, real-time bouncing of individual tracks is the only solution.
  20. Anonymousdude

    Anonymousdude New Member

    Well, this is the 2nd time i have had this happen to me and i think i know what it is, either one of 2 things (in my case, at least)....

    Both tracks that this happened to had a good amount of midi data, so i think that it is either too much midi for the CPU or what seems more probable is that there are delays and/or reverbs with very long feedbacks...

    I kept having this problem,, that the computer was still processing the feedback although i was out of the region where i had sent the midi data to fade out and quell the long delay. I think that possibly what happens is that it is overwhelmed with data and both times as i went along i was manipulating midi and it just crashed giving me this same error as you guys. I think its running the feedback in the background although i am unable to hear it until i click in a region where the volume is set high enough. I know, this sounds strange, but both times, exact same thing. Scary stuff.

    Im not a programmer, i have no idea why, or how, or if that is the reason, but i was lucky this second time, i immediately bounced the delayed tracks and erased those tracks, then imported them in audio channels, everything seems to be ok, i almost lost a verrrry nice track i have been working on for a long time. And yes i have a back up, but last time i damaged that one as well somehow. Now that everything is working fine on the same project i am convinced that this is the problem in my case.

Share This Page