PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Presonus FaderPort vs. Frontier Design AlphaTrack

Discussion in 'Studio Techniques' started by Beatlefreek, May 31, 2011.

  1. Beatlefreek

    Beatlefreek Member

    What I'm wanting know is how well either one of these works with Logic 9? Has anyone experienced any difficulty or oddities with either one, is one preferred over the other, and of course, if so, why?
    What would be really great is if someone has had the opportunity to A/B these two units.

  3. georgelegeriii

    georgelegeriii Senior member

    I have both, though I've only just got the Alpha track.

    The Faderport doesn't always seem to connect properly, so it appears dead to Logic. Seems like it just doesn't work, and Presonus, while a good company, don't seem to be that concerned to fix the issues unfortunately. If you ask Protools users, they are totally pissed at Presonus, and I'm a bit disappointed that mine doesn't work as advertised.

    The AlphaTrack seems to work, but I can't say until I test it a bit more. I can let you know, I will be doing some mixing with it.
  4. hammertom

    hammertom New Member

    I also have the faderport and it doesn't really work as George mentioned. I've called Presonus support and spoke with them at NAMM and they tried to help me but we never got it to work properly. Really disappointed since it would fill the need if it always worked.
    Doesn't work at all for me when logic is in 64 bit mode.
  5. daveyboy

    daveyboy Senior member

    I have the alphatrack and it works great in Logic 9.1.4 in 64 bit mode. I highly recommend it.
  6. Beatlefreek

    Beatlefreek Member

    Hmmm? From whatever other bits and pieces I've gleened from the net - and now, Daveyboy - Alphatrack seems to be the superior product.
    The Faderport seems very problem-ridden.

    Thanks so far for all your responses.
  7. ChrisByrd

    ChrisByrd Member

    I've had an Alphatrack since November 2008, and it has been excellent with Logic - currently working fine in 9.1.4 in 64-bit mode. I'd also recommend.
  8. innerbeats

    innerbeats New Member

    Workaround for Faderport and Logic 64-bit

    My engineer has discovered that if you set the control surface to "Mackie Designs HUI", and the output port and input port to "Faderport" (which should be available when the device is connected) then most functions appear to work.
  9. georgelegeriii

    georgelegeriii Senior member

    That would be when the Mac sees the fricken thing, which seems to be once out of every 3 or 4 tries.

    Nice that your engineer seems to have one that works, but I can assure you that after working with this device in many modes, and in many DAWS (Logic Protools specifically) over every update where I hope it will work as advertised, it just won't work reliably. I'm sure you will find that I am not alone in my frustration...
  10. innerbeats

    innerbeats New Member

    Still working, after several restarts, uuninstalling, disconnecting etc. But you do have to open Logic in 32-bit the first time to install it, and then open in 64-bit to work as a Mackie Designs HUI. They use the same protocol. Perhaps there are a lot of dodgy units out there?
  11. georgelegeriii

    georgelegeriii Senior member

    It seems to be more that don't work than do. Almost everyone who I have met who owns on, doesn't use it, myself included.
  12. Jarguzzi

    Jarguzzi New Member

    I can´t understand the negative points. I use an Alphatrack since 2 years. From Logic 8 to Logic 9.1.5. Plug-in and works. Every function as described in the manual. I would not give up that tool.
  13. georgelegeriii

    georgelegeriii Senior member

    Faderport is the problem, not the Alpha track, that works fine.

Share This Page