1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Running SoundDiver in a virtual machine

Discussion in 'Music Creation' started by Colin Shapiro, Apr 14, 2012.

  1. Colin Shapiro

    Colin Shapiro Senior member

    [Note to Admin: I didn't know where to post this topic]

    I have finally upgraded to Lion and in the process, have lost SoundDiver which needs Rosetta/OS 10.6.x

    I got VMWare Fusion and installed a virtual machine running OS 10.6
    I installed SoundDiver, which tries to start, but it doesn't find my XSKey. I have installed the XSKey drivers in the virtual machine. Strangely, the VM sees my Unitor 8's but not the XSKey.

    If anyone has any experience with this or could make some suggestions regarding how to proceed, I'd be most grateful.

    Regards - Colin
  3. Orren Merton

    Orren Merton Logic Samurai / Administrator Staff Member

    Hi Colin,

    I moved the thread to Music Creation as SoundDiver was created by the Emagic team, but was never part and parcel of Logic.

    I wish I had a solid answer for you, but you might be looking at the limitations of running SoundDiver and 10.6 in a virtual machine.

    Here's my one suggestion: if you're already running a virtual machine, what about running Windows XP? Perhaps running the Windows version of SoundDiver with the Windows version of the XS Key will work. I don't remember if the SoundDiver CDROM came with both Mac and Windows versions, but I believe that both Mac/Windows versions were updated to the same version number before they were abandoned (not entirely sure thought).

    Hope that helps,
  4. Colin Shapiro

    Colin Shapiro Senior member

    Hi Orren,

    Thanks for the suggestions.

    I don't have any means of installing Windows as I've never used it and don't have the disks. The CD does have installers for both Mac and Windows by the way. I was trying to run the OSX beta version of SoundDiver as the originals need either OS9 or Classic which won't work on my Intel Mac.

    I do have a "legacy" Mac (a G4) which I've kept for....running legacy apps. I know I can run SoundDiver on that machine, but then it's a brain-bender as to how I'd hook up the MIDI, so that both Macs can access my Unitors and hardware.

    The future really isn't what it used to be.

  5. Eli

    Eli Senior member

    I love that line!

    [sorry - I don't have anything to contribute to your problem though]
  6. Doug Zangar

    Doug Zangar Senior member

    This may help....


    The fact the key isn't recognized may not bode well. However, if the key is recognized on the G4 perhaps you could try the updater there.
  7. Colin Shapiro

    Colin Shapiro Senior member

    Thanks Doug for the suggestion.

    I thought I had already installed all the XSkey drivers and updates, but now I'm trying to get help at the VMware forums as I'm not sure if I have indeed succeeded. I'm also trying to update the OS in the virtual machine with no success. (newbie at virtualization...)

    I'll report back.
  8. Doug Zangar

    Doug Zangar Senior member

    Let me know how VMware works for you - I've found version 4 to be a total disaster on my machine - after using it for years. Tech support has not yet resolved the problem.

    I have found that once in a while my ES key isn't recognized and running that program fixes it. I've had to do it two or three times in recent years.
  9. Colin Shapiro

    Colin Shapiro Senior member

    I just got the cold shoulder at the VMWare forums because I'm running a Client version of OSX, which apparently is not allowed, though I bought VM Fusion 4.1 specifically because it was supposed to work with Snow Leopard, which it does. Only OSX Server is officially OK.

    All my PowerPC apps are running so far, but I can't launch SoundDiver because of this XSkey hassle. The update you suggested won't work because it doesn't find the XSKey in the first place.

    I've tried every USB connection on my Mac and there's just no go - System Profiler doesn't even see the key.

  10. Doug Zangar

    Doug Zangar Senior member

    Can you put the key on your G4 and download/run the updater there?
  11. Colin Shapiro

    Colin Shapiro Senior member

    I ran the exact same updater years ago, when it first came out, so I assume the XSkey is updated to the max.
  12. Doug Zangar

    Doug Zangar Senior member

    I guess what I'm trying to say is I have experienced my key to just quit working. Running the updater made it work again. This has happened on more than one occasion. Others have had the same experience. It may be worth a try - think of it as a verifier/fixer, not an updater. I keep the program in my utilities folder as I do need to use it periodically. It's worth a try....
  13. Colin Shapiro

    Colin Shapiro Senior member

    I don't know if it's sunspot activity or what but everything is breaking down here. :brkwl:

    My old G4 wouldn't boot and seems to be dying on me. However, after 2 hours of restarts and disk doctoring, I got it running long enough to run the XSkey updater as you suggested.

    Sadly, it still doesn't work in VMware Fusion.

    I think I'll have to work on another solution. Maybe running SoundDiver in Windows in Fusion....?

    Thanks for the responses and suggestions though - much appreciated!
  14. Doug Zangar

    Doug Zangar Senior member

    Gah! Sounds like a PITA on this project. No problem for the useless tips - good luck on this!

    I've never done the Windows version of SoundDiver - no idea if that would recognize the key. The frustrating thing is you'd think Apple (or whoever owns it now) could afford to make the program no longer require the dongle - it's not a supported product and hasn't been touched in years.....
  15. Orren Merton

    Orren Merton Logic Samurai / Administrator Staff Member

    I'd say go for it. I've run Windows apps under Parallels with great success. I'm guessing Fusion would be much the same. And remember that if Fusion Windows has issues with the XSkey, you can use Mac OS X's built in "Boot Camp" Windows boot software.

    If you don't already own Windows XP (the version I'd recommend running if you're trying to get SoundDiver running, since SD was developed before Windows 7), you can buy an OEM version on eBay very, very cheap.

  16. Colin Shapiro

    Colin Shapiro Senior member

    Huge yes to that. Apple should release the source code of SoundDiver - they're doing bugger-all with it and they won't acknowledge that users are out there and still using hardware.
  17. Colin Shapiro

    Colin Shapiro Senior member

    Good point & thanks for that tip Orren - I'll certainly check it out.
  18. Haswell Dekatron

    Haswell Dekatron New Member

  19. Colin Shapiro

    Colin Shapiro Senior member

    Thanks for posting that link.
    However, if MIDI doesn't work, then it's useless for me. I can still run SoundDiver from an OS 10.6 partition, but I was trying to avoid rebooting.

    If I get a chance, I'll try those instructions to see what happens here....
  20. topaz

    topaz New Member

    Hi , this a long shot but I have been hunting high and low for the last soundiver Mac, I have an xskey so would love to try it.

    I have a TR-Rack that needs some editing.


Share This Page