PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Sculpture & Ultrabeat Missing in Logic 10.2.3

Discussion in 'Logic Pro X' started by Bhang, Jun 27, 2016.

  1. Bhang

    Bhang New Member

    I have been trying to figure out why Sculpture and Ultrabeat are not showing up in my version of Logic X. I tried re-installing and checked with the AU-manager ( which doesn't seem to help for Logic native plugins) to no avail. I know that Logic selectively shows only plugins that can be used in a particular track type, but, this also does not seem to be the issue. It just simply is not showing up although it is listed in the AU manager. I suspect I'm missing something very simple here, but I can not for the life of me figure it out. Any help is much appreciated!
  3. Bhang

    Bhang New Member

    Sorry for the reply. I don't see any way to edit my post: I wanted to add this little bit of info about my issue.
    I also have Logic 9, so I created a session with Sculpture and Ultrabeat. Saved it and then opened it with Logic 10. Sculpture and Ultrabeat show up fine, but even when I open the Instrument selection menu for the track that has sculpture or ultrabeat in it, neither plugin shows up in the menu. What's going on here? Any ideas anyone?
    Thanks ahead of time for your help.
  4. Bhang

    Bhang New Member

    Easy solution. I tried Reset & Rescan Selected in the Plugin Manager and that didn't work. However, Restore Default Settings did the trick.
    bambony likes this.

Share This Page