Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Strange Tap-Tempo behavior!

Discussion in 'Logic Pro X' started by airforceguitar, Jul 10, 2015.

  1. airforceguitar

    airforceguitar New Member

    Fellow LPX Afficianodos,

    I have been trying to use the "tap-tempo" feature to set the initial tempo in my new projects, but experiencing some strange effects. I set a key command to enable tap-tempo (external sync) but after it sets the tempo and displays it in the transport bar, the playback is irregular. The time between beats one and two of my project are different! No changes in the tempo map, but it's obvious that Logic is not "finding" the tempo from the start. What's worse is that I recorded several takes of parts to the metronome and the alignment is almost a half-beat off!

    I know that my time isn't perfect, but this was WAY off! Am I missing something?
  3. airforceguitar

    airforceguitar New Member


    After some experimenting, I found that after you use the "tap-tempo" command, it displays correctly in the transport bar, and will play at that tempo after the 5th tap (for MIDI at least, I know that audio must be stretched/compressed), BUT IT DOES NOT UPDATE the musical grid in the main window. As soon as you stop the playback and restart the playback the old tempo is resumed. I found by clicking and highlighting the tempo display and then hitting 'enter', Logic accepts the new tempo and plays correctly.

    I suppose this falls under "feature, not bug", because it allows you to audition new tempos without committing to them. I just wish that the manual would say that. Also, it requires extra steps to set the tempo (stop playback, highlight tempo, hit enter). If anyone out there knows a better way to do this please let me know. [​IMG]
  4. Peter Ostry

    Peter Ostry Administrator Staff Member

    First ...
    I always found the Tap Tempo feature of Logic unreliabe, although I had some success in the past with recording audio while tapping. Maybe I'm wrong, but I have the feeling that Tap Tempo worked better in former versions. To find out what your problem could be, I tried to tap in Logic 10.1.1. and it worked. Then I tried a second time and could not make it work again ...

    Basically the Tempo Interpreter must be set to support the kind of tapping you want to do, otherwise it does not work at all or the tempo might jump widely. Often the tempo track needs some correction.

    What you are you trying to do? Usually Tap Tempo records the tapped tempo to the global tempo track. There is no choice to find or not to find a tempo, miss beats etc. Logic simply runs with the tempo that the tempo track dictates. If you do not see varying tempo information in the tempo track, you did not record it.

    If you expect something like beatmapping (getting the tempo from a series of taps in a region), you should use beatmapping. The Tempo Interpreter ist rather "manual synchronization".

Share This Page