Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Sudden problem with MIDIServer - Help!

Discussion in 'Logic 9' started by starobin, May 17, 2012.

  1. starobin

    starobin New Member

    I'm having a sudden MIDI problem.

    Whenever I launch Logic, the MIDIServer starts going crazy in the Activity monitor. Soon as my file opens (or a new file) the MIDIServer starts using over 100% of the CPU. The Activity Monitor will not let me quit (or force quit) MIDIServer. If I force quit Logic, the MIDIServer continues using 100% of the CPU. I can't shutdown or restart the computer without powering off.

    This is not happening with other software using MIDI, just with Logic.

    Logic (9.1.7)
    OSX Lion (10.7.4)
    Mac Pro (2 x 2.66 GHz Dual-Core Intel Xeon)
    RAM - 16 GB 667 MHz DDR2 FB-DIMM
    NO MIDI INTERFACE, just a M-Audio Keystation 88 (USB)

    - I have tried trashing all of Logic's pref files and any pref files I could find for Audio-Midi Setup. No help.

    - I have disconnected the USB hub I've been using. No help.

    - I tried running Logic in a different user - same problem.

    - I am running various pieces of software like QuicKeys and LaunchBar. But these have never caused a problem, and are presently working with Logic on a Mac Mini with no difficulty.

    Any help would be greatly appreciated.

    Michael Starobin
  3. georgelegeriii

    georgelegeriii Senior member

    There is a free app called "midi monitor" you can grab. It will attempt to monitor any midi data your system is seeing in the inputs through your OS and computer/interfaces.

    I'd suggest downloading it and running it to see if you find a bunch of info being generated. If so, I'd track it down by removing things from your system one by one, including software added to the system.

    Some things to try: make a new user in your computer (Preference pane "Users and Groups") make a new user, and see if you still have the issue when you boot Logic.

    Also, head into your library folder / audio / midi driver, and see if something is in there that shouldn't be or could be causing the issue. Try moving any drivers to the desktop, restart your system, and see if the problem still exists.

    Let me know what happens when you try these suggestions...
  4. starobin

    starobin New Member

    George -

    Thanks for your suggestions - they were very helpful.

    I actually disconnected all hardware except for mouse and computer keyboard and added things back one by one. I discovered it was an old Edirol Firewire interface I was using just to bring in the audio from some outboard gear - which I'm not really using anymore, so it was easy to just eliminate it.

    A much easier solution than the Digital Performer midi burps that finally made me abandon DP!

    Again - thanks for your suggestions.

Share This Page