Hey Folks, My first post to you. Apologies if this has been asked but I didn't see it. Since I'm running an older Snow Leopard 10.6.3, I was under the impression that I needed to look for Logic 8 rather than 9, based on the system requirements I read on the Apple site (10.6.8). Then, I came across this awesome group and its FAQ on Logic 9 and saw that minimum is considered 10.5.7 with a link in that sentence to Apple's site, where it shows the same 10.6.8 requirement. Can someone sort out? Thanks!