PT Logic
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic Studio apps Using Loopback Live w/o Sync

Discussion in 'MainStage' started by CPWhite, Mar 24, 2010.

  1. CPWhite

    CPWhite New Member

    I'm trying to set up Loopback in Mainstage 2 to do live looping without syncing to a tempo. I have sync disabled, fine, I have a FCB1010 with the UnO chip programmed and stomp boxes mapped to the Play, Stop and Rec transport buttons, and all that is working. I start playing my instrument then when I'm in the groove I hit the record footswitch and Loopback starts recording. Except, it doesn't start right away. The delay might be small or quite significant but other than looking at the waveform display, there's no indication that it isn't recording yet. So it doesn't "keep up" with what I'm playing because it doesn't start when I hit the record foot switch. by the way, the panel indicator lights as soon as I press the footswitch. I have a MBP 2.53 GHz which is almost brand new so lot's of disk space. I'm using a Echo Audio AudioFire4 with a 128 sample buffer for 11.9ms latency. This delay is way more than 11.9ms. I have even tried playing against the click and it's not me, it's the machine.

    Anyone run into this?
  3. Robert Wilson

    Robert Wilson Senior member

    I had similar problems and gave up trying to use Loopback because of it.
  4. CPWhite

    CPWhite New Member

    I did find that if I import a 'click track' of some sort, start it playing (it will not start the instant I hit the play button. Same delay source I'm guessing) then I can add to it by hitting record at some point. It's all about the start. Maybe what Apple needs is an Arm function which will prepare the looper for action and then when you hit record it will start instantly.
  5. CPWhite

    CPWhite New Member

    I read somewhere unrelated to this issue, that Loopback always starts on "1", of some internal metered clock. This is why the start time is so variable. To prove this I set a really high tempo and there was more consistency, because '1' came around quicker. I sure hope Apple fixes this soon because to me it makes Loopback worthless for truly live looping applications. My cheap little Boss RC-2 does a better job.
  6. gtodd876

    gtodd876 Member

    Yes you have to stop Mainstage's Beat Clock AS WELL as the stop button on loopback. When your stopping loopback the beat clock is still running and it is waiting till you get back to beat 1 to start up again. You can view this by adding some parameter text to your layout and linking it to the beat clock.

  7. CPWhite

    CPWhite New Member

    Stopping Main Clock

    Thanks. That helps quite a bit, although the short drop out as the clock starts when starting to record in Loopback is annoying. I connected the MIDI foot switch I connect to Loopback play/stop to the Main Clock play/stop. I have another MIDI foot switch connected to the Record function on Loopback which starts things. It seems as though the two play/stop functions gets out of sync on occasion so I added a button on the front panel which stops the Main Beat Clock.

    I think the current Loopback app with this 'fix' is OK, but I'd still like to see a simple looper, perhaps multi-track, that is not tied to the beat clock, or an option to disconnect the current looper from the beat block.

    Thanks for your help,

  8. gtodd876

    gtodd876 Member

    No problem. I found all of this frustrating as well so I don't use loopback now for looping. I use a third party plug-in called Mobius..... although on my new Macbook pro with snow leopard Mobius is not passing au validation. That and Mainstage now asking for my serial everytime I fire up the program is killin' me ! :) Hopefully we will be loopin' soon.....
  9. CPWhite

    CPWhite New Member


    I downloaded Mobius but couldn't figure it out in a short period of time, and couldn't figure out how to integrate into Mainstage. I know it is intended to be simple, and I applaud that, but it looked too cheap to trust and wasn't worth my time.

    Maybe next revision they'll improve it.
  10. Brooklynite

    Brooklynite New Member

    actually it's pretty trust worthy, but really complicated to set up.
  11. Brian Stone

    Brian Stone Member

    Though it doesn't pass AU Validation? hmm..
  12. Brooklynite

    Brooklynite New Member

    Not that I'm an expert, but I have a fair amount of experience trying to loop w/ a laptop. So far my best results for stability, timing and actually working with out audio artifacts have been with Mobius. It's so complicated to set up that I have avoided some things I know it can do b/c I can't figure it out in an hour or two.
    I know there are ppl do it with ableton using tracks, but I think we are talking here about doing it on the fly, with out setting up a bunch of tracks ahead of time. I love Expert Sleeper's tape loop plugin, but last time I tried it is was crackling as a looper. I should check back with it.

Share This Page