1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Would someone shoot me please?

Discussion in 'Logic 9' started by David51, Oct 15, 2010.

  1. David51

    David51 Senior member

    Embarrassing but I find I have to ask How can I hear the MIDI input in play mode? A simple question from a simple person, thanks in advance.
  3. Multispace

    Multispace Member

    Don't really understand your question. What do you mean by hearing the MIDI input? The MIDI that's coming in in Logic is directed to the selected track in stop, play and record-mode.
  4. georgelegeriii

    georgelegeriii Senior member

    For starters, you should make sure you have a midi or VI track selected, and your midi device or VI instantiated and ready to go.

    Next, select the track you wish to "play" with.

    the record button will turn red when you play a note on your midi controller.

    One thing that is very important: make sure "software monitoring " is enabled in your audio preferences.
  5. David51

    David51 Senior member

    Multispace-Thanks for helping, I can't hear that MIDI input that I am playing[practicing] to record later so I can hear the other tracks and play along. George, thanks a lot, I have been reading the manual and it claims I should be able to hear the incoming breath controller MIDI even in play mode I have software monitoring on but not the yellow input button on the track header, should that be on too? The track is selected-otherwise I wouldn't be able to read in page view the solo part I want to record first. I do of course use a score editor from the drop down windows menu it seems to be a floating one which is very handy when doing this. I can see the MIDI in on the transport bar but no sound comes out. The part is in the score so I do hear the sequencer metronomically[no music there] playing back the part I want to record myself, to add "musical' breathing pauses and phrase pauses and tempo rubato tempo changes-too much and too detailed for the sequencer to do with track automation.
  6. georgelegeriii

    georgelegeriii Senior member

    You would still require midi input enable on (the red record icon).
  7. David51

    David51 Senior member

    Thank you George for replying[apparently in the middle of the night]. I didn't see that in the manual but I think you know better than me how logic works, so I will try today with the record enable button on and I hope that means the track won't be bounced unless I hit the record button, I do remember that. I think. There remains one mystery to me-that area of the transport bar has eluded me in the Manual; what do the NO INPUT NO OUTPUT signs mean? the incoming midi shows up in the NO INPUT, the NO OUTPUT doesn't change.
  8. marksealey

    marksealey Member


    Make sure that the 'R' icon in the Track Header (to the left of the Track itself, near 'M' and 'S' etc) is clicked on once and thus red.

    You won't actually commit anything to recording until you click the Record icon in the Transport Bar, but will be able to hear your MIDI events (notes) as you Play.

    You have tested your MIDI device in the Utilities>Audio and MIDI Setup, haven't you?

    Good luck!
  9. David51

    David51 Senior member

    Mark, Thank you for the help I appreciate all the help I can find. Plus I have developed a bad habit of turning off those auto record enable buttons out of fear that I will lose yet more MIDI events, they seem in my hands to have a life of their own, I wish them well but I would really rather make a little music. I will stop that. My MIDI Devices all worked well until a few months ago when the AMS stopped saving it's settings, then I got control back from the AMS, now it seems that even trashing the pref for the audio and for the Aggregate device doesn't help. I wonder sometimes if Logic is using some pref that's in the trash, so I changed the name by one letter and the AMS still doesn't want to remember it's settings. I am now going to trash the AMS settings and use the Edirol UA-25 Audio/MIDI interface hardware with new drivers,thanks to you and all the others here I believe it will work, you answered the last doubt I had ans I am grateful for that. So, thanks to you all,happy music making!
  10. marksealey

    marksealey Member


    Sorry that you're experiencing so many difficulties.

    Could it be something more fundamental than merely a Logic setting?

    System or hardware-wide?

    Good luck!
    Don't forget that you can always undo actions with CTRL-Z (to bring back 'lost' MIDI events).
  11. David51

    David51 Senior member

    Wuld someone shoot me please?

    Thanks Mark, I have the great fortune to have a nephew in Houston who repairs Mac's so I know how much re-building a Hard Drive can help. He recommends an app called Disk Warrior that makes a copy of the drive then makes a new 'build' or configuration of the contents and presents you with both in a large window. You can try out fixing things and the new build is in my case always better, and smaller[my bad]. I will post here the result after re building the HD.

    As for MIDI files, they can become corrupted too, this happens to mine in Logic quite often and cmd-z won't fix them, but I have exported MIDI files many times and they where OK. These project files are easy to rebuild in the score.
  12. marksealey

    marksealey Member


    Disk Warrior doesn't work exactly as you say; but is a worthy and utterly reliable utility. In fact its most useful routine is to repair and compact damaged disc directories (the indexes that tell your HD where to look for files). Yes, get it and use it judiciously.

    But it sounds as though you may have other faults with your system. I hate to say it, but maybe consider setting aside some time for a complete system re-install and then introducing the apps you have and love one by one.

    Suggest trying to avoid those cute little system 'add-ons' (aka haxies) which… rotate the dock in psychedelic colours (!) or allow you to launch one app from within another using the 'escape' key etc :)

    Good luck.

Share This Page