Logic Pro 9 9.1.1 64-bit and MOTU midi?


Is anyone successfully running a MOTU MTP AV setup with 64 bit Logic? How about in 9.1.1? [Snow Leopard up to date on all software updates]
I've tried it and on m system at least, Logic does not pick up the MOTU midi interface. I've downloaded and installed the latest from the MOTU web site, which claims 64-bit compatibility. And all looks well in Audio-Midi setup, including assignment of names to used i/o port connections...
Note it all works in 32-bit.

Another quirk, at best distantly related, Logic 9.1.1 does not seem to pick up MOTU channel names from a (configured and working in 32-bit) PC424/2408 setup.

Can anyone confirm these problems, or provide a counter-example that might suggest where I could dig in and try other things?

Few more tidbits fwiw -- Play seems to run fine in 32-bit bridge mode -- I get sound when using the plug-in's controls. Likewise for all the connected midi gear -- it provides output and the output is recognized by Logic's audio inputs. Monitors on pre-built environments show midi coming in and passing all the way to the sequencer input. The transport shows midi incoming. But the MOTU units never indicate midi output and no sounds are ever produced at the targets...
dang, and I was so exited to see the Euphonix 64 bit support, which I had thought to be my last stumbling block prior to the 64-bit cut-over ;-\ ]

Another quirk, at best distantly related, Logic 9.1.1 does not seem to pick up MOTU channel names from a (configured and working in 32-bit) PC424/2408 setup.

I had the same problem !!:brkwl:

- I downloaded the new PCI driver
- Launch my configuration in Motu PCI audio setup
- save it as Motu PCI config on the desktop

and now I have the names back into Logic


Upvote 0
Thanks, Cyril, I'll try that and post results later today.
I've done more exploring of the issue, and it is decidedly confusing!
If I launch Logic in 64-bit mode with an existing project as the 'current' (the one that opens by default as 'last used' or however Logic wants to name it).
Voila, the midi interface is there, all looks well. But no midi is passed through.
If I then create a new empty project (regardless of whether I close the existing one or not), I only get a GM device and no midi interface.

I'm now wondering if the problem might be the existence of the Euphonix mc mix -- in 32 bit mode it presents 4 midi ports that come before the 16 from my MTPs. They, of course, do not show up any more than the motu ports do in 64 bit mode...
I'm going to try some permutations to see if this can be narrowed down. Results later today.

Upvote 0
Thanks again, Cyril -- your "trick" worked fine for bringing the audio io names into Logic.
I tried the same thing with Clockworks for the midi but it didn't help (not surprising, really).
As nearly as I can tell at this point, Logic is connected at least partially to the MOTU.
If I launch with a working 32 bit or create a new project, go to clicks and ports, and create some monitors, I can connect the port for a given controller to a monitor and see the input data. Further confirmation is that upon connection the data coming in from a port disappears from 'sum', as it should.
But the connection must be only partial because no midi is ever output from Logic, as verified by the lights on the mtp's and the silence of the target synths (and their midi in lights when present).
Shutting down the Euphonix does not seem to have any impact. In fact, the 4 euphonix midi ports appear to be present as the first 4 below the 'sum' output of the physical input. Labels from audiomidi setup do not appear.

OK, final test. Close the project and create a new project from the template saved and used in 32 bit mode (and that has been the basis of my day to day work). Logic complains about sends to midi ports that no longer exist/are not connected. Yet no complaint is made when launching Logic if the 'current project' is based on that same template. That's the one that displays the monitor behavior described above.

So, any ideas? Anybody else using 2 mtp's (and maybe a euphonix mc mix) plus 9.1.1 in 64 bit mode? If so, chime in with your experience!

Meanwhile, I'm back to 32-bit mode for a while longer.

Upvote 0
Update after further tests and research:
The issue is due to a conflict between the Euphonix drivers and the MOTU drivers.
MOTU/Logic/Euphonix fails to recognize midi ports for either a dual MTP AV or Express 128, identically on two entirely different Macs (8Core Xeon/dual core iMac)
MOTU/Logic performs find on both machines for both interfaces if and only if Euphonix control is uninstalled.
The failure mode is perfectly correlated to the installation of the Euphonix software. Re-installation of the MOTU drivers after install of the Euphonix drivers does not help.
Uninstall of Euphonix reliably restores midi for Logic 64 bit.

I've raised the issue with Euphonix and will be reporting to MOTU today.
Meanwhile, all continues to work fine in 32 bit mode.
But at least I'm confident now that this is not a Logic issue but a contention between drivers from Euphonix and MOTU.

If anyone can report success with both a Eupyonix MC MIx and MOTU midi drivers, please let me know, this may provide information to help find and fix the incompatibility.

Upvote 0