Logic Pro 9 Annoying click sounds at the start of midi notes?


New Member
Hi there,
I've just splashed out on the east west quantum leap composer's edition, mainly for the piano, orchestral and world instruments. Everything seems to be working fine with the exception of a few sample heavy instruments like the pianos of the Gold library. While I can load and play them mostly fine, I do get regular, very annoying clicking sounds at the start of some notes. When I then play those midi sections back the clicks are still there, although they seem to be occurring in different places each time. If this could be solved by bouncing the tracks, I wouldn't mind but every time I do bounce to audio the clicks are just as present on the bounce as well (I should add that the samples are on an external drive, connected via firewire 800).
Even though the pianos seem more cpu heavy than other instruments, I've been monitoring the cpu levels and they aren't exceedingly high. I've also increased the buffer size to no avail.
I'm running a Macbook Pro (2.33 Intel Core 2 duo processor) 15inch with 3GB of RAM. Could this purely be a lack of RAM or are there any other possibilities? As I am maxed out on RAM I would just like to check all other options before I'd have to consider investing in a new computer!

If you have any pointers, your help would be much appreciated - many thanks!



I would max out your ram and run Logic 9.1.5 in 64 bit mode. Also, there's a new play update as of this last week I believe. Also, when mixing raise your audio buffer to 1024. I still get random pops but mostly when I use a waves plugins or ampitube 3.